MyDomoticz - Testers wanted!

On various Hardware and OS systems: pi / windows / routers / nas, etc
modF
Posts: 3
Joined: Wednesday 08 August 2018 19:34
Target OS: Windows
Domoticz version:
Contact:

Re: MyDomoticz - Testers wanted!

Post by modF » Tuesday 21 August 2018 17:52

I am still having this same issue even after grabbing today's 4.9917 version. I believe I have tried just about everything I can think of short of uninstalling and removing everything, I would really like to not lose the last couple years of data. If anyone has any suggestions please tell! :)

User avatar
chimit
Posts: 284
Joined: Saturday 18 April 2015 18:55
Target OS: Raspberry Pi
Domoticz version: master
Location: Rotterdam, the Netherlands
Contact:

Re: MyDomoticz - Testers wanted!

Post by chimit » Friday 24 August 2018 12:00

tgg3 wrote:
Thursday 21 June 2018 6:37
If I login with my vanity hostname I see a blank page with only the colored background. I don't even get to select an instance. This worked previously.

Logging into www.mydomoticz.com works correctly.
When you log in with your vanity hostname, you will be directed directly to the Domoticz screen. There's no instance selection, since you already do that by choosing the hostname.

User avatar
chimit
Posts: 284
Joined: Saturday 18 April 2015 18:55
Target OS: Raspberry Pi
Domoticz version: master
Location: Rotterdam, the Netherlands
Contact:

Re: MyDomoticz - Testers wanted!

Post by chimit » Friday 24 August 2018 12:02

Tmaster2018 wrote:
Friday 29 June 2018 17:51
NOT ANYMOre!

It is related with release of Domoticz new version?

can we do something about that?for example de paid/donate version don't have this long failures?

I know i still on free version :oops: ,but just to understand what happens :mrgreen:
To the people that were experiencing mydomoticz being intermittently offline.
I've been working for the past week or so on fixing this. I think I got it now. It took a bit because of the holidays as well.
But mydomoticz should be more infrequent offline since now.

User avatar
chimit
Posts: 284
Joined: Saturday 18 April 2015 18:55
Target OS: Raspberry Pi
Domoticz version: master
Location: Rotterdam, the Netherlands
Contact:

Re: MyDomoticz - Testers wanted!

Post by chimit » Friday 24 August 2018 12:05

modF wrote:
Wednesday 08 August 2018 19:50
What is the correct procedure for removing an instance ID from my local installation on Windows? In another location, I have a raspberry pi connected and functioning, but I can't seem to get my windows version connected to MyDomoticz. I keep getting the error of invalid credentials for this instance/api. I know they are good, so I tried to get a new instance ID and this one will not go away. I've tried removing all of my credentials from the settings page, enabling/disabling, restarting, upgrading to the latest version. The instance ID on the windows one is the same one that has been there for at least a year or more.
If you like, PM me your api key and instance key so I look into your matter.

User avatar
chimit
Posts: 284
Joined: Saturday 18 April 2015 18:55
Target OS: Raspberry Pi
Domoticz version: master
Location: Rotterdam, the Netherlands
Contact:

Re: MyDomoticz - Testers wanted!

Post by chimit » Friday 24 August 2018 14:39

MobileDomUser wrote:
Wednesday 11 July 2018 22:17
Lately I have been having issues connecting to mydomoticz.com, my instance is showing offline now. I think this may be a symptom:

Code: Select all

2018-07-11 16:03:18.872 Accepting shared server connections via MyDomotiz (see settings menu).
2018-07-11 16:03:18.886 Active notification Subsystems: email, pushbullet (2/13)
2018-07-11 16:03:18.869 Status: Proxymanager started.
2018-07-11 16:03:20.991 Status: PROXY: Authenticate result: Disallowing due to maxinstances (2725773122DF087)..
I have tried enabling and disabling in MyDomoticz settings of the settings page multiple times, tried removing my instance with it disabled several times (each time I get "Cannot delete while the instance is online"), making sure the Rpi3 this runs on is up-to-date, etc.

Is it possibly a server-ralated issue, it seems there was a similar issue reported in viewtopic.php?t=7764&start=60#p68702?
By chance I caught this one in the server code. One also got this error message erroneously when a whitelist ip was entered and the domoticz connected from a different ip.
This caused a lot of confusion as well. A fix will be put online in the next release, within a day, more or less.

Rene

gcoupe
Posts: 158
Joined: Saturday 24 January 2015 15:43
Target OS: Raspberry Pi
Domoticz version: v4.9700
Location: The Netherlands
Contact:

Re: MyDomoticz - Testers wanted!

Post by gcoupe » Sunday 09 September 2018 13:34

Is there some reason why the incorrect URL is given for the MyDomoticz service in the Wiki pages? It gives https://my.domoticz.com/ as the URL in at least two places instead of http://mydomoticz.com/ (using my.domoticz.com gives a "site not found" warning, and using https://mydomoticz.com gives a security warning...)

Cees
Posts: 8
Joined: Sunday 10 May 2015 16:01
Target OS: Windows
Domoticz version:
Contact:

Re: MyDomoticz - Testers wanted!

Post by Cees » Sunday 09 September 2018 13:41

Thanks for the info.. I didn't know it changed.(did it?)

https://my.domoticz.com was working until a few days ago (Maybe a week)..
Maybe it's an idea to make a redirect from the old URL to the new URL?

(For now I am not even will try to login on the new URL until I know for sure it is legit)

mirikbb
Posts: 3
Joined: Wednesday 12 September 2018 14:15
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MyDomoticz - Testers wanted!

Post by mirikbb » Wednesday 12 September 2018 14:24

Hello,
while activating mydomoticz, (together with creating account etc...) in Domoticz settings, I can't get Instance ID and can't see any Domoticz instance in web my.domoticz.com dashboard.
It looks like that the https://my.domoticz.com doesn't work/ is stopped. I used non secured version of web page http://my.domoticz.com to create account and check web dashboard, but apparently the Domoticz application is communicating with my.domoticz over secured https only.

Please, is there running any maintenance on the https web server, or is it turned off for a reason, or permanently?

Thank you.

Ignacio
Posts: 3
Joined: Sunday 12 February 2017 19:10
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MyDomoticz - Testers wanted!

Post by Ignacio » Saturday 15 September 2018 20:25

Currently i am not able to connect my systems neither using https://my.domoticz.com/ nor http://my.domoticz.com/ . Fortunately I still can connect using Dataplicity service and Wormhole.

tomchees
Posts: 2
Joined: Wednesday 27 June 2018 15:07
Target OS: Raspberry Pi
Domoticz version: 4.999
Contact:

Re: MyDomoticz - Testers wanted!

Post by tomchees » Wednesday 19 September 2018 12:52

I can also confirm that https://my.domoticz.com is not responding.
On the other hand I'm able to log in to non-secure http://my.domoticz.com and see instance of my system online can't go any further than this (e.g. see the dashboard).

Tomasz

modF
Posts: 3
Joined: Wednesday 08 August 2018 19:34
Target OS: Windows
Domoticz version:
Contact:

Re: MyDomoticz - Testers wanted!

Post by modF » Thursday 27 September 2018 16:01

chimit wrote:
Friday 24 August 2018 12:05

If you like, PM me your api key and instance key so I look into your matter.
Thanks, I will as soon as I can PM :)

magicsam
Posts: 3
Joined: Friday 26 October 2018 11:56
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MyDomoticz - Testers wanted!

Post by magicsam » Friday 26 October 2018 12:10

Since a month or so I'm experiencing issues when trying to access http://my.domoticz.com

When trying to login with email/password I often get the message "Invalid login".
I did reset the password several times now and directly after I can login. But once I close the browser or try another device, I get the same Invalid login message.
If I manage to login, I see my instance online but can't go any further than this.

I hope there is some advise on how to resolve these issues!

User avatar
chimit
Posts: 284
Joined: Saturday 18 April 2015 18:55
Target OS: Raspberry Pi
Domoticz version: master
Location: Rotterdam, the Netherlands
Contact:

Re: MyDomoticz - Testers wanted!

Post by chimit » Friday 26 October 2018 12:40

This may happen due to page caching.
Sometimes it helps to refresh the page (press F5) before logging in after loading the page.
It's a known issue.

== Rene
magicsam wrote:
Friday 26 October 2018 12:10
Since a month or so I'm experiencing issues when trying to access http://my.domoticz.com

When trying to login with email/password I often get the message "Invalid login".
I did reset the password several times now and directly after I can login. But once I close the browser or try another device, I get the same Invalid login message.
If I manage to login, I see my instance online but can't go any further than this.

I hope there is some advise on how to resolve these issues!

User avatar
chimit
Posts: 284
Joined: Saturday 18 April 2015 18:55
Target OS: Raspberry Pi
Domoticz version: master
Location: Rotterdam, the Netherlands
Contact:

Re: MyDomoticz - Testers wanted!

Post by chimit » Friday 26 October 2018 12:44

Some background history:

my.domoticz.com is the legacy host name and still works, besides at times a bug I'm hunting since a long time already pops up.
mydomoticz.com is the same page. This domain was registered to enable the vanity hostnames (e.g. micasa.mydomoticz.com).

Both are served on a different ip address (and thus a different server instance), hence the reason why one of them works and the other sometimes doesn't.

== Rene
gcoupe wrote:
Sunday 09 September 2018 13:34
Is there some reason why the incorrect URL is given for the MyDomoticz service in the Wiki pages? It gives https://my.domoticz.com/ as the URL in at least two places instead of http://mydomoticz.com/ (using my.domoticz.com gives a "site not found" warning, and using https://mydomoticz.com gives a security warning...)

diogoc
Posts: 12
Joined: Monday 30 July 2018 12:20
Target OS: -
Domoticz version:
Contact:

Re: MyDomoticz - Testers wanted!

Post by diogoc » Friday 26 October 2018 13:09

I can login and see that my domoticz is online, but when I enter It shows the domoticz offline page

Cees
Posts: 8
Joined: Sunday 10 May 2015 16:01
Target OS: Windows
Domoticz version:
Contact:

Re: MyDomoticz - Testers wanted!

Post by Cees » Friday 26 October 2018 16:31

I can login (https://mydomoticz.com/mydomoticz/dashboard), see that both instances are online but when I click on one of them I get a 500 error
Is it only me?

Supplement:
There is a difference between the "https" and the "http" version.

Over "https" Gives a 500 error (on Windows 10 en Pi).

Over "http":
- On Windows 10 machine: loads some elements but blocks most (the missing elements are automatically loaded over "https" and give a 500 error)
- On Pi, it just shows "DOMOTICZ OFFLINE"

magicsam
Posts: 3
Joined: Friday 26 October 2018 11:56
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MyDomoticz - Testers wanted!

Post by magicsam » Monday 29 October 2018 14:57

Thanks for the advise, indeed after refreshing the page I now managed to login!

Unfortunately my Domoticz instance is now showing as offline. Rebooted my Raspberry Pi and Router just to be sure, but that didn't help.
Domoticz itself works fine within my LAN and no configuration changes were made.

Do you have any idea what might cause it to appear offline and how to resolve this?
chimit wrote:
Friday 26 October 2018 12:40
This may happen due to page caching.
Sometimes it helps to refresh the page (press F5) before logging in after loading the page.
It's a known issue.

== Rene
magicsam wrote:
Friday 26 October 2018 12:10
Since a month or so I'm experiencing issues when trying to access http://my.domoticz.com

When trying to login with email/password I often get the message "Invalid login".
I did reset the password several times now and directly after I can login. But once I close the browser or try another device, I get the same Invalid login message.
If I manage to login, I see my instance online but can't go any further than this.

I hope there is some advise on how to resolve these issues!

User avatar
chimit
Posts: 284
Joined: Saturday 18 April 2015 18:55
Target OS: Raspberry Pi
Domoticz version: master
Location: Rotterdam, the Netherlands
Contact:

Re: MyDomoticz - Testers wanted!

Post by chimit » Tuesday 30 October 2018 0:29

Currently there's been work going on, on MyDomoticz in order to make it more stable for everybody.
Unfortunately this means occasional restarts of the service and sometimes new bug fixes don't work out like they are supposed to do.
We appreciate everybody's patience on this.

== Rene
magicsam wrote:
Monday 29 October 2018 14:57
Thanks for the advise, indeed after refreshing the page I now managed to login!

Unfortunately my Domoticz instance is now showing as offline. Rebooted my Raspberry Pi and Router just to be sure, but that didn't help.
Domoticz itself works fine within my LAN and no configuration changes were made.

Do you have any idea what might cause it to appear offline and how to resolve this?

magicsam
Posts: 3
Joined: Friday 26 October 2018 11:56
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MyDomoticz - Testers wanted!

Post by magicsam » Tuesday 30 October 2018 11:31

Thanks for clarifying, happy to support where I can with testing!
chimit wrote:
Tuesday 30 October 2018 0:29
Currently there's been work going on, on MyDomoticz in order to make it more stable for everybody.
Unfortunately this means occasional restarts of the service and sometimes new bug fixes don't work out like they are supposed to do.
We appreciate everybody's patience on this.

== Rene

pbakkers
Posts: 6
Joined: Monday 11 December 2017 18:31
Target OS: Raspberry Pi
Domoticz version: 3.8153
Location: The Netherlands
Contact:

Re: MyDomoticz - Testers wanted!

Post by pbakkers » Thursday 01 November 2018 21:43

magicsam wrote:
Monday 29 October 2018 14:57
Thanks for the advise, indeed after refreshing the page I now managed to login!

Unfortunately my Domoticz instance is now showing as offline. Rebooted my Raspberry Pi and Router just to be sure, but that didn't help.
Domoticz itself works fine within my LAN and no configuration changes were made.

Do you have any idea what might cause it to appear offline and how to resolve this?
chimit wrote:
Friday 26 October 2018 12:40
This may happen due to page caching.
Sometimes it helps to refresh the page (press F5) before logging in after loading the page.
It's a known issue.

== Rene
magicsam wrote:
Friday 26 October 2018 12:10
Since a month or so I'm experiencing issues when trying to access http://my.domoticz.com

When trying to login with email/password I often get the message "Invalid login".
I did reset the password several times now and directly after I can login. But once I close the browser or try another device, I get the same Invalid login message.
If I manage to login, I see my instance online but can't go any further than this.

I hope there is some advise on how to resolve these issues!
[I have the same problems but after several password resets I am logged in but get a red icon and cannot go further!!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests