PiFace support added

Moderator: fantom

NickHead
Posts: 164
Joined: Tuesday 29 October 2013 19:30
Target OS: Linux
Domoticz version:
Location: North East Coast of the UK
Contact:

Re: PiFace support added

Post by NickHead » Saturday 08 August 2015 22:26

Maciek,

You could try and delete the old "Impulse" settings from Devices, and see if it changes when it finds them again.

Unless you did that already.

Also, did you run the update changes below ?

sudo apt-get --reinstall install libraspberrypi-bin libraspberrypi-dev libraspberrypi-doc libraspberrypi0 raspberrypi-bootloader

sudo reboot
A lot of stuff that is doing my head in.

NickHead
Posts: 164
Joined: Tuesday 29 October 2013 19:30
Target OS: Linux
Domoticz version:
Location: North East Coast of the UK
Contact:

Re: PiFace support added

Post by NickHead » Saturday 08 August 2015 22:46

This is how Domoticz starts up as depicted in the log file.

You can compare yours to this and see if it is anywhere near the same.

You may have to KickStart the PD2 in to running by the initpi.py program.

I SSH into my PI2 from a separate computer but have the PI2 next to me on another monitor.

The PI2 has the operating system on a USB stick and not the SD card.

Power supply is a 2A 5V Unit, this is because I had problems with a smaller supply causing
fluctuations and irrational booting.

Code: Select all

   
2015-08-08 21:39:04.885 Domoticz V2.2657 (c)2012-2015 GizMoCuz
2015-08-08 21:39:04.888 System: Raspberry Pi
2015-08-08 21:39:04.891 System: ODroid
2015-08-08 21:39:04.894 Startup Path: /home/pi/domoticz/
2015-08-08 21:39:05.737 Sunrise: 05:28:00 SunSet:20:45:00
2015-08-08 21:39:05.749 Active notification subsystems: (0/8)
2015-08-08 21:39:05.753 Webserver started on port: 6080
2015-08-08 21:39:06.295 Webserver started on port: 343
2015-08-08 21:39:07.826 Hardware Monitor: Started
2015-08-08 21:39:08.598 Incoming connection from: 192.168.1.104
2015-08-08 21:39:09.828 PiFace: Starting PiFace_SPI_Start()
2015-08-08 21:39:09.828 PiFace: SPI device opened successfully
2015-08-08 21:39:09.830 PiFace: Found the following PiFaces:

2015-08-08 21:39:09.830 PiFace: 0

2015-08-08 21:39:09.831 PiFace: config file: Valid address: 0 , Pin: 0 and Port O Parameter: enabled , Value false
2015-08-08 21:39:09.831 PiFace: config file: Valid address: 0 , Pin: 0 and Port O Parameter: pin_type , Value level
2015-08-08 21:39:09.832 PiFace: config file: Valid address: 0 , Pin: 0 and Port O Parameter: count_enabled , Value false
2015-08-08 21:39:09.832 PiFace: config file: Valid address: 0 , Pin: 0 and Port O Parameter: count_update_interval_sec , Value 30
2015-08-08 21:39:09.832 PiFace: config file: Valid address: 0 , Pin: 0 and Port I Parameter: enabled , Value true
2015-08-08 21:39:09.832 PiFace: config file: Valid address: 0 , Pin: 0 and Port I Parameter: pin_type , Value falling
2015-08-08 21:39:09.832 PiFace: config file: Valid address: 0 , Pin: 0 and Port I Parameter: count_enabled , Value true
2015-08-08 21:39:09.832 PiFace: config file: Valid address: 0 , Pin: 0 and Port I Parameter: count_update_interval_sec , Value 5
2015-08-08 21:39:09.834 PiFace: retrieved value for Input counter: BoardNr 0 , Pin: 0, Value 76098
2015-08-08 21:39:09.867 PiFace: Worker started...
2015-08-08 21:39:09.967 (PiFace) Lighting 1 (this)
2015-08-08 21:39:10.081 (PiFace) RFXMeter (Usage Meter)
2015-08-08 21:39:37.829 Hardware Monitor: Fetching data (System sensors)
2015-08-08 21:39:40.116 (PiFace) RFXMeter (Usage Meter)

 
I don't know what else I can add to help you both.
A lot of stuff that is doing my head in.

NickHead
Posts: 164
Joined: Tuesday 29 October 2013 19:30
Target OS: Linux
Domoticz version:
Location: North East Coast of the UK
Contact:

Re: PiFace support added

Post by NickHead » Saturday 08 August 2015 23:01

Won't be needing this then
Last edited by NickHead on Sunday 09 August 2015 13:13, edited 1 time in total.
A lot of stuff that is doing my head in.

macieiks
Posts: 56
Joined: Tuesday 07 July 2015 12:00
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: PiFace support added

Post by macieiks » Sunday 09 August 2015 12:59

Hi, I was trying to reinstall libs on my beta but still no luck, so I connected my Photo Sensor to Arduino Nano and I can read these statistics using MySensors 1.4. Atleast it is working 8-). I run it on stable domoticz v2.2563. I set the node to report Nano gateway each 20 seconds.

Here are the statistics (avoid this ~10kWh report, I was testing with portable flashlight :lol: )

Photo:
Image
Image
Image

I will just use my PiFace 2 for different purposes.
RPI2 + RFLink + PiFace D2 + Aeon Z-Wave Gen5 + Foscams FI9821P&R2 + MySensors + UPS APC Back-UPS 950VA
RPI2 + RFXtrx433e + Foscams FI9821P + MySensors + UPS APC Back-UPS 950VA
RPIB+ + TP-Link MR3420 + Huawei E173 GarageDomoticz :)

korniza
Posts: 198
Joined: Thursday 27 August 2015 18:12
Target OS: Raspberry Pi
Domoticz version: V3.6028
Location: Greece
Contact:

Re: PiFace support added

Post by korniza » Saturday 19 September 2015 5:03

I think I found a bug 8-)
I have a raspberry pi 2 with piface 2. I can control the relays on piface 2 from the installed DOmoticz on raspberry (V2.3072).
I have also a Master DOmoticz server that runs on a PC (V2.3072). I have shared successfully the outputs of PiFace 2 on the Master.
The problem is that when I press the button on Master Domoticz to activate a relay on Slave (Raspberry 2+piface 2) nothing happens.
I cheched the logs. Command is sent to Slave successfully as you can see below.
EDIT: I also can see the bulb on SLAVE activated, even the relay is not armed!

MASTER
2015-09-19 06:01:02.561 Hardware Monitor: Fetching data (System sensors)
2015-09-19 06:01:17.200 (Raspberry Pi) Lighting 1 (Unknown)
2015-09-19 06:01:32.583 Hardware Monitor: Fetching data (System sensors)
2015-09-19 06:01:33.648 (Raspberry Pi) Lighting 1 (Unknown)
SLAVE
2015-09-19 06:00:55.331 Hardware Monitor: Fetching data (System sensors)
2015-09-19 06:01:17.187 (MyPiFace) Lighting 1 (face)
2015-09-19 06:01:25.393 Hardware Monitor: Fetching data (System sensors)
2015-09-19 06:01:33.705 (MyPiFace) Lighting 1 (face)
2015-09-19 06:01:55.455 Hardware Monitor: Fetching data (System sensors)
>>>> Google Home <<<<<
SBC: Odroid XU4 * Raspberry Pi2 * banana Pi v1
Peripherals: rfxtrx433E, aeon z-stick gen5, bluetooth dongles
Extended Software packages: Xeoma (video NVR), FHEM (extra home automation software)

Ronny
Posts: 7
Joined: Saturday 14 February 2015 18:41
Target OS: Raspberry Pi
Domoticz version:
Location: Netherlands
Contact:

Re: PiFace support added

Post by Ronny » Sunday 15 November 2015 22:24

Does anybody has expierience using the paramter "count_minimum_pulse_period" or "count_minimum_pulse_period_msec". As I have used an TCRT5000 to read the dail of my water meter. This works but sometimes it flutters to enormous ammounts.

User avatar
EdddieN
Posts: 378
Joined: Wednesday 16 November 2016 12:31
Target OS: Raspberry Pi
Domoticz version: 4.9700
Location: Scotland
Contact:

Re: PiFace support added

Post by EdddieN » Monday 03 April 2017 23:42

Hi

Is there a way to set one of the inputs in tristate mode?
I.e.: pull up/down = none

The reason is I need to use external pull up
11101101 - www.machinon.com

Jan Jansen
Posts: 164
Joined: Wednesday 30 April 2014 20:27
Target OS: Raspberry Pi
Domoticz version: Beta
Location: The Netherlands
Contact:

Re: PiFace support added

Post by Jan Jansen » Tuesday 04 April 2017 10:01

Take a look into the wiki!

User avatar
EdddieN
Posts: 378
Joined: Wednesday 16 November 2016 12:31
Target OS: Raspberry Pi
Domoticz version: 4.9700
Location: Scotland
Contact:

Re: PiFace support added

Post by EdddieN » Tuesday 04 April 2017 10:59

I did, no mention of it:
http://www.domoticz.com/wiki/PiFace
11101101 - www.machinon.com

Misiek1977
Posts: 5
Joined: Sunday 16 April 2017 18:44
Target OS: -
Domoticz version:
Contact:

Re: PiFace support added

Post by Misiek1977 » Tuesday 27 February 2018 21:46

I've tried to reinstall Piface 2 after some time on clean Rapsbian-stretch but without success. Even tutorial on Wiki is out-of-date because there is nolonger "A5-Device tree"
Can someone help me with it or I should put my Piface on the shelf?

Best Regards
Michal

Jan Jansen
Posts: 164
Joined: Wednesday 30 April 2014 20:27
Target OS: Raspberry Pi
Domoticz version: Beta
Location: The Netherlands
Contact:

Re: PiFace support added

Post by Jan Jansen » Wednesday 28 February 2018 11:09

I use 2 pifaces (Stretch) without any issue. What does the log say?

Misiek1977
Posts: 5
Joined: Sunday 16 April 2017 18:44
Target OS: -
Domoticz version:
Contact:

Re: PiFace support added

Post by Misiek1977 » Thursday 01 March 2018 18:43

I do not know at this moment because I've removed it.
PLS give me a quick guide how to install stretch/domoticz and PiFace 2?
1. Pure Rapsbian stretch instaltion
2. Do I have to install something else or just install domoticz according Wiki (without "sudo raspi-config, 8 Advanced Options, A5 Device Tree -> disabled")
3. Add hardware to the domoticz?


THX
Michal

Jan Jansen
Posts: 164
Joined: Wednesday 30 April 2014 20:27
Target OS: Raspberry Pi
Domoticz version: Beta
Location: The Netherlands
Contact:

Re: PiFace support added

Post by Jan Jansen » Thursday 01 March 2018 22:00

Follow the Wiki

raspi-config >> enable SPI

after > curl -L install.domoticz.com | sudo bash
cd domoticz
./updatebeta

Point your browser to the IP address of your Raspberry Pi
Click hardware tab and add the piface board.

Check if is there is a piface.conf file in the domoticz folder.

Misiek1977
Posts: 5
Joined: Sunday 16 April 2017 18:44
Target OS: -
Domoticz version:
Contact:

Re: PiFace support added

Post by Misiek1977 » Friday 02 March 2018 0:30

I've done this
I have piface conf
I've added piface (only four buttons are added)

but it is not working

Log is below.

2018-03-01 23:18:57.846 PiFace: Found the following PiFaces:
2018-03-01 23:18:57.847 PiFace: 0
2018-03-01 23:18:57.850 PiFace: config file: Valid address: 0 , Pin: 0 and Port O Parameter: enabled , Value false
2018-03-01 23:18:57.850 PiFace: config file: Valid address: 0 , Pin: 0 and Port O Parameter: pin_type , Value level
2018-03-01 23:18:57.850 PiFace: config file: Valid address: 0 , Pin: 0 and Port O Parameter: count_enabled , Value true
2018-03-01 23:18:57.850 PiFace: config file: Valid address: 0 , Pin: 0 and Port O Parameter: count_type , Value generic
2018-03-01 23:18:57.850 PiFace: config file: Valid address: 0 , Pin: 0 and Port O Parameter: count_update_interval_sec , Value 10
2018-03-01 23:18:57.850 PiFace: config file: Valid address: 0 , Pin: 0 and Port I Parameter: enabled , Value true
2018-03-01 23:18:57.850 PiFace: config file: Valid address: 0 , Pin: 0 and Port I Parameter: pin_type , Value rising
2018-03-01 23:18:57.850 PiFace: config file: Valid address: 0 , Pin: 0 and Port I Parameter: count_enabled , Value false
2018-03-01 23:18:57.851 PiFace: config file: Valid address: 0 , Pin: 0 and Port I Parameter: count_type , Value generic
2018-03-01 23:18:57.851 PiFace: config file: Valid address: 0 , Pin: 0 and Port I Parameter: count_update_interval_sec , Value 10
2018-03-01 23:18:57.851 PiFace: config file: Valid address: 0 , Pin: 1 and Port O Parameter: enabled , Value false
2018-03-01 23:18:57.851 PiFace: config file: Valid address: 0 , Pin: 1 and Port O Parameter: pin_type , Value level
2018-03-01 23:18:57.851 PiFace: config file: Valid address: 0 , Pin: 1 and Port O Parameter: count_enabled , Value true
2018-03-01 23:18:57.851 PiFace: config file: Valid address: 0 , Pin: 1 and Port O Parameter: count_type , Value generic
2018-03-01 23:18:57.851 PiFace: config file: Valid address: 0 , Pin: 1 and Port O Parameter: count_update_interval_sec , Value 10
2018-03-01 23:18:57.851 PiFace: config file: Valid address: 0 , Pin: 1 and Port I Parameter: enabled , Value true
2018-03-01 23:18:57.851 PiFace: config file: Valid address: 0 , Pin: 1 and Port I Parameter: pin_type , Value rising
2018-03-01 23:18:57.851 PiFace: config file: Valid address: 0 , Pin: 1 and Port I Parameter: count_enabled , Value false
2018-03-01 23:18:57.852 PiFace: config file: Valid address: 0 , Pin: 1 and Port I Parameter: count_type , Value generic
2018-03-01 23:18:57.852 PiFace: config file: Valid address: 0 , Pin: 1 and Port I Parameter: count_update_interval_sec , Value 10
2018-03-01 23:18:57.852 PiFace: config file: Valid address: 0 , Pin: 2 and Port O Parameter: enabled , Value false
2018-03-01 23:18:57.852 PiFace: config file: Valid address: 0 , Pin: 2 and Port O Parameter: pin_type , Value level
2018-03-01 23:18:57.852 PiFace: config file: Valid address: 0 , Pin: 2 and Port O Parameter: count_enabled , Value true
2018-03-01 23:18:57.852 PiFace: config file: Valid address: 0 , Pin: 2 and Port O Parameter: count_type , Value generic
2018-03-01 23:18:57.852 PiFace: config file: Valid address: 0 , Pin: 2 and Port O Parameter: count_update_interval_sec , Value 10
2018-03-01 23:18:57.852 PiFace: config file: Valid address: 0 , Pin: 2 and Port I Parameter: enabled , Value true
2018-03-01 23:18:57.852 PiFace: config file: Valid address: 0 , Pin: 2 and Port I Parameter: pin_type , Value rising
2018-03-01 23:18:57.852 PiFace: config file: Valid address: 0 , Pin: 2 and Port I Parameter: count_enabled , Value false
2018-03-01 23:18:57.852 PiFace: config file: Valid address: 0 , Pin: 2 and Port I Parameter: count_type , Value generic
2018-03-01 23:18:57.852 PiFace: config file: Valid address: 0 , Pin: 2 and Port I Parameter: count_update_interval_sec , Value 10
2018-03-01 23:18:57.853 PiFace: config file: Valid address: 0 , Pin: 3 and Port O Parameter: enabled , Value false
2018-03-01 23:18:57.853 PiFace: config file: Valid address: 0 , Pin: 3 and Port O Parameter: pin_type , Value level
2018-03-01 23:18:57.853 PiFace: config file: Valid address: 0 , Pin: 3 and Port O Parameter: count_enabled , Value true
2018-03-01 23:18:57.853 PiFace: config file: Valid address: 0 , Pin: 3 and Port O Parameter: count_type , Value generic
2018-03-01 23:18:57.853 PiFace: config file: Valid address: 0 , Pin: 3 and Port O Parameter: count_update_interval_sec , Value 10
2018-03-01 23:18:57.853 PiFace: config file: Valid address: 0 , Pin: 3 and Port I Parameter: enabled , Value true
2018-03-01 23:18:57.853 PiFace: config file: Valid address: 0 , Pin: 3 and Port I Parameter: pin_type , Value rising
2018-03-01 23:18:57.853 PiFace: config file: Valid address: 0 , Pin: 3 and Port I Parameter: count_enabled , Value false
2018-03-01 23:18:57.853 PiFace: config file: Valid address: 0 , Pin: 3 and Port I Parameter: count_type , Value generic
2018-03-01 23:18:57.853 PiFace: config file: Valid address: 0 , Pin: 3 and Port I Parameter: count_update_interval_sec , Value 10
2018-03-01 23:18:57.853 PiFace: config file: Valid address: 0 , Pin: 4 and Port O Parameter: enabled , Value false
2018-03-01 23:18:57.853 PiFace: config file: Valid address: 0 , Pin: 4 and Port O Parameter: pin_type , Value level
2018-03-01 23:18:57.854 PiFace: config file: Valid address: 0 , Pin: 4 and Port O Parameter: count_enabled , Value true
2018-03-01 23:18:57.854 PiFace: config file: Valid address: 0 , Pin: 4 and Port O Parameter: count_type , Value generic
2018-03-01 23:18:57.854 PiFace: config file: Valid address: 0 , Pin: 4 and Port O Parameter: count_update_interval_sec , Value 10
2018-03-01 23:18:57.854 PiFace: config file: Valid address: 0 , Pin: 4 and Port I Parameter: enabled , Value false
2018-03-01 23:18:57.854 PiFace: config file: Valid address: 0 , Pin: 4 and Port I Parameter: pin_type , Value rising
2018-03-01 23:18:57.854 PiFace: config file: Valid address: 0 , Pin: 4 and Port I Parameter: count_enabled , Value true
2018-03-01 23:18:57.854 PiFace: config file: Valid address: 0 , Pin: 4 and Port I Parameter: count_type , Value generic
2018-03-01 23:18:57.854 PiFace: config file: Valid address: 0 , Pin: 4 and Port I Parameter: count_update_interval_sec , Value 10
2018-03-01 23:18:57.854 PiFace: config file: Valid address: 0 , Pin: 5 and Port O Parameter: enabled , Value false
2018-03-01 23:18:57.854 PiFace: config file: Valid address: 0 , Pin: 5 and Port O Parameter: pin_type , Value level
2018-03-01 23:18:57.854 PiFace: config file: Valid address: 0 , Pin: 5 and Port O Parameter: count_enabled , Value true
2018-03-01 23:18:57.854 PiFace: config file: Valid address: 0 , Pin: 5 and Port O Parameter: count_type , Value generic
2018-03-01 23:18:57.855 PiFace: config file: Valid address: 0 , Pin: 5 and Port O Parameter: count_update_interval_sec , Value 10
2018-03-01 23:18:57.855 PiFace: config file: Valid address: 0 , Pin: 5 and Port I Parameter: enabled , Value false
2018-03-01 23:18:57.855 PiFace: config file: Valid address: 0 , Pin: 5 and Port I Parameter: pin_type , Value rising
2018-03-01 23:18:57.855 PiFace: config file: Valid address: 0 , Pin: 5 and Port I Parameter: count_enabled , Value true
2018-03-01 23:18:57.855 PiFace: config file: Valid address: 0 , Pin: 5 and Port I Parameter: count_type , Value generic
2018-03-01 23:18:57.855 PiFace: config file: Valid address: 0 , Pin: 5 and Port I Parameter: count_update_interval_sec , Value 10
2018-03-01 23:18:57.855 PiFace: config file: Valid address: 0 , Pin: 6 and Port O Parameter: enabled , Value false
2018-03-01 23:18:57.855 PiFace: config file: Valid address: 0 , Pin: 6 and Port O Parameter: pin_type , Value level
2018-03-01 23:18:57.855 PiFace: config file: Valid address: 0 , Pin: 6 and Port O Parameter: count_enabled , Value true
2018-03-01 23:18:57.856 PiFace: config file: Valid address: 0 , Pin: 6 and Port O Parameter: count_type , Value generic
2018-03-01 23:18:57.856 PiFace: config file: Valid address: 0 , Pin: 6 and Port O Parameter: count_update_interval_sec , Value 10
2018-03-01 23:18:57.856 PiFace: config file: Valid address: 0 , Pin: 6 and Port I Parameter: enabled , Value false
2018-03-01 23:18:57.856 PiFace: config file: Valid address: 0 , Pin: 6 and Port I Parameter: pin_type , Value rising
2018-03-01 23:18:57.856 PiFace: config file: Valid address: 0 , Pin: 6 and Port I Parameter: count_enabled , Value true
2018-03-01 23:18:57.856 PiFace: config file: Valid address: 0 , Pin: 6 and Port I Parameter: count_type , Value generic
2018-03-01 23:18:57.856 PiFace: config file: Valid address: 0 , Pin: 6 and Port I Parameter: count_update_interval_sec , Value 10
2018-03-01 23:18:57.856 PiFace: config file: Valid address: 0 , Pin: 7 and Port O Parameter: enabled , Value false
2018-03-01 23:18:57.856 PiFace: config file: Valid address: 0 , Pin: 7 and Port O Parameter: pin_type , Value level
2018-03-01 23:18:57.856 PiFace: config file: Valid address: 0 , Pin: 7 and Port O Parameter: count_enabled , Value true
2018-03-01 23:18:57.856 PiFace: config file: Valid address: 0 , Pin: 7 and Port O Parameter: count_type , Value generic
2018-03-01 23:18:57.857 PiFace: config file: Valid address: 0 , Pin: 7 and Port O Parameter: count_update_interval_sec , Value 10
2018-03-01 23:18:57.857 PiFace: config file: Valid address: 0 , Pin: 7 and Port I Parameter: enabled , Value false
2018-03-01 23:18:57.857 PiFace: config file: Valid address: 0 , Pin: 7 and Port I Parameter: pin_type , Value rising
2018-03-01 23:18:57.857 PiFace: config file: Valid address: 0 , Pin: 7 and Port I Parameter: count_enabled , Value true
2018-03-01 23:18:57.857 PiFace: config file: Valid address: 0 , Pin: 7 and Port I Parameter: count_type , Value generic
2018-03-01 23:18:57.857 PiFace: config file: Valid address: 0 , Pin: 7 and Port I Parameter: count_update_interval_sec , Value 10
2018-03-01 23:18:57.860 PiFace: Worker started...
2018-03-01 23:18:57.861 EventSystem: reset all events...
2018-03-01 23:18:57.861 EventSystem: reset all device statuses...
2018-03-01 23:18:57.972 (PI2) Lighting 1 (pi0)
2018-03-01 23:18:58.010 PluginSystem: Entering work loop.
2018-03-01 23:18:58.068 (PI2) Lighting 1 (pi1)
2018-03-01 23:18:58.090 Python EventSystem: Initalizing event module.
2018-03-01 23:18:58.091 EventSystem: Started
2018-03-01 23:18:58.091 EventSystem: Queue thread started...
2018-03-01 23:18:58.168 (PI2) Lighting 1 (pi2)
2018-03-01 23:18:58.273 (PI2) Lighting 1 (pi3)
2018-03-01 23:27:30.676 Error: PI2 hardware (2) thread seems to have ended unexpectedly
2018-03-01 23:28:50.040 Incoming connection from: 192.168.50.51
2018-03-01 23:28:55.102 User: Admin initiated a switch command (1/pi0/On)
2018-03-01 23:28:55.103 Error: Piface: wrong housecode I

Jan Jansen
Posts: 164
Joined: Wednesday 30 April 2014 20:27
Target OS: Raspberry Pi
Domoticz version: Beta
Location: The Netherlands
Contact:

Re: PiFace support added

Post by Jan Jansen » Friday 02 March 2018 15:37

For me it seems that you have adjusted the piface.conf. I use the following (I only use switches and no counters).

Code: Select all

//piface.conf [Autogenerated]
//This file is part of the PiFace driver (written by Robin Stevenhagen) for domoticz, and allows for more advanced pin configuration options
//This file can optionaly hold all the configuration for all attached PiFace boards.
//Please note that if this file is found the default config is discarded, and only the configuration in this file is used, all IO that is not specified will
///be configured as not used.
//
// Configuration line syntax:
// piface.<board address>.<I/O>.<pin number>.<parameter>=<value>
//
// <board address>:                Check piface (JP1 & JP2) jumper settings, value between 0..3
//
// <I/O>:                          input
//                                 output
//
// <pinnumber>:                    value between 0..7
//
// <parameter>:                    enabled
//                                 pin_type
//                                 count_enabled
//                                 count_update_interval_sec
//                                 count_initial_value
//                                 count_minimum_pulse_period
//
// Available <parameter> / <values>:
// enabled:                        true  or 1
//                                 false or 0
//
// pin_type:                       level                     //best to keep this paramter to level for outputs, as Domoticz does not like other values
//                                 inv_level
//                                 rising
//                                 falling
//
// count_enabled:                  true  or 1
//                                 false or 0
//
// count_update_interval_sec:      0 to 3600
piface.0.output.0.enabled=true
piface.0.output.0.pin_type=level
piface.0.output.0.count_enabled=false
piface.0.output.0.count_update_interval_sec=10

piface.0.input.0.enabled=true
piface.0.input.0.pin_type=level
piface.0.input.0.count_enabled=false
piface.0.input.0.count_update_interval_sec=10

piface.0.output.1.enabled=true
piface.0.output.1.pin_type=level
piface.0.output.1.count_enabled=false
piface.0.output.1.count_update_interval_sec=10

piface.0.input.1.enabled=true
piface.0.input.1.pin_type=level
piface.0.input.1.count_enabled=false
piface.0.input.1.count_update_interval_sec=10

piface.0.output.2.enabled=true
piface.0.output.2.pin_type=level
piface.0.output.2.count_enabled=false
piface.0.output.2.count_update_interval_sec=10

piface.0.input.2.enabled=true
piface.0.input.2.pin_type=inv_level
piface.0.input.2.count_enabled=false
piface.0.input.2.count_update_interval_sec=10

piface.0.output.3.enabled=true
piface.0.output.3.pin_type=level
piface.0.output.3.count_enabled=false
piface.0.output.3.count_update_interval_sec=10

piface.0.input.3.enabled=true
piface.0.input.3.pin_type=level
piface.0.input.3.count_enabled=false
piface.0.input.3.count_update_interval_sec=10

piface.0.output.4.enabled=true
piface.0.output.4.pin_type=level
piface.0.output.4.count_enabled=false
piface.0.output.4.count_update_interval_sec=10

piface.0.input.4.enabled=true
piface.0.input.4.pin_type=level
piface.0.input.4.count_enabled=false
piface.0.input.4.count_update_interval_sec=10

piface.0.output.5.enabled=true
piface.0.output.5.pin_type=level
piface.0.output.5.count_enabled=false
piface.0.output.5.count_update_interval_sec=10

piface.0.input.5.enabled=true
piface.0.input.5.pin_type=level
piface.0.input.5.count_enable=false
piface.0.input.5.count_update_interval_sec=10

piface.0.output.6.enabled=true
piface.0.output.6.pin_type=level
piface.0.output.6.count_enabled=false
piface.0.output.6.count_update_interval_sec=10

piface.0.input.6.enabled=true
piface.0.input.6.pin_type=level
piface.0.input.6.count_enabled=false
piface.0.input.6.count_update_interval_sec=10

piface.0.output.7.enabled=true
piface.0.output.7.pin_type=level
piface.0.output.7.count_enabled=false
piface.0.output.7.count_update_interval_sec=10

piface.0.input.7.enabled=true
piface.0.input.7.pin_type=level
piface.0.input.7.count_enabled=false
piface.0.input.7.count_update_interval_sec=10

gbuico
Posts: 16
Joined: Saturday 25 November 2017 14:39
Target OS: Raspberry Pi
Domoticz version: 3.8153
Location: Nice, France
Contact:

Re: PiFace support added

Post by gbuico » Friday 02 March 2018 17:26

Misiek1977, just to check, are you sure that the installation of PıFace completed without problems?
I'm sure I had to work a bit to have it properly installed on Stretch... of course now it's working fine.
The only trouble I remember at the moment is described here
https://www.raspberrypi.org/forums/view ... p?t=194332

Misiek1977
Posts: 5
Joined: Sunday 16 April 2017 18:44
Target OS: -
Domoticz version:
Contact:

Re: PiFace support added

Post by Misiek1977 » Friday 02 March 2018 21:44

Jan: I haven't change a bit in the conf-file
gbuico: THX I will check the link maybe there is something that will help me.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests