new 2gig CT100...

For Z-Wave related questions in Domoticz
Post Reply
tdavis
Posts: 8
Joined: Wednesday 05 March 2014 19:24
Target OS: Raspberry Pi
Domoticz version:
Contact:

new 2gig CT100...

Post by tdavis » Wednesday 15 October 2014 19:08

Got a 2gig CT100 (aka, Radio Thermostat CT100, FCC ID Q08-CT100R1, IC 4714A-CT100R1)

First, a simple change was needed to manufacturer_specific.xml:

<Product type="6401" id="0107" name="CT100 Thermostat" config="2gig/ct100.xml"/>

They changed the ID from 105 to 107.


I also get this on startup:

Code: Select all

Fri Oct 10 14:10:24 2014 OpenZWave: Value_Added: Node: 9, CommandClass: CLOCK, Label: Day, Instance: 1
Fri Oct 10 14:10:24 2014 Error: OpenZWave: Unhandled class: 0x81 (CLOCK)
Fri Oct 10 14:10:24 2014 OpenZWave: Value_Added: Node: 9, CommandClass: CLOCK, Label: Hour, Instance: 1
Fri Oct 10 14:10:24 2014 Error: OpenZWave: Unhandled class: 0x81 (CLOCK)
Fri Oct 10 14:10:24 2014 OpenZWave: Value_Added: Node: 9, CommandClass: CLOCK, Label: Minute, Instance: 1
Fri Oct 10 14:10:24 2014 Error: OpenZWave: Unhandled class: 0x81 (CLOCK)
Fri Oct 10 14:10:24 2014 OpenZWave: Value_Added: Node: 9, CommandClass: INDICATOR, Label: Indicator, Instance: 1
Fri Oct 10 14:10:24 2014 Error: OpenZWave: Unhandled class: 0x87 (INDICATOR)
Fri Oct 10 14:10:24 2014 OpenZWave: Value_Added: Node: 9, CommandClass: THERMOSTAT OPERATING STATE, Label: Operating State, Instance: 1
Fri Oct 10 14:10:24 2014 Error: OpenZWave: Unhandled class: 0x42 (THERMOSTAT OPERATING STATE)
Fri Oct 10 14:10:24 2014 OpenZWave: Value_Added: Node: 9, CommandClass: THERMOSTAT FAN STATE, Label: Fan State, Instance: 1
Fri Oct 10 14:10:24 2014 Error: OpenZWave: Unhandled class: 0x45 (THERMOSTAT FAN STATE)
Fri Oct 10 14:10:24 2014 OpenZWave: Value_Added: Node: 9, CommandClass: BATTERY, Label: Battery Level, Instance: 1
Fri Oct 10 14:10:30 2014 Hardware Monitor: Fetching data (System sensors)
Fri Oct 10 14:10:31 2014 OpenZWave: Value_Added: Node: 9, CommandClass: THERMOSTAT MODE, Label: Mode, Instance: 1
Fri Oct 10 14:10:31 2014 Error: OpenZWave: Unhandled class: 0x40 (THERMOSTAT MODE)
Fri Oct 10 14:10:32 2014 OpenZWave: Value_Added: Node: 9, CommandClass: THERMOSTAT SETPOINT, Label: Heating 1, Instance: 1
Fri Oct 10 14:10:32 2014 OpenZWave: Value_Added: Node: 9, CommandClass: THERMOSTAT SETPOINT, Label: Cooling 1, Instance: 2
Fri Oct 10 14:10:33 2014 OpenZWave: Value_Added: Node: 9, CommandClass: THERMOSTAT FAN MODE, Label: Fan Mode, Instance: 1
Fri Oct 10 14:10:33 2014 Error: OpenZWave: Unhandled class: 0x44 (THERMOSTAT FAN MODE)
I added some code to see what the values are, and got these:

Code: Select all

Wed Oct 15 09:47:02 2014 OpenZWave: Value_Added: Node: 9, CommandClass: SENSOR MULTILEVEL, Label: Temperature, Instance: 1
Wed Oct 15 09:47:02 2014 OpenZWave: Value_Added: Node: 9, CommandClass: SENSOR MULTILEVEL, Label: Temperature, Instance: 2
Wed Oct 15 09:47:02 2014 OpenZWave: Value_Added: Node: 9, CommandClass: SENSOR MULTILEVEL, Label: Relative Humidity, Instance: 5
Wed Oct 15 09:47:02 2014 OpenZWave: Value_Added: Node: 9, CommandClass: THERMOSTAT OPERATING STATE, Label: Operating State, Instance: 1
Wed Oct 15 09:47:02 2014 Operating State: Heating
Wed Oct 15 09:47:02 2014 OpenZWave: Value_Added: Node: 9, CommandClass: THERMOSTAT SETPOINT, Label: Heating 1, Instance: 1
Wed Oct 15 09:47:02 2014 OpenZWave: Value_Added: Node: 9, CommandClass: THERMOSTAT SETPOINT, Label: Cooling 1, Instance: 2
Wed Oct 15 09:47:02 2014 OpenZWave: Value_Added: Node: 9, CommandClass: THERMOSTAT FAN MODE, Label: Fan Mode, Instance: 1
Wed Oct 15 09:47:02 2014 Fan Mode: Auto Low
Wed Oct 15 09:47:02 2014 OpenZWave: Value_Added: Node: 9, CommandClass: THERMOSTAT FAN STATE, Label: Fan State, Instance: 1
Wed Oct 15 09:47:02 2014 Fan State: Idle
Wed Oct 15 09:47:02 2014 OpenZWave: Value_Added: Node: 9, CommandClass: BATTERY, Label: Battery Level, Instance: 1
Wed Oct 15 09:47:02 2014 OpenZWave: Value_Added: Node: 9, CommandClass: CLOCK, Label: Day, Instance: 1
Wed Oct 15 09:47:02 2014 Day: Tuesday
Wed Oct 15 09:47:02 2014 OpenZWave: Value_Added: Node: 9, CommandClass: CLOCK, Label: Hour, Instance: 1
Wed Oct 15 09:47:02 2014 Hour: 10
Wed Oct 15 09:47:02 2014 OpenZWave: Value_Added: Node: 9, CommandClass: CLOCK, Label: Minute, Instance: 1
Wed Oct 15 09:47:02 2014 Minute: 51
Wed Oct 15 09:47:02 2014 OpenZWave: Value_Added: Node: 9, CommandClass: INDICATOR, Label: Indicator, Instance: 1
Wed Oct 15 09:47:02 2014 Indicator: 0
Things I've found out so far:
  • You can change the setpoint via web interface, but not by blocky.
  • Every time domoticz startups/restarts, it re-adds temperature devices..
I'm willing to try code for this; I I just do not have lots of time for it. It would be really nice to be able to use Domoticz to totally control this device.

dougmattingly
Posts: 1
Joined: Saturday 18 October 2014 0:56
Target OS: Linux
Domoticz version:
Contact:

Re: new 2gig CT100...

Post by dougmattingly » Monday 20 October 2014 5:35

Can you share what you did to remove the unhandled command class error? I have a Radio Thermostat plug-in module which acts the same as the CT100. I have made the appropriate changes to manufacturer-specific.xml and and have the exact same log as you show with the unhandled command classes. Do you know if full control is available via lua scripts after the changes you made? I know the thermostat is fully controllable via other platforms based on openzwave (specifically agocontrol), but I like domoticz interface better.

Thank you,
Doug

User avatar
gizmocuz
Posts: 8688
Joined: Thursday 11 July 2013 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Top of the world
Contact:

Re: new 2gig CT100...

Post by gizmocuz » Saturday 15 November 2014 14:59

I just added support for (#2122)

- COMMAND_CLASS_THERMOSTAT_MODE
- COMMAND_CLASS_THERMOSTAT_FAN_MODE

If you would like to have support for THERMOSTAT OPERATING STATE and/or THERMOSTAT FAN STATE:
- could you loan me the device ?
- or provide SSH and Domoticz HTTP access to your system ?

Send me a PM !
Quality outlives Quantity!

Poof
Posts: 5
Joined: Wednesday 15 April 2015 5:51
Target OS: Raspberry Pi
Domoticz version: beta
Contact:

Re: new 2gig CT100...

Post by Poof » Friday 26 June 2015 7:59

Do you still need SSH/HTTP access to set up the CT100?

Poof
Posts: 5
Joined: Wednesday 15 April 2015 5:51
Target OS: Raspberry Pi
Domoticz version: beta
Contact:

Re: new 2gig CT100...

Post by Poof » Tuesday 30 June 2015 6:23

Well, I hope support gets baked in some time. I can't set the thermostat mode on the current version of Domoticz. :(

Davelusa
Posts: 1
Joined: Friday 20 May 2016 19:29
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: new 2gig CT100...

Post by Davelusa » Friday 20 May 2016 19:31

Were any of these features ever added for the Radio Thermostats? Sure would love to control my CT-50 with Domoticz

jensc
Posts: 47
Joined: Saturday 12 March 2016 2:49
Target OS: Windows
Domoticz version: 3.5494
Location: Columbia City, Oregon, USA
Contact:

Re: new 2gig CT100...

Post by jensc » Wednesday 29 March 2017 8:15

@Davelusa

The answer, a year later, appears to be no.

skybehind
Posts: 35
Joined: Monday 04 April 2016 22:00
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: new 2gig CT100...

Post by skybehind » Thursday 08 February 2018 1:22

And yet another year later, I'd still like to see this.

Ittiz
Posts: 29
Joined: Tuesday 03 January 2017 1:37
Target OS: Windows
Domoticz version:
Contact:

Re: new 2gig CT100...

Post by Ittiz » Saturday 24 February 2018 1:51

@Davelusa, Some yes some no. I have a CT100 and everything works except THERMOSTAT OPERATING STATE, THERMOSTAT FAN STATE and INDICATOR. I had to build the device config myself though. It's part of the open-z-wave source now, but you'll need to download the latest beta though. It doesn't seem that CT50 is in the open-z-wave configs yet though, so you may have to implement it yourself based on CT100 or CT32

skybehind
Posts: 35
Joined: Monday 04 April 2016 22:00
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: new 2gig CT100...

Post by skybehind » Sunday 25 February 2018 17:12

I have the CT100 as well. What did you add to what config file to make the THERMOSTAT OPERATING STATE and THERMOSTAT FAN STATE work?

Nomader
Posts: 40
Joined: Wednesday 24 February 2016 9:22
Target OS: Windows
Domoticz version:
Contact:

Re: new 2gig CT100...

Post by Nomader » Monday 26 March 2018 13:53

Ittiz wrote:
Saturday 24 February 2018 1:51
@Davelusa, Some yes some no. I have a CT100 and everything works except THERMOSTAT OPERATING STATE, THERMOSTAT FAN STATE and INDICATOR. I had to build the device config myself though. It's part of the open-z-wave source now, but you'll need to download the latest beta though. It doesn't seem that CT50 is in the open-z-wave configs yet though, so you may have to implement it yourself based on CT100 or CT32
I am very interested in the thermostat state as well.. did you get it working by editing the config.. can you explain more

Ittiz
Posts: 29
Joined: Tuesday 03 January 2017 1:37
Target OS: Windows
Domoticz version:
Contact:

Re: new 2gig CT100...

Post by Ittiz » Sunday 12 August 2018 23:17

Wow, been awhile since I logged in here. Yes the thermostat mostly works with the stock config now. I was never able to get a compiler to compile Domoticz because it had was too many dependencies and I wasn't able to figure them all out with how little free time I have. And no one else seems that interested in implementing those extra features. So the THERMOSTAT OPERATING STATE, THERMOSTAT FAN STATE and INDICATOR features still haven't been added.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests