domoticz in synology as package! Available now.

Others (MiLight, Hue, Toon etc...)
ottovdv
Posts: 1
Joined: Sunday 28 October 2018 19:03
Target OS: NAS (Synology & others)
Domoticz version:
Contact:

Re: domoticz in synology as package! Available now.

Post by ottovdv » Sunday 28 October 2018 19:13

On Sourceforge I found the synology toolchains for DSM 6.2.
Any chance somebody can use this to make Domoticz available for the DS211j with the Marvell Kirkwood 88f6281?

https://sourceforge.net/projects/dsgpl/ ... %20Chains/

User avatar
jumbotroll
Posts: 696
Joined: Tuesday 13 January 2015 15:36
Target OS: NAS (Synology & others)
Domoticz version: Beta
Location: Oslo,Norway
Contact:

Re: domoticz in synology as package! Available now.

Post by jumbotroll » Sunday 28 October 2018 19:38

ottovdv wrote:
Sunday 28 October 2018 19:13
On Sourceforge I found the synology toolchains for DSM 6.2.
Any chance somebody can use this to make Domoticz available for the DS211j with the Marvell Kirkwood 88f6281?

https://sourceforge.net/projects/dsgpl/ ... %20Chains/
gcc is to old in this toolchain for compile newer versions of domoticz.
Latest build for 88f68x is domoticz_88f6281-6.2_3.0.9483-7.spk
http://www.jadahl.com/domoticz_beta_6.2 ... 9483-7.spk
Regards
Jumbotroll
http://www.jadahl.com

PhilippeDom
Posts: 9
Joined: Tuesday 12 December 2017 19:40
Target OS: NAS (Synology & others)
Domoticz version: 3.0.8770
Contact:

Re: domoticz in synology as package! Available now.

Post by PhilippeDom » Wednesday 31 October 2018 16:44

Hello Jumbotroll,

It seems I have some issues regarding the USB1 port where my evohome (HGI/S80) gateway is connected. I'm pretty sure that the problems started with a Synology update about four weeks ago, I did not worry about this, because most problems are usually fixed with a Domoticz update. Unfortunately, all updates so far have not resolved the connection problem with the HGI/S80 interface.

Model: DS118, Realtek RTD1296 SoC
Synology version: DSM 6.2.1-23824 Update 1
Domoticz version: V4.10119-7

I did notice that when Domoticz is running, the Synology Info Center, "General" tab would remains empty. After stopping Domoticz and restarting Synology, the "general" tab shows all synology information, including Evohome USB device: TUSB3410 Boot Device - Honeywell, Inc.

Hope you can help me out, thanks in advance,

Philippe

User avatar
jumbotroll
Posts: 696
Joined: Tuesday 13 January 2015 15:36
Target OS: NAS (Synology & others)
Domoticz version: Beta
Location: Oslo,Norway
Contact:

Re: domoticz in synology as package! Available now.

Post by jumbotroll » Wednesday 31 October 2018 17:08

PhilippeDom wrote:
Wednesday 31 October 2018 16:44
Hello Jumbotroll,

It seems I have some issues regarding the USB1 port where my evohome (HGI/S80) gateway is connected. I'm pretty sure that the problems started with a Synology update about four weeks ago, I did not worry about this, because most problems are usually fixed with a Domoticz update. Unfortunately, all updates so far have not resolved the connection problem with the HGI/S80 interface.

Model: DS118, Realtek RTD1296 SoC
Synology version: DSM 6.2.1-23824 Update 1
Domoticz version: V4.10119-7

I did notice that when Domoticz is running, the Synology Info Center, "General" tab would remains empty. After stopping Domoticz and restarting Synology, the "general" tab shows all synology information, including Evohome USB device: TUSB3410 Boot Device - Honeywell, Inc.

Hope you can help me out, thanks in advance,

Philippe
I don't think there is any changes in domoticz source with HGI/S80, so I am not sure what causes this problem.
Did you try to do a complete reinstall of domoticz package?
Take backup of domoticz.db and uninstall domoticz and reinstall.
I don't use HGI/S80 so I can't test it.
Regards
Jumbotroll
http://www.jadahl.com

PhilippeDom
Posts: 9
Joined: Tuesday 12 December 2017 19:40
Target OS: NAS (Synology & others)
Domoticz version: 3.0.8770
Contact:

Re: domoticz in synology as package! Available now.

Post by PhilippeDom » Thursday 01 November 2018 17:01

I did uninstall and install Domoticz, but the problem remains the same. I don't think the (HGI/S80) is the problem, but USB port is not initialized correctly.
Is it possible that the USB driver with Domoticz is not supported with my synology update?

Tx. Philippe
jumbotroll wrote:
Wednesday 31 October 2018 17:08
PhilippeDom wrote:
Wednesday 31 October 2018 16:44
Hello Jumbotroll,

It seems I have some issues regarding the USB1 port where my evohome (HGI/S80) gateway is connected. I'm pretty sure that the problems started with a Synology update about four weeks ago, I did not worry about this, because most problems are usually fixed with a Domoticz update. Unfortunately, all updates so far have not resolved the connection problem with the HGI/S80 interface.

Model: DS118, Realtek RTD1296 SoC
Synology version: DSM 6.2.1-23824 Update 1
Domoticz version: V4.10119-7

I did notice that when Domoticz is running, the Synology Info Center, "General" tab would remains empty. After stopping Domoticz and restarting Synology, the "general" tab shows all synology information, including Evohome USB device: TUSB3410 Boot Device - Honeywell, Inc.

Hope you can help me out, thanks in advance,

Philippe
I don't think there is any changes in domoticz source with HGI/S80, so I am not sure what causes this problem.
Did you try to do a complete reinstall of domoticz package?
Take backup of domoticz.db and uninstall domoticz and reinstall.
I don't use HGI/S80 so I can't test it.

User avatar
jumbotroll
Posts: 696
Joined: Tuesday 13 January 2015 15:36
Target OS: NAS (Synology & others)
Domoticz version: Beta
Location: Oslo,Norway
Contact:

Re: domoticz in synology as package! Available now.

Post by jumbotroll » Thursday 01 November 2018 18:07

PhilippeDom wrote:
Thursday 01 November 2018 17:01
I did uninstall and install Domoticz, but the problem remains the same. I don't think the (HGI/S80) is the problem, but USB port is not initialized correctly.
Is it possible that the USB driver with Domoticz is not supported with my synology update?

Tx. Philippe
Maybe USB driver change?
Did this happend when update from DSM 6.1 to DSM 6.2 ??
Please log in with Telnet or SSH and Type: dmesg

Check if there is any error with drivers and copy/paste result here..
Regards
Jumbotroll
http://www.jadahl.com

PhilippeDom
Posts: 9
Joined: Tuesday 12 December 2017 19:40
Target OS: NAS (Synology & others)
Domoticz version: 3.0.8770
Contact:

Re: domoticz in synology as package! Available now.

Post by PhilippeDom » Friday 02 November 2018 16:02

Hi,

Here's the dmesg. I hope that you can figure this out. Tx, Philippe
Attachments
dmsg.png
dmsg.png (46.4 KiB) Viewed 400 times

Gravityz
Posts: 284
Joined: Wednesday 16 December 2015 20:13
Target OS: NAS (Synology & others)
Domoticz version: V3.8637
Location: Netherlands
Contact:

Re: domoticz in synology as package! Available now.

Post by Gravityz » Saturday 03 November 2018 18:55

with version 10159 and a hardware/software modification i can confirm the RFXCOM XL is now working very well with a P1 smart meter.
Thanks Jumbotroll for supplying the right versions for the Synology Apollolake

michass
Posts: 23
Joined: Tuesday 27 March 2018 14:39
Target OS: NAS (Synology & others)
Domoticz version: 4.10064
Location: Gdynia
Contact:

Re: domoticz in synology as package! Available now.

Post by michass » Monday 05 November 2018 20:41

Hi,
I have 4.10171 for Armada37xx and events don't work :(
please help!


Edit, Now is working, i see new layout of events page :D
Synology NAS
Heating: eq-3 MAX!
Vent: by Sonoff POW R2 & Espeasy
Cam: Foscam C1

nono212
Posts: 31
Joined: Sunday 18 December 2016 14:47
Target OS: Linux
Domoticz version: 3.6179
Contact:

Re: domoticz in synology as package! Available now.

Post by nono212 » Wednesday 07 November 2018 16:35

Hi Jumbotroll
I upgrade my 218+to DSM 6.2.1-23824 Update 1 ( it was a bad idea )
And Now I have an alarm in the system health :
DSM cannot start up normally because it ran into a problem .please contact synology .
I open a ticket and I send them the logs ...it seems there is a problem with the domoticz package so they asks me to reinstall all the system
Can you please help ?

Regards

User avatar
jumbotroll
Posts: 696
Joined: Tuesday 13 January 2015 15:36
Target OS: NAS (Synology & others)
Domoticz version: Beta
Location: Oslo,Norway
Contact:

Re: domoticz in synology as package! Available now.

Post by jumbotroll » Wednesday 07 November 2018 17:05

nono212 wrote:
Wednesday 07 November 2018 16:35
Hi Jumbotroll
I upgrade my 218+to DSM 6.2.1-23824 Update 1 ( it was a bad idea )
And Now I have an alarm in the system health :
DSM cannot start up normally because it ran into a problem .please contact synology .
I open a ticket and I send them the logs ...it seems there is a problem with the domoticz package so they asks me to reinstall all the system
Can you please help ?

Regards
I don't know why you have alarm in system health..There is no another reporting this...
I also run on my DS712+ DSM 6.2.1-23824 Update 1 with no issue.
Regards
Jumbotroll
http://www.jadahl.com

Gravityz
Posts: 284
Joined: Wednesday 16 December 2015 20:13
Target OS: NAS (Synology & others)
Domoticz version: V3.8637
Location: Netherlands
Contact:

Re: domoticz in synology as package! Available now.

Post by Gravityz » Wednesday 07 November 2018 17:52

also use DSM 6.2.1-23824 Update 1 on a DS718+
no problems either.

did you perhaps run a really old domoticz, made for and older dsm version.

Davlent
Posts: 3
Joined: Tuesday 06 November 2018 12:35
Target OS: NAS (Synology & others)
Domoticz version: V4.10181
Location: Belgium
Contact:

Re: domoticz in synology as package! Available now.

Post by Davlent » Thursday 08 November 2018 20:21

Hi Jumbotroll,

I'm facing problems to connect an HGI80 Honeywell on my Syno DS412+ (DSM 6.2.1-23824 Update 1)
I never connected it, HGI80 were in a box in the garage, I never used it, then I decided to try to use it with domoticz (Beta 4.10.157)(one week ago +/-).
I read a lot of information to can connect it on Domo/syno and have installed your driver packages.
I also use an RFXCOM who is working fine and use USBtt0 on my syno.
I don't receive any errors when I go to Dmseg/lsusb and usb-devices (only a driver = none in usb-devices fot Texas Inst).
I see a difference in lsusb and in usb-drivers when HGI connected or not.
Syno seems then to see HGI80 is connected but no USBttx is mounted.
I don't use Evohome but a 'simple' DTS92 thermostat who seems also to work fine.
From what I also read in different forums, HGI80 don't need to be nonnected to an Evohome or to a thermostat to be recognized by Syno.
I asked Syno support but they answered me that hardware HGI80 is not supported by them.
I'm a little lost, can you help me ?

Regards,
David.

Code: Select all

Lsusb
 
Bus 002 Device 002: ID f400:f400
Bus 005 Device 003: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 007 Device 004: ID 10ac:0102 Honeywell, Inc.
Bus 008 Device 002: ID 174c:55aa ASMedia Technology Inc. ASMedia 2105 SATA bridge
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Code: Select all

dmesg

[  163.538396] usbcore: registered new interface driver usbserial
[  163.616424] usbcore: registered new interface driver ftdi_sio
[  163.622370] usbserial: USB Serial support registered for FTDI USB Serial Device
[  163.630299] ftdi_sio 7-1:1.0: FTDI USB Serial Device converter detected
[  163.637082] usb 7-1: Detected FT232RL
[  163.640857] usb 7-1: Number of endpoints 2
[  163.645104] usb 7-1: Endpoint 1 MaxPacketSize 64
[  163.649807] usb 7-1: Endpoint 2 MaxPacketSize 64
[  163.654485] usb 7-1: Setting MaxPacketSize 64
[  163.665444] usb 7-1: FTDI USB Serial Device converter now attached to ttyUSB0
[  163.788716] cp210x: module verification failed: signature and/or required key missing - tainting kernel
[  163.798654] usbcore: registered new interface driver cp210x
[  163.804374] usbserial: USB Serial support registered for cp210x
[  163.869812] usbcore: registered new interface driver pl2303
[  163.875552] usbserial: USB Serial support registered for pl2303
[  163.953669] usbcore: registered new interface driver ch341
[  163.959329] usbserial: USB Serial support registered for ch341-uart
[  163.997411] usbcore: registered new interface driver ti_usb_3410_5052
[  164.004220] usbserial: USB Serial support registered for TI USB 3410 1 port adapter
[  164.012069] usbserial: USB Serial support registered for TI USB 5052 2 port adapter
[  169.182161] ip_tables: (C) 2000-2006 Netfilter Core Team
[  172.392767] init: pkg-WebStation-userdir main process (13728) terminated with status 1
[  181.547404] init: upnpd main process (8141) killed by KILL signal
[  181.831155] ip_tables: (C) 2000-2006 Netfilter Core Team
[  191.838816] usbcore: registered new interface driver snd-usb-audio
[  192.022799] usbcore: registered new interface driver snd-usb-hiface
[  193.715492] perf interrupt took too long (2539 > 5000), lowering kernel.perf_event_max_sample_rate to 50000
[  197.422401] init: pkg-WebStation-userdir main process (16112) terminated with status 1
[  202.926178] init: nmbd main process (16664) killed by TERM signal
[  226.930749] ip_tables: (C) 2000-2006 Netfilter Core Team
[  265.447790] ip_tables: (C) 2000-2006 Netfilter Core Team
[  312.914312] usb 5-2: USB disconnect, device number 2
[  319.054410] usb 7-1: USB disconnect, device number 2
[  319.059824] ftdi_sio ttyUSB0: FTDI USB Serial Device converter now disconnected from ttyUSB0
[  319.068387] ftdi_sio 7-1:1.0: device disconnected
[  360.614116] usb 7-1: new full-speed USB device number 3 using xhci_hcd
[  536.663167] usb 5-2: new full-speed USB device number 3 using uhci_hcd
[  536.880247] ftdi_sio 5-2:1.0: FTDI USB Serial Device converter detected
[  536.886950] usb 5-2: Detected FT232RL
[  536.890640] usb 5-2: Number of endpoints 2
[  536.894773] usb 5-2: Endpoint 1 MaxPacketSize 64
[  536.899422] usb 5-2: Endpoint 2 MaxPacketSize 64
[  536.904086] usb 5-2: Setting MaxPacketSize 64
[  536.911254] usb 5-2: FTDI USB Serial Device converter now attached to ttyUSB0
[  998.224651] usb 7-1: USB disconnect, device number 3
[ 1047.906668] usb 7-1: new full-speed USB device number 4 using xhci_hcd

Code: Select all

usb-devices

T:  Bus=07 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  4 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=ff(vend.) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=10ac ProdID=0102 Rev=01.01
S:  Manufacturer=Texas Instruments
S:  Product=TUSB3410 Boot Device
S:  SerialNumber=TUSB3410
C:  #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)

User avatar
jumbotroll
Posts: 696
Joined: Tuesday 13 January 2015 15:36
Target OS: NAS (Synology & others)
Domoticz version: Beta
Location: Oslo,Norway
Contact:

Re: domoticz in synology as package! Available now.

Post by jumbotroll » Thursday 08 November 2018 21:23

Davlent wrote:
Thursday 08 November 2018 20:21
Hi Jumbotroll,

I'm facing problems to connect an HGI80 Honeywell on my Syno DS412+ (DSM 6.2.1-23824 Update 1)
I never connected it, HGI80 were in a box in the garage, I never used it, then I decided to try to use it with domoticz (Beta 4.10.157)(one week ago +/-).
I read a lot of information to can connect it on Domo/syno and have installed your driver packages.
I also use an RFXCOM who is working fine and use USBtt0 on my syno.
I don't receive any errors when I go to Dmseg/lsusb and usb-devices (only a driver = none in usb-devices fot Texas Inst).
I see a difference in lsusb and in usb-drivers when HGI connected or not.
Syno seems then to see HGI80 is connected but no USBttx is mounted.
I don't use Evohome but a 'simple' DTS92 thermostat who seems also to work fine.
From what I also read in different forums, HGI80 don't need to be nonnected to an Evohome or to a thermostat to be recognized by Syno.
I asked Syno support but they answered me that hardware HGI80 is not supported by them.
I'm a little lost, can you help me ?

Regards,
David.
Sorry, but I don't have this hardware HGI80 and can't troubleshoot.
Edit: the vendor id in driver for HGI80 was not added in kernel, and I have added the vendor id.
I will build new domoticz version for cedarview you can test..
Regards
Jumbotroll
http://www.jadahl.com

Davlent
Posts: 3
Joined: Tuesday 06 November 2018 12:35
Target OS: NAS (Synology & others)
Domoticz version: V4.10181
Location: Belgium
Contact:

Re: domoticz in synology as package! Available now.

Post by Davlent » Friday 09 November 2018 10:59

jumbotroll wrote:
Thursday 08 November 2018 21:23

Edit: the vendor id in driver for HGI80 was not added in kernel, and I have added the vendor id.
I will build new domoticz version for cedarview you can test..
Hi Jumbotroll, thanks ! I'm happy you found this missing :-) you make my day ;-)
It is not hurry for me, then take the time you need to adapt cedarview.
Read you later, kind regards
David.

Edit: I just saw you modified last cedarview, HGI80 i s now recognized, many thanks for the work done !! :D :D

PhilippeDom
Posts: 9
Joined: Tuesday 12 December 2017 19:40
Target OS: NAS (Synology & others)
Domoticz version: 3.0.8770
Contact:

Re: domoticz in synology as package! Available now.

Post by PhilippeDom » Saturday 10 November 2018 12:35

Hi Jumbotroll,

Is it possible to also update the RTD1296? I think that I have the same problem as David.

Tx. Philippe

Davlent wrote:
Friday 09 November 2018 10:59
jumbotroll wrote:
Thursday 08 November 2018 21:23

Edit: the vendor id in driver for HGI80 was not added in kernel, and I have added the vendor id.
I will build new domoticz version for cedarview you can test..
Hi Jumbotroll, thanks ! I'm happy you found this missing :-) you make my day ;-)
It is not hurry for me, then take the time you need to adapt cedarview.
Read you later, kind regards
David.

Edit: I just saw you modified last cedarview, HGI80 i s now recognized, many thanks for the work done !! :D :D

User avatar
jumbotroll
Posts: 696
Joined: Tuesday 13 January 2015 15:36
Target OS: NAS (Synology & others)
Domoticz version: Beta
Location: Oslo,Norway
Contact:

Re: domoticz in synology as package! Available now.

Post by jumbotroll » Saturday 10 November 2018 13:28

PhilippeDom wrote:
Saturday 10 November 2018 12:35
Hi Jumbotroll,

Is it possible to also update the RTD1296? I think that I have the same problem as David.

Tx. Philippe
The vendor id was added in arch-rtd1296 kernel, so this is a different bug.
I have found some code change in this driver for linux kernel 4.4.58 for rtd-1296 and will try to fix it.
I will give you a link to a updated domoticz build in 20 min here for you to test.
If this don't work, I don't know if I can fix this for you..

Edit:
USB: serial: ti_usb_3410_5052: fix array underflow in completion handler on linux kernel 4.4.58.
Test the latest build and before you install, please uninstall old domoticz and if you have installed USBSerial package remove this and only install the latest domoticz build.
domoticz_rtd1296-6.2_4.0.10181-7.spk
http://www.jadahl.com/domoticz_beta_6.2/
Regards
Jumbotroll
http://www.jadahl.com

PhilippeDom
Posts: 9
Joined: Tuesday 12 December 2017 19:40
Target OS: NAS (Synology & others)
Domoticz version: 3.0.8770
Contact:

Re: domoticz in synology as package! Available now.

Post by PhilippeDom » Saturday 10 November 2018 16:35

Hi Jumbotroll,

Unfortunately, this update pkg (domoticz_rtd1296-6.2_4.0.10181-7.spk) did not fix the problem. I did uninstall Domoticz, reinstall the new version and reloaded the last backup. Then I restarted the system multiple times, somtimes with Domoticz started and sometimes stopped, but the result and Dmesg message is still the same, and from within domoticz, I'm still not able to find the USB port where the HGI80 is connected. I've attached the dmesg log.


Thanks for the support, it's appreciated.



jumbotroll wrote:
Saturday 10 November 2018 13:28
PhilippeDom wrote:
Saturday 10 November 2018 12:35
Hi Jumbotroll,

Is it possible to also update the RTD1296? I think that I have the same problem as David.

Tx. Philippe
The vendor id was added in arch-rtd1296 kernel, so this is a different bug.
I have found some code change in this driver for linux kernel 4.4.58 for rtd-1296 and will try to fix it.
I will give you a link to a updated domoticz build in 20 min here for you to test.
If this don't work, I don't know if I can fix this for you..

Edit:
USB: serial: ti_usb_3410_5052: fix array underflow in completion handler on linux kernel 4.4.58.
Test the latest build and before you install, please uninstall old domoticz and if you have installed USBSerial package remove this and only install the latest domoticz build.
domoticz_rtd1296-6.2_4.0.10181-7.spk
http://www.jadahl.com/domoticz_beta_6.2/
Attachments
dmsg1.png
dmsg1.png (35.28 KiB) Viewed 223 times

User avatar
jumbotroll
Posts: 696
Joined: Tuesday 13 January 2015 15:36
Target OS: NAS (Synology & others)
Domoticz version: Beta
Location: Oslo,Norway
Contact:

Re: domoticz in synology as package! Available now.

Post by jumbotroll » Saturday 10 November 2018 18:07

PhilippeDom wrote:
Saturday 10 November 2018 16:35
Hi Jumbotroll,

Unfortunately, this update pkg (domoticz_rtd1296-6.2_4.0.10181-7.spk) did not fix the problem. I did uninstall Domoticz, reinstall the new version and reloaded the last backup. Then I restarted the system multiple times, somtimes with Domoticz started and sometimes stopped, but the result and Dmesg message is still the same, and from within domoticz, I'm still not able to find the USB port where the HGI80 is connected. I've attached the dmesg log.


Thanks for the support, it's appreciated.
Hmm .. I have no clue what this may be.
I see that this NAS only has 1GB of memory and maybe you have other applications that require a lot of memory and that it therefore crashes.
Try and stop other applications that might require a lot of memory and restart NAS. No other arch-rtd1296 users have reported this problem, so it may be a combination of software / hardware issues?
If you are using USB HUB, try unplugging this.
Regards
Jumbotroll
http://www.jadahl.com

Gravityz
Posts: 284
Joined: Wednesday 16 December 2015 20:13
Target OS: NAS (Synology & others)
Domoticz version: V3.8637
Location: Netherlands
Contact:

Re: domoticz in synology as package! Available now.

Post by Gravityz » Saturday 10 November 2018 20:19

Hi Jumbotroll,
do you have any idea how to get logrotate working on a synology.
i see lots of info, logrotate scripts but do not have any idea which script is for synology, where to put it and how that script automatically is started
some say crontab, some say truncate.

the logfile is in
/usr/local/domoticz/var

logrotate script is in
/usr/local/domoticz/var/scripts/logrotate

file is called domoticz and has 0644 rights
/usr/local/domoticz/var/domoticz.log
{
missingok
weekly
rotate 4
compress
notifempty
postrotate
if [ -x /usr/sbin/invoke-rc.d ]; then \
invoke-rc.d domoticz reload > /dev/null; \
else \
/etc/init.d/domoticz reload > /dev/null; \
fi
endscript
}

Post Reply

Who is online

Users browsing this forum: DutchHans and 0 guests