[Solved] Virtual Switches in Events scripts Topic is solved

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
manubis
Posts: 5
Joined: Saturday 07 January 2017 18:10
Target OS: NAS (Synology & others)
Domoticz version: 4.9700
Contact:

[Solved] Virtual Switches in Events scripts

Post by manubis » Friday 09 November 2018 20:58

Hello,

I created a virtual switch that I can't find in Devices - Switches. I have 3 switches but in this panel I can find 4 devices including 2 which say "No device found". I tried to clean the cache, to restart my NAS, "Accept new hardware devices" is activated but the problem is still here.

Thanks for your help.

Manubis

Domoticz 4.9700 on Synology DSM 6.2.1.
Last edited by manubis on Saturday 10 November 2018 11:31, edited 1 time in total.

User avatar
waaren
Posts: 1238
Joined: Tuesday 03 January 2017 15:18
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Virtual Switches in Events scripts

Post by waaren » Friday 09 November 2018 22:50

manubis wrote:
Friday 09 November 2018 20:58
I created a virtual switch that I can't find in Devices - Switches. I have 3 switches but in this panel I can find 4 devices including 2 which say "No device found". I tried to clean the cache, to restart my NAS, "Accept new hardware devices" is activated but the problem is still here.
For me it not completely clear from your post what your problem is. It might help if you could show some screenshots.
Raspberry (debian stretch via berryboot on Synology DS916+) , Domoticz (almost) latest Beta, , dzVents 2.6, RFLink, RFXtrx433e, P1, Youless, Harmony, Hue, Yeelight, Xiaomi, HomeWizard, Zwave, Amazon echo

manubis
Posts: 5
Joined: Saturday 07 January 2017 18:10
Target OS: NAS (Synology & others)
Domoticz version: 4.9700
Contact:

Re: Virtual Switches in Events scripts

Post by manubis » Saturday 10 November 2018 10:53

Sure !

Image
Image

I don't kwow what are this two switches with "no device found".

elmortero
Posts: 238
Joined: Sunday 29 November 2015 21:46
Target OS: Raspberry Pi
Domoticz version: 3.9639
Location: Spain
Contact:

Re: Virtual Switches in Events scripts

Post by elmortero » Saturday 10 November 2018 11:21

That means you have no switches whose names start with a letter in the range indicated on the left (G-L) for example.
Also, all of those blocks have an arrow pointing downward. If you click that you will see the other switches that you are currently not seeing.

manubis
Posts: 5
Joined: Saturday 07 January 2017 18:10
Target OS: NAS (Synology & others)
Domoticz version: 4.9700
Contact:

Re: Virtual Switches in Events scripts

Post by manubis » Saturday 10 November 2018 11:30

Oh thank you ! I feel dumb but happy to know how it works !

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests