Cannot change 1-wire temperature sensor poll period

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
Sipowitz
Posts: 7
Joined: Wednesday 06 June 2018 19:00
Target OS: Linux
Domoticz version:
Contact:

Cannot change 1-wire temperature sensor poll period

Post by Sipowitz » Monday 05 November 2018 22:22

Hi

I am currently running Domoticz version 4.10145 on a Raspberry Pi 2. I am using a 1 Wire Pi Zero HAT to connect up 9 1-wire temperature probes which are connected to my central heating system.

I believe I may have found a bug in that no matter what settings I use for the "Sensor Poll Period" setting in the hardware setup page my sensors update at roughly 30 second intervals.

Code: Select all

 
 2018-11-05 20:03:09.574 (1wire) Temp (Hot Water Flow)
2018-11-05 20:03:40.350 (1wire) Temp (Central Heating Return)
2018-11-05 20:04:11.171 (1wire) Temp (Hot Water Return)
2018-11-05 20:04:41.991 (1wire) Temp (Central Heating Flow)
2018-11-05 20:05:12.811 (1wire) Temp (Hot Water Tank - Mid)
2018-11-05 20:05:43.630 (1wire) Temp (Hot Water Tank - Bottom)
2018-11-05 20:06:14.452 (1wire) Temp (Hot Water Tank - Upper Mid)
2018-11-05 20:06:45.272 (1wire) Temp (Hot Water Tank - Lower Mid)
2018-11-05 20:07:16.096 (1wire) Temp (Hot Water Tank - Top)
2018-11-05 20:08:20.673 (1wire) Temp (Hot Water Flow)
2018-11-05 20:08:51.442 (1wire) Temp (Central Heating Return)
2018-11-05 20:09:22.261 (1wire) Temp (Hot Water Return)
2018-11-05 20:09:53.082 (1wire) Temp (Central Heating Flow)
2018-11-05 20:10:23.907 (1wire) Temp (Hot Water Tank - Mid)
2018-11-05 20:10:54.731 (1wire) Temp (Hot Water Tank - Bottom) 
The above log snippet is with both "Sensor Poll Period" and "Switch Poll Period" set to 10 milliseconds. I have tried various settings up to 1 minute and the update interval seems to remain at roughly 30 seconds.

If I change the settings to say 10 milliseconds and then press the update button I can see the 1-wire threads starting and stopping and then the sensors update more frequently, however they soon begin the 30 second cycle again:

Code: Select all

 
 2018-11-05 19:49:24.262 Status: 1-Wire: Sensor thread terminating
2018-11-05 19:49:24.262 Status: 1-Wire: Switch thread terminating
2018-11-05 19:49:24.273 Status: Using 1-Wire support (OWFS)...
2018-11-05 19:49:24.262 Error: RxQueue: cannot retrieve hardware with id: 8
2018-11-05 19:54:52.529 (1wire) Temp (Hot Water Tank - Mid)
2018-11-05 19:55:23.364 (1wire) Temp (Hot Water Tank - Bottom)
2018-11-05 19:55:54.189 (1wire) Temp (Hot Water Tank - Upper Mid)
2018-11-05 19:56:25.020 (1wire) Temp (Hot Water Tank - Lower Mid) 
I'm at a loss as to what to do as the domoticz log does not provide much information. Is there a lower level log file I could view?


Many Thanks

Sip

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests