RFXtrx433XL : invalid data received - version 0

On various Hardware and OS systems: pi / windows / routers / nas, etc
Post Reply
benp
Posts: 12
Joined: Saturday 21 May 2016 20:12
Target OS: Raspberry Pi
Domoticz version: V3.8153
Location: France
Contact:

RFXtrx433XL : invalid data received - version 0

Post by benp » Saturday 27 October 2018 11:20

Hello,

I am unable to SetMode in rfxcom pannel: I return to Dashboard and all devices stay to red (disable).

Here is my log file:

Code: Select all

 2018-10-27 10:22:16.378 Status: RFXCOM: Using serial port: /dev/ttyUSB1
2018-10-27 10:24:31.684 Error: RFXCOM: Invalid data received!....
2018-10-27 10:24:35.609 subtype = Interface Command
2018-10-27 10:24:35.609 Sequence nbr = 3
2018-10-27 10:24:35.609 set configuration of the interface 
domoticz v4.9700 on raspberry Raspbian Stretch Lite
RFXtrx433XL update to the last firmware: RFXtrx433XL_ProXL1_1031.hex

Here is what I tried:
  • I tried to restart domoticz (stop/unplug/restart)
  • Hardware is enable
  • RFXtrx433XL is on /dev/ttyUSB1
  • Zigate is on /dev/ttyUSB0
  • I have version 0
  • I have read the post: RFXtrx433 Version 0
  • I have a RFXtrx433E on another raspberry and manualy copy the same config
  • RFXtrx433XL can update firmwae
  • RFXtrx433XL can detect oregon THGR810 with the RFXmngr software on W10
Thank you

Regards

benp
Posts: 12
Joined: Saturday 21 May 2016 20:12
Target OS: Raspberry Pi
Domoticz version: V3.8153
Location: France
Contact:

Re: RFXtrx433XL : invalid data received - version 0

Post by benp » Sunday 28 October 2018 10:10

Does somebody was able to successfully use the new RFXtrx433XL with domoticz stable 4.9700?

antwan
Posts: 303
Joined: Saturday 13 July 2013 13:28
Target OS: Linux
Domoticz version: Latest
Location: Hilversum, The Netherlands
Contact:

RFXtrx433XL : invalid data received - version 0

Post by antwan » Sunday 28 October 2018 10:59

Yep i do, without any problem.

I only use the latest beta....
Rasp Pi 2B: 3x DS18S20 (1-wire), BME280 (i2c)
Cubietruck 1: Aeotec Z-Wave+, RFXtrx433E, RFXtrx868, P1 Converter, TE923 display, Voltcraft CO-20, SolarEdge proxy
Cubietruck 2: Aeotec Z-Wave, RFXtrx433E

benp
Posts: 12
Joined: Saturday 21 May 2016 20:12
Target OS: Raspberry Pi
Domoticz version: V3.8153
Location: France
Contact:

Re: RFXtrx433XL : invalid data received - version 0

Post by benp » Sunday 28 October 2018 12:15

Thank you antwan.
Did you test with the stable before beta?
What beta version number is OK?

antwan
Posts: 303
Joined: Saturday 13 July 2013 13:28
Target OS: Linux
Domoticz version: Latest
Location: Hilversum, The Netherlands
Contact:

Re: RFXtrx433XL : invalid data received - version 0

Post by antwan » Sunday 28 October 2018 21:32

Im always on the beta channel, and i never look back.
Rasp Pi 2B: 3x DS18S20 (1-wire), BME280 (i2c)
Cubietruck 1: Aeotec Z-Wave+, RFXtrx433E, RFXtrx868, P1 Converter, TE923 display, Voltcraft CO-20, SolarEdge proxy
Cubietruck 2: Aeotec Z-Wave, RFXtrx433E

RueDesButtes
Posts: 9
Joined: Monday 26 March 2018 10:13
Target OS: Raspberry Pi
Domoticz version: 3.8153
Contact:

Re: RFXtrx433XL : invalid data received - version 0

Post by RueDesButtes » Monday 26 November 2018 19:42

Hello,
I have been able to use it on the stable version during 2 weeks,
now i have only the following:
  • 2018-11-26 17:28:55.928 Error: RFXCOM: input buffer out of sync, going to restart!....
  • 2018-11-26 18:34:38.003 Error: RFXCOM: Invalid data received!....
it seems fine on RFXmngr,
I have updated to the 1032 firmware, no difference.

RueDesButtes
Posts: 9
Joined: Monday 26 March 2018 10:13
Target OS: Raspberry Pi
Domoticz version: 3.8153
Contact:

Re: RFXtrx433XL : invalid data received - version 0

Post by RueDesButtes » Monday 26 November 2018 20:23

i have reboot the pi,
deleted the RFXCOM hardware, created a new one (and changed the usb port) something happened at the usb management
now it is fine.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests