open zwave 1.4 not supporting Eurotronic SPIRIT Thermostat properly

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
User avatar
raymond1972
Posts: 4
Joined: Wednesday 28 February 2018 14:00
Target OS: Raspberry Pi
Domoticz version: 4.9796
Contact:

open zwave 1.4 not supporting Eurotronic SPIRIT Thermostat properly

Post by raymond1972 » Friday 12 October 2018 21:29

Hi,

This post is to gizmocus.
Can you tell me when the 1.5 version from open zwave is supported in domoticz?
In the current 1.4 version my Eurotronics SPIRIT thermostat is not supported.
I already tried to fix the suggestions in viewtopic.php?t=21417 to correct the xml files.
That helped to include the thermostat and I am able to use the configuration parameters for example invert the display.
The thermostat reacts properly. But when I try to control the setpoint it won't react properly.

I quick analyse lead me to https://github.com/OpenZWave/open-zwave/issues/1340 where the problem is mentioned in regarding to "Implementations of Thermostat Setpoint Command Class, version 3 MUST comply with Interpretation A."

So I hope the newer domoticz version supports 1.5 version of open zwave.
HW:Raspberry Pi 3 B, Pi B,Nano w, Aeon Labs Aeotec Gen 5 Z-Wave USB

Post Reply

Who is online

Users browsing this forum: cencen, Google [Bot] and 5 guests