Fedora requirements

On various Hardware and OS systems: pi / windows / routers / nas, etc
Post Reply
meyland
Posts: 17
Joined: Wednesday 03 January 2018 17:39
Target OS: Linux
Domoticz version: V3.8153
Location: Denmark
Contact:

Fedora requirements

Post by meyland » Friday 31 August 2018 20:47

Hi

I'm trying to build domotics from source on my Fedora 28 system, but I can't find any requirementslist.

I've done this: which give me:

Code: Select all

-- Failed to get ProjectRevision from git
-- Read ProjectRevision from appversion.default
-- ###########################
-- Compiling Revision #9700
-- ###########################
-- Using builtin Mosquitto library
-- Could NOT find OpenSSL, try to set the path to OpenSSL root folder in the system variable OPENSSL_ROOT_DIR (missing: OPENSSL_CRYPTO_LIBRARY) (found version "1.1.0h")
-- Failed to find the openssl library, no TLS support
-- Could NOT find PythonLibs (missing: PYTHON_LIBRARIES PYTHON_INCLUDE_DIRS) (Required is at least version "3.4")
CMake Error at CMakeLists.txt:134 (MESSAGE):
  Python3 not found on your system, use USE_PYTHON=NO or sudo apt-get install
  python3-dev)


-- Configuring incomplete, errors occurred!
See also "/home/peterm/udvikling/_git/domoticz/CMakeFiles/CMakeOutput.log".
Is there a list over requeriments? The INSTALL.md found here does not give me any hints
regards

Peter

liderbug
Posts: 41
Joined: Monday 02 January 2017 18:30
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Fedora requirements

Post by liderbug » Friday 23 November 2018 23:14

I'm having the same problem. It started with a new load of FC29 and dnf install domoticz. When I start dom I get a python err and it quits. Seems the src is all Ubuntu.

:cry:

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests