Editing switches doesn't work

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
Posts: 1
Joined: Saturday 25 August 2018 17:02
Target OS: Raspberry Pi
Domoticz version:

Editing switches doesn't work

Post by astra » Saturday 25 August 2018 17:05

When I'm trying to edit switches the save button doesn't work no matter what I try. Doesn't matter what kind of switch it is.

Error in the Chrome console:
Spoiler: show
angular.min.js:124 ReferenceError: b64DecodeUnicode is not defined
at DeviceLightEdit.js:495
at angular.min.js:137
at m.$digest (angular.min.js:148)
at m.$apply (angular.min.js:151)
at l (angular.min.js:103)
at t (angular.min.js:108)
at XMLHttpRequest.A.onload (angular.min.js:109) "Possibly unhandled rejection: {}"

Posts: 2288
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.10069
Location: The Netherlands

Re: Editing switches doesn't work

Post by SweetPants » Saturday 25 August 2018 17:16

BTW, did follow you follow the RED forum rules?

Did you recently upgrade?

goto www/js folder
if domoticz.js exists, keep it
if domoticz.js.gz exists delete it
restart domoticz
clear browser and app cache
try again
Ubuntu 16.04.5 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

User avatar
Posts: 1083
Joined: Tuesday 03 January 2017 15:18
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands

Re: Editing switches doesn't work

Post by waaren » Sunday 16 September 2018 11:37

bennyparker wrote:
Sunday 16 September 2018 10:59
They're all dummy "Selector Switch" and I just realizethat the switches where the "Edit" button works are just "Switch", in all the "Selector Switches" the "Edit" button doesn't work.
Are they intended to work this way?

I've tried with Chrome and the behavior is the same.
On my systems (RPI-3 Debian stretch / domoticz 4.9999) the edit buttons for selector type switches are just working fine.
Raspberry (debian stretch via berryboot on Synology DS916+) , Domoticz (almost) latest Beta, , dzVents 2.6, RFLink, RFXtrx433e, P1, Youless, Harmony, Hue, Yeelight, Xiaomi, HomeWizard, Zwave, Amazon echo

Posts: 7
Joined: Tuesday 02 October 2018 16:40
Target OS: Raspberry Pi
Domoticz version:

Re: Editing switches doesn't work

Post by chaimeichini » Tuesday 02 October 2018 16:44

Clear your cache – if this doesn’t work, go ahead and disable your cache for the time being while you troubleshoot this problem.
Update or reinstall WordPress – If for some reason, you are unable to reinstall WordPress through the dashboard, you will need to manually install a fresh copy through FTP or your file manager.
Update your WordPress plugins
If you get to this step without success, you will need to take some more drastic steps to diagnose the problem. If you run a busy website, you may want to consider 1). putting the site in maintenance mode or 2). copying your site to another location where you can run some tests.
Disable ALL of your plugins and reactivate them one-by-one – yes, this sounds horrible, doesn’t it? But chances are high that you WILL discover that one of your plugins is acting up. When you identify the misbehaving plugin you will probably need to find an alte
https://subwaysurfers.vip/ https://psiphon.vip/ https://hillclimbracing.vip/

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests