Blocky script not working any more after update 4.9700 Topic is solved

Post Reply
User avatar
madpatrick
Posts: 49
Joined: Monday 26 December 2016 13:17
Target OS: Linux
Domoticz version: 4.9700
Location: Netherlands
Contact:

Blocky script not working any more after update 4.9700

Post by madpatrick » Friday 10 August 2018 22:01

Hi,
I've some Nodon switches with operate some lights with a blocky script.
After the upgrade these switches are not working any more.
I see in the log the switch is operated, but nothing is happening.

Code: Select all

2018-08-10 21:54:51.732 (Zwave USB) Light/Switch (NodOn Button 3)
Image[/url]
ClearOS 7.5.0 - Toon 4.15.16 (rooted) - Domoticz 4.9700

SweetPants
Posts: 2274
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.10067
Location: The Netherlands
Contact:

Re: Blocky script not working any more after update 4.9700

Post by SweetPants » Saturday 11 August 2018 9:57

So the Blockly is working but the switch is not. Your tittle says something different. Can you manually switch?
Ubuntu 16.04.5 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

User avatar
madpatrick
Posts: 49
Joined: Monday 26 December 2016 13:17
Target OS: Linux
Domoticz version: 4.9700
Location: Netherlands
Contact:

Re: Blocky script not working any more after update 4.9700 [solved]

Post by madpatrick » Saturday 11 August 2018 18:46

Hi,

Everything was working fine. The blocky script was working and the switched were operated by the blocky script.
After the upgrade to 4.9700 the the switches were not operating any more by the script. Manually was working fine.

But, i've found the problem.
Somehow in the settings the events were not set active anymore.
When i put the check mark on active, every thing was working again.
ClearOS 7.5.0 - Toon 4.15.16 (rooted) - Domoticz 4.9700

SweetPants
Posts: 2274
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.10067
Location: The Netherlands
Contact:

Re: Blocky script not working any more after update 4.9700

Post by SweetPants » Sunday 12 August 2018 9:20

Good to hear it is working again. I think you ran into an 'old' bug where the eventsystem was switched off after upgrade. Depending on the version prior to your upgrade to V4.9700, this could well have been your problem. Can you mark this solved?
Ubuntu 16.04.5 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

kalinkamaen
Posts: 90
Joined: Sunday 04 January 2015 16:57
Target OS: Windows
Domoticz version: 4.900
Location: Norway
Contact:

Re: Blocky script not working any more after update 4.9700

Post by kalinkamaen » Thursday 04 October 2018 9:27

I have the same probolem here now. I cant figure out whats the problem. Switch is working in domoticz and motion sensor is detected in domoticz. But my event is not reacting.

Image

Image
Windows 7, Domoticz 4.9700

SweetPants
Posts: 2274
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.10067
Location: The Netherlands
Contact:

Re: Blocky script not working any more after update 4.9700

Post by SweetPants » Thursday 04 October 2018 19:21

Was this also after an upgrade? Then check if your events are still enabled (Setttings->settings->Other "EventSystem (Lua/Blockly/Scripts)"
Ubuntu 16.04.5 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

kalinkamaen
Posts: 90
Joined: Sunday 04 January 2015 16:57
Target OS: Windows
Domoticz version: 4.900
Location: Norway
Contact:

Re: Blocky script not working any more after update 4.9700

Post by kalinkamaen » Thursday 04 October 2018 22:09

No it was not directly after update. It happened after a while.

Image
Windows 7, Domoticz 4.9700

kalinkamaen
Posts: 90
Joined: Sunday 04 January 2015 16:57
Target OS: Windows
Domoticz version: 4.900
Location: Norway
Contact:

Re: Blocky script not working any more after update 4.9700

Post by kalinkamaen » Thursday 04 October 2018 22:30

Why is there difference in setting on my windows 10 computer?
Eventsystem works on this computer.

Image
Windows 7, Domoticz 4.9700

kalinkamaen
Posts: 90
Joined: Sunday 04 January 2015 16:57
Target OS: Windows
Domoticz version: 4.900
Location: Norway
Contact:

Re: Blocky script not working any more after update 4.9700

Post by kalinkamaen » Friday 05 October 2018 19:32

I have tried to uninstall Domoticz with revo uninstaller and instal it fresh again. Same problem. I cant understand whats doing this. :(
Windows 7, Domoticz 4.9700

kalinkamaen
Posts: 90
Joined: Sunday 04 January 2015 16:57
Target OS: Windows
Domoticz version: 4.900
Location: Norway
Contact:

Re: Blocky script not working any more after update 4.9700

Post by kalinkamaen » Monday 15 October 2018 22:06

Please help me here.

I have reinstalled fresh windows 10. Blocky worked for +- 5 days. Now its fucked again. I have done nothing.
Windows 7, Domoticz 4.9700

SweetPants
Posts: 2274
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.10067
Location: The Netherlands
Contact:

Re: Blocky script not working any more after update 4.9700

Post by SweetPants » Tuesday 16 October 2018 8:50

Please watch your language, it's an international forum. Are you willing to upgrade to the latest Beta?
Ubuntu 16.04.5 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

Post Reply

Who is online

Users browsing this forum: kalinkamaen and 0 guests