[Solved] Zipato RGBW bulb 2 no rgb function

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
peet3kabo
Posts: 49
Joined: Thursday 05 July 2018 17:29
Target OS: -
Domoticz version:
Contact:

[Solved] Zipato RGBW bulb 2 no rgb function

Post by peet3kabo » Friday 10 August 2018 17:28

I have the bulb mentioned in the title and have another topic about this problem:
https://r.tapatalk.com/shareLink?url=ht ... are_type=t

Domoticz only sees the bulb as a led dimmable bulb and that is the only function that I get.
Read somewhere that Domoticz doesn't completly support this bulb yet.
Something that might be solved in the near future?

Would like to use it as an RGBW bulb like it supported to be used like.

Edit:
Solution:
Got an answer from somebody to adjust the RGBBulb2.XML file.

You can find the answer here:
https://gathering.tweakers.net/forum/li ... es/1869961


Adjust config file for Zipato Bulb2 (~/domoticz/Config/ZipatoRGBBulb2.xml). The <CommandClass id="51"> needs to be replaced with the following:

Code: Select all

<CommandClass id="51" name="COMMAND_CLASS_COLOR" version="1" request_flags="2" innif="true" colorchannels="31"> 
 <Instance index="1" /> 
 <Value type="string" genre="user" instance="1" index="0" label="Color" units="#RRGGBBWWCW" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="#8888000000" /> <Value type="list" genre="user" instance="1" index="1" label="Color Index" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" vindex="17" size="0">
      <Item label="Off" value="0" /> 
      <Item label="Cool White" value="1" />
      <Item label="Warm White" value="2" />
      <Item label="Red" value="3" /> 
      <Item label="Lime" value="4" /> 
      <Item label="Blue" value="5" /> 
      <Item label="Yellow" value="6" /> 
      <Item label="Cyan" value="7" /> 
      <Item label="Magenta" value="8" /> 
      <Item label="Silver" value="9" /> 
      <Item label="Gray" value="10" /> 
      <Item label="Maroon" value="11" /> 
      <Item label="Olive" value="12" /> 
      <Item label="Green" value="13" /> 
      <Item label="Purple" value="14" /> 
      <Item label="Teal" value="15" /> 
      <Item label="Navy" value="16" /> 
      <Item label="Custom" value="17" /> 
  </Value> 
  <Value type="int" genre="system" instance="1" index="2" label="Color Channels" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="-2147483648" max="2147483647" value="31" /> 
</CommandClass>

Edit:
Don't know how to get the code visible yet, working on it.

Verstuurd vanaf mijn SM-G935F met Tapatalk









Last edited by peet3kabo on Friday 10 August 2018 17:28, edited 8 times in total.

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests