Domoticz does not see my Philips Hue switches

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
Dave47
Posts: 14
Joined: Thursday 19 July 2018 14:36
Target OS: -
Domoticz version: 4.10178
Contact:

Domoticz does not see my Philips Hue switches

Post by Dave47 » Friday 27 July 2018 12:18

Wat have i done:

In Hue:
Removed them from the used devices and re-added them: still not working
Disabled the Hue hardware and re-enabled: still not working
Deleted the Hue hardware and all devices. Re-connected everything: still not working!


With clib api debugger i can switch the light on and off using

Code: Select all

http://192.168.178.24:80/api/api/lights/7/state

put

Code: Select all

{"on": false}
and

Code: Select all

http://192.168.178.24:80/api/apiuser/lights/7/state
put

Code: Select all

{"on": true}
I made two .sh scripts, 1 for on and 1 for off

Code: Select all

#!/bin/bash
do

curl --request PUT --data "{"on": true}" http://192.168.178.24:80/api/apiuser/lights/7/state


done
and

Code: Select all

#!/bin/bash
do

curl --request PUT --data "{"on": false}" http://192.168.178.24:80/api/apiuser/lights/7/state


done


In Domoticz:

Just add a scene to Domotiz and link its "On Action" and optionally "Off Action" with bash scripts.

I made a bash folder in scripts

On action: script///home/pi/domoticz/scripts/bash/Hue1_on.sh
Off action: script///home/pi/domoticz/scripts/bash/Hue1_off.sh





Sudo:

sudo chmod +x Hue1_off.sh

Must i do this also for: sudo chmod +x Hue1_off.sh

How do i setup these setting for sudo?

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests