Google assistant - Commands are lower case

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
ayasystems
Posts: 28
Joined: Tuesday 19 April 2016 23:37
Target OS: Raspberry Pi
Domoticz version:
Contact:

Google assistant - Commands are lower case

Post by ayasystems » Friday 13 July 2018 9:41

Hi,

Version: 4.9763
Platform: Raspberry

Description:
I'm creating task on IFTTT in order to do actions with google assistant on my Domoticz

I've a problem due commands are case sensitive. Could be it change to respond with no case sensitive commands?


Example
domoticz_assistant_1.png
domoticz_assistant_1.png (35.96 KiB) Viewed 76 times
As action we can create a webhoock with http://domoticz.testweb.com/json.htm?ty ... switchcmd= {{TextField}}

{{TextField}} is the command received by google assistan but it is lowcase and domoticz is not doing the command.

Example, you send on command

http://domoticz.xxxxxxxxxx.com/json.htm ... itchcmd=on

2018-07-13 09:40:09.886 Status: User: admin initiated a switch command (17/Depuradora/on)

{
"message" : "Error sending switch command, check device/hardware !",
"status" : "ERROR",
"title" : "SwitchLight"
}

but if you send On... works fine!
http://domoticz.xxxxxxxxxx.com/json.htm ... itchcmd=On

Regards!

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests