Controlicz and NGINX

Alexa, Google Home and Siri
Post Reply
rlg6767
Posts: 8
Joined: Friday 30 March 2018 22:51
Target OS: Raspberry Pi
Domoticz version:
Contact:

Controlicz and NGINX

Post by rlg6767 » Wednesday 11 July 2018 11:31

Hi,

So I have Domoticz sat begind NGINX which is being used to reverse proxy a number of applications to the internet. I can access Domoticz remotely from the browser using https://mydns.dns.net/domo fine. I don't have a username/password setup for Domoticz.

My server block in NGINX looks like this:

# Domo
location /domo {
proxy_pass http://192.168.1.90:8080;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
}

However in Controlicz, I set my the host addrress to https://mydns.dns.net/domo with port 443, and use my NGINX username and password but it doesn't connect and always pops up with "Check your Settings".

Has anyone else tried this and got it working?
Many thanks!!

bverhalleman
Posts: 1
Joined: Thursday 20 September 2018 11:53
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Controlicz and NGINX

Post by bverhalleman » Thursday 20 September 2018 11:59

Hi

I just encountered the same problem. It looks like Controlicz doesn't like the /domo suffix. I ended up in configuring it like this

# Domo
location / {
proxy_pass http://192.168.1.90:8080;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
}

# Otherapp
location /otherapp {
# First attempt to serve request as file, then
# as directory, then fall back to displaying a 404.
try_files $uri $uri/ =404;
}

Gr

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests