Seismic devices

For Z-Wave related questions in Domoticz
Post Reply
User avatar
EddyG
Posts: 247
Joined: Monday 02 November 2015 6:54
Target OS: Raspberry Pi
Domoticz version: 4.9732
Location: Rhenen, Netherlands
Contact:

Seismic devices

Post by EddyG » Sunday 01 July 2018 10:48

I saw that the seismic device are in the latest beta.
I have an FIBARO FGMS001-ZW5 Motion Sensor which supports seismic data.
It was always an error in the logging at the start of Domoticz because Domoticz did not support it yet.
But now the support is in I do not get the device(s).
How do I get the device(s) in Domoticz?
Regards,
Eddy

User avatar
gizmocuz
Posts: 8640
Joined: Thursday 11 July 2013 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Top of the world
Contact:

Re: Seismic devices

Post by gizmocuz » Monday 02 July 2018 8:49

I have not tested it... I have a multisensor, but i have no idea how to simulate an earhquake with it.
I tried shaking... but nothing happens
You should enable 'accept new devices' in the settings, and then it should be detected (i hope)
Quality outlives Quantity!

User avatar
EddyG
Posts: 247
Joined: Monday 02 November 2015 6:54
Target OS: Raspberry Pi
Domoticz version: 4.9732
Location: Rhenen, Netherlands
Contact:

Re: Seismic devices

Post by EddyG » Monday 02 July 2018 9:56

I did shake it, I did forcely tap it, I forced an Alarm.
I did enable 'accept new devices', but nothing happend.
Previous I always had an error when starting Domoticz about a seismic device. That error has gone.
The log now shows:

Code: Select all

2018-07-02 09:53:01.633  OpenZWave: Value_Added: Node: 17 (0x11), CommandClass: SENSOR MULTILEVEL, Label: Seismic Intensity, Instance: 25
But NO new device.
Regards,
Eddy

User avatar
gizmocuz
Posts: 8640
Joined: Thursday 11 July 2013 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Top of the world
Contact:

Re: Seismic devices

Post by gizmocuz » Monday 02 July 2018 10:07

Then it seems you (and i) don't get any updates on this sensor.

Can you try to enable debug on the zwave controller (not to long as this file can be very big)
(Setup on OZW hardware)
When all nodes have been queried, try to simulate an alarm.
In the 'Config' folder you should find the log file, can you see any updates on this sensor ?
Quality outlives Quantity!

User avatar
EddyG
Posts: 247
Joined: Monday 02 November 2015 6:54
Target OS: Raspberry Pi
Domoticz version: 4.9732
Location: Rhenen, Netherlands
Contact:

Re: Seismic devices

Post by EddyG » Monday 02 July 2018 10:17

Going for a short holiday in 30 min.
Will test comming friday or saterday.
Regards,
Eddy

User avatar
EddyG
Posts: 247
Joined: Monday 02 November 2015 6:54
Target OS: Raspberry Pi
Domoticz version: 4.9732
Location: Rhenen, Netherlands
Contact:

Re: Seismic devices

Post by EddyG » Monday 09 July 2018 11:36

I did startup domoticz with loglevel 9 on ZWave.
This is the result concerning Seismic data, it came together with Lux data.

Code: Select all

2018-07-09 11:27:29.087 Detail, Node017,   Received: 0x01, 0x0b, 0x00, 0x04, 0x00, 0x11, 0x05, 0x31, 0x05, 0x19, 0x21, 0x38, 0xd0
2018-07-09 11:27:29.087 Detail, 
2018-07-09 11:27:29.087 Info, Node017, Received SensorMultiLevel report from node 17, instance 1, Seismic Intensity: value=5.6mercalli
2018-07-09 11:27:29.087 Detail, Node017, Initial read of value
2018-07-09 11:27:29.088 Detail, Node017, Notification: ValueChanged
2018-07-09 11:27:29.272 Detail, Node017,   Received: 0x01, 0x0c, 0x00, 0x04, 0x00, 0x11, 0x06, 0x31, 0x05, 0x03, 0x0a, 0x01, 0x25, 0xf9
2018-07-09 11:27:29.272 Detail, 
2018-07-09 11:27:29.272 Info, Node017, Received SensorMultiLevel report from node 17, instance 1, Luminance: value=293lux
2018-07-09 11:27:29.272 Detail, Node017, Initial read of value
2018-07-09 11:27:29.272 Detail, Node017, Notification: ValueChanged
And somewhat later this:

Code: Select all

2018-07-09 11:27:56.643 Detail, Node017,   Received: 0x01, 0x0b, 0x00, 0x04, 0x00, 0x11, 0x05, 0x31, 0x05, 0x19, 0x21, 0x00, 0xe8
2018-07-09 11:27:56.643 Detail, 
2018-07-09 11:27:56.643 Info, Node017, Received SensorMultiLevel report from node 17, instance 1, Seismic Intensity: value=0.0mercalli
2018-07-09 11:27:56.644 Detail, Node017, Refreshed Value: old value=5.6, new value=0.0, type=decimal
2018-07-09 11:27:56.644 Detail, Node017, Changes to this value are not verified
2018-07-09 11:27:56.644 Detail, Node017, Notification: ValueChanged
Regards,
Eddy

User avatar
gizmocuz
Posts: 8640
Joined: Thursday 11 July 2013 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Top of the world
Contact:

Re: Seismic devices

Post by gizmocuz » Monday 09 July 2018 17:07

@Eddy, was this during startup or where the nodes already queried ?
Did you pick up the node, and give it a shake ?
If after nodes queried and shaking, i should be able to replicate this, tried it before, but no Seismic changes where reported
Quality outlives Quantity!

User avatar
EddyG
Posts: 247
Joined: Monday 02 November 2015 6:54
Target OS: Raspberry Pi
Domoticz version: 4.9732
Location: Rhenen, Netherlands
Contact:

Re: Seismic devices

Post by EddyG » Monday 09 July 2018 18:53

I restarted domoticz with Zwave loglevel at 9.
Directly after all nodes where queried I shaked the device and this was the output.
In the domoticz log I see the message, but a new device is not created.

Code: Select all

2018-07-09 11:29:32.742 OpenZWave: Value_Added: Node: 17 (0x11), CommandClass: SENSOR MULTILEVEL, Label: Seismic Intensity, Instance: 25
Regards,
Eddy

User avatar
EddyG
Posts: 247
Joined: Monday 02 November 2015 6:54
Target OS: Raspberry Pi
Domoticz version: 4.9732
Location: Rhenen, Netherlands
Contact:

Re: Seismic devices

Post by EddyG » Friday 13 July 2018 17:51

Anyone got it working yet?
Regards,
Eddy

User avatar
gizmocuz
Posts: 8640
Joined: Thursday 11 July 2013 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Top of the world
Contact:

Re: Seismic devices

Post by gizmocuz » Saturday 14 July 2018 8:33

Nope sorry, just checked again, and i get no Seismic value at all, also not at startup
Could you tell me from the openzwave node list, what ID/Type you have ?
Mine is 0x1001, 0x0800, i have included this on a non-zwave+ stick
fgms.png
fgms.png (45.07 KiB) Viewed 33 times
Quality outlives Quantity!

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests