Domoticz version 4.9700 released (Stable)

News and/or updates regarding Domoticz or things related to Domoticz will be placed here.
Twitter: https://twitter.com/Domoticz | Facebook: https://www.facebook.com/domoticz | Changelog: Github
Post Reply
SpawnMC
Posts: 3
Joined: Friday 29 June 2018 22:24
Target OS: -
Domoticz version:
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by SpawnMC » Friday 29 June 2018 23:07

Bluelightcrew wrote:
Monday 25 June 2018 21:00
I updated from a beta.After some minutes domoticz crashes.I tryed a complete new setup.After adding some devices domoticz crashes.
i have the same problem. after 15 min it crash.
i tried my old setup with jessie and domoticz new beta version
and i tried a new setup on a new sd card with stretch and domoticz stable 4.97

bevore i used domoticz with beta versions for 2 yeras without problems :-(

EDIT: Problem solved by disable all "MyDomoticz configs", the server builds a timeout and after 15 min domoticz crash

francouai
Posts: 2
Joined: Saturday 07 May 2016 22:02
Target OS: NAS (Synology & others)
Domoticz version:
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by francouai » Saturday 30 June 2018 8:22

using Domoticz on syno DSM6.X .
it worked fine since many years until this upgrade.
My TEMPERATURES tab was fully empty and the sensor names on another tab was gone.

I downgraded back to the old stable version but geeting other worst issues now . :(

francouai
Posts: 2
Joined: Saturday 07 May 2016 22:02
Target OS: NAS (Synology & others)
Domoticz version:
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by francouai » Saturday 30 June 2018 8:31

just did a clear COOKIES on FIREFOX and it cleared all the mess. :lol:

AHSchaap
Posts: 3
Joined: Friday 29 June 2018 21:57
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by AHSchaap » Saturday 30 June 2018 14:06

AHSchaap wrote:
Friday 29 June 2018 22:02
I installed this new version but now no Lua scripts are executed. Of cource i do not have a backup.
Domoticz is running on a Raspberry Pi 2B+ and there were no problems in the past.
I reinstalled Dotmoticz but no diverence, lua scripts are not executed.
Can enyone please help me?

Raini
Posts: 5
Joined: Saturday 23 June 2018 18:43
Target OS: Raspberry Pi
Domoticz version: 4.9700
Location: Netherlands
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by Raini » Saturday 30 June 2018 14:43

AHSchaap wrote:
Saturday 30 June 2018 14:06
AHSchaap wrote:
Friday 29 June 2018 22:02
I installed this new version but now no Lua scripts are executed. Of cource i do not have a backup.
Domoticz is running on a Raspberry Pi 2B+ and there were no problems in the past.
I reinstalled Dotmoticz but no diverence, lua scripts are not executed.
Can enyone please help me?
In my case the LUA-scripts are working perfectly. Is there something in the logs that you want to share? Mine is running also on the Pi 2B+ with the latest updated version of Raspian version 9 (stretch).
Last edited by Raini on Saturday 30 June 2018 14:48, edited 1 time in total.

florisi
Posts: 43
Joined: Saturday 30 July 2016 10:14
Target OS: Raspberry Pi
Domoticz version: v4.9732
Location: Arnhem
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by florisi » Saturday 30 June 2018 14:47

I like to have my Hue bulbs back in Domoticz.
Is it possible to switch to Beta and later on back to Stable?

In Beta Hue should work again.

User avatar
waaren
Posts: 943
Joined: Tuesday 03 January 2017 15:18
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by waaren » Saturday 30 June 2018 14:55

florisi wrote:
Saturday 30 June 2018 14:47
I like to have my Hue bulbs back in Domoticz.
Is it possible to switch to Beta and later on back to Stable?

In Beta Hue should work again.
It is not advisable to switch back to stable V4.9700 after you switched to the latest Beta now but you can switch afterwards to a more recent stable which is expected to be released soon.
Raspberry (debian stretch via berryboot on Synology DS916+) , Domoticz (almost) latest Beta, , dzVents 2.6, RFLink, RFXtrx433e, P1, Youless, Harmony, Hue, Yeelight, Xiaomi, HomeWizard, Zwave, Amazon echo

Roncalli
Posts: 22
Joined: Tuesday 17 February 2015 22:37
Target OS: Raspberry Pi
Domoticz version: beta
Location: Germany
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by Roncalli » Saturday 30 June 2018 16:08

First of all: Thanks a lot for this great piece of software! Domoticz is reliably running my home since almost three years.

I now decided to move from the previous stable version to the new one. I chose to use a completely new Raspberry 3+ with a fresh stretch light installation.

I could successfully transfer my hardware to the new setup. The only thing I cannot transfer are my floorplans (and I'm still struggling with Imperihome; but I guess this I will accomplish after reading again into it).
As specified by Rob I back-uped the content of he images/floorplans folder and copied the files to the same location on the new pi. After that I restored the database via the web interface (and vice versa). Both ways don't get me to the new system showing my floorplans. As I have 8 relatively full and complex plans, I'd rather not redo the whole thing (especially as the editor is very tedious - at least on my old Mac).

Can anyone give me a hint what else to try?

Thanks a lot!
Domoticz Stable on RaspberryPi 3B+ running stretch-light
Aeon-Labs stick with 23 z-wave devices, RFXtrx with 14 devices, Netatmo with 6 modules, Satel Integra, Instar IP Camera

grousset
Posts: 1
Joined: Saturday 30 June 2018 16:38
Target OS: Linux
Domoticz version:
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by grousset » Saturday 30 June 2018 16:43

Hello,

The module Denkovi smartden LOGGER not work on the Linux version (no devices) while they are recognized under windows?


thank you in advance

forumdomo
Posts: 10
Joined: Saturday 30 April 2016 19:31
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by forumdomo » Saturday 30 June 2018 17:09

It seams updating domoticz is the same crazy thing like the big Windows 10 Updates...

/etc/init.d/domoticz.sh start
/home/pi/domoticz/domoticz: error while loading shared libraries: libudev.so.1: cannot open shared object file: No such file or directory

Linux dependecies HELL

Also the Forum does not work on two differnt PCs with FF60 because of some Cookie - accepting thing. IE brings this Cookie accept thing, FF not.
"You cannot access links on this board until you have accepted the Cookie Policy." WTH?
Raspi 2, domoticz-raspi-image, rfxcom433e, intertechno, home easy

frenchyyii
Posts: 18
Joined: Saturday 24 September 2016 18:33
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by frenchyyii » Sunday 01 July 2018 16:10

Hi, I'm now out of a solution to get my domoticz ok with my database and can't create a fresh raspbian.

Domoticz starts and closes instantly with beta or stable edition with the same message:

Code: Select all

terminate called after throwing an instance of 'std::invalid_argument'
  what():  stoull
abandon
Please does someone have an idea of what the problem should be ?

Regards

hoeby
Posts: 43
Joined: Saturday 02 June 2018 11:05
Target OS: Raspberry Pi
Domoticz version: V4.9700
Location: Echt, Netherlands
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by hoeby » Sunday 01 July 2018 18:14

Just a question, don't know if it is about the stable release.

Does somebody use the stable release 4.9700 whit dashticz_v2?
I am running the stable release for 2 weeks now.
This weekend started whit dashticz, but can't get it to work. Dashticz says, check your connection whit domoticz.
I have 1 PC that runs google chome and that works. But getting an other PC on chrome, than it doesn't run.
On IE or Edge it both doesn't run, doesn't matter which pc.

Has this something to do whit domoticz V4.9700, or do i need to search it on an other location?

HierBenIk
Posts: 2
Joined: Saturday 09 September 2017 22:29
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by HierBenIk » Sunday 01 July 2018 21:50

According to the instructions I should make a copy of the Z-wave configuration file (Config/zwcfg_xxxxx.xml)".
I made a sftp connection with FileZilla, but when I copy the zwcfg_xxx.xml file I get the massage:
Fout: /home/pi/domoticz/Config/tmp.xml: open for read: permission denied
Fout: Bestandsoverdracht mislukt


I already deactivated the zwave controller in Domoticz, but this didn't solve this issue? The owner of the file is the "root" and not PI.
Maybe I need to login with sftp with the root user but I don't know how.
Has anyone a solution how I can make a backup of the zwave configuration file?

Edit: Found it. Just download the configuration file from the settings page of the z-wave adaptor within domoticz
Last edited by HierBenIk on Sunday 01 July 2018 22:35, edited 1 time in total.

m0rph13
Posts: 20
Joined: Sunday 31 January 2016 2:24
Target OS: Raspberry Pi
Domoticz version: 3.4834
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by m0rph13 » Sunday 01 July 2018 22:16

Unable to list or set timers in 4.9700

m0rph13
Posts: 20
Joined: Sunday 31 January 2016 2:24
Target OS: Raspberry Pi
Domoticz version: 3.4834
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by m0rph13 » Sunday 01 July 2018 22:18

Unable to edit a deactivation action on a device.. The current URL is hashed out and it does not seem possible to change it.

jeleve
Posts: 6
Joined: Saturday 07 November 2015 18:33
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by jeleve » Monday 02 July 2018 9:27

I am using Domoticz in its 3.8153 version on a raspberry Pi with raspbian.
I had the bad idea to update my working Domoticz to the last version yesterday when I leave on holidays tomorrow.
Unfortunately it didn't restart and any attempt to restart it produces the error message: "error while loading shared libraries: libudev.so.1: cannot open shared object file: No such file or directory"
Can somebody help me ?

Hanzepanz
Posts: 12
Joined: Monday 05 January 2015 0:46
Target OS: Raspberry Pi
Domoticz version:
Location: Netherlands, Eindhoven
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by Hanzepanz » Monday 02 July 2018 17:38

Dahl1632 wrote:
Sunday 24 June 2018 16:50
I found a workaround for my udev problem. Created a symlink from libudev.so to libudev.so.1 in /usr/lib.
Can you explain how i can create a symlink? Do i have to be in library /usr/lib? what command do i use?
Regards,

Hans
__________________
Raspberry Pi B+
Rfxcom (RFXtrx433E)
TP-Link TL-WN725n

AHSchaap
Posts: 3
Joined: Friday 29 June 2018 21:57
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by AHSchaap » Monday 02 July 2018 20:14

Raini wrote:
Saturday 30 June 2018 14:43
AHSchaap wrote:
Saturday 30 June 2018 14:06
AHSchaap wrote:
Friday 29 June 2018 22:02
I installed this new version but now no Lua scripts are executed. Of cource i do not have a backup.
Domoticz is running on a Raspberry Pi 2B+ and there were no problems in the past.
I reinstalled Dotmoticz but no diverence, lua scripts are not executed.
Can enyone please help me?
In my case the LUA-scripts are working perfectly. Is there something in the logs that you want to share? Mine is running also on the Pi 2B+ with the latest updated version of Raspian version 9 (stretch).
I found the solution. In setup/settings/Other there can be a switch set 'on' or 'off' for Eventsystem. I did not change this but it was changed during the update process. I set the switch 'on' and the problem was solved.

greenwitch
Posts: 13
Joined: Saturday 26 May 2018 18:30
Target OS: Raspberry Pi
Domoticz version: BETA
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by greenwitch » Monday 02 July 2018 21:35

Hi,

Can you please publish properly source code of this stable version:

When I download it from https://github.com/domoticz/domoticz/ar ... 700.tar.gz
and compile domoticz is on version V4.5876

Adam

User avatar
waaren
Posts: 943
Joined: Tuesday 03 January 2017 15:18
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Domoticz version 4.9700 released (Stable)

Post by waaren » Monday 02 July 2018 21:42

greenwitch wrote:
Monday 02 July 2018 21:35
When I download it from https://github.com/domoticz/domoticz/ar ... 700.tar.gz
and compile domoticz is on version V4.5876
I experience also a strange versionnumber when I use the cmake command the first time.
Solution is to do the cmake command twice before the make. Strange but it works
Raspberry (debian stretch via berryboot on Synology DS916+) , Domoticz (almost) latest Beta, , dzVents 2.6, RFLink, RFXtrx433e, P1, Youless, Harmony, Hue, Yeelight, Xiaomi, HomeWizard, Zwave, Amazon echo

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest