P1 (slimme meter) Smartmeter cant get it working ?

Post Reply
TheCub3
Posts: 35
Joined: Saturday 24 February 2018 19:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

P1 (slimme meter) Smartmeter cant get it working ?

Post by TheCub3 » Friday 22 June 2018 12:18

Hi,

i bought a P1 usb kabel i have pluged it in my Raspberry and i see in Domoticz 2018-06-22 11:42:04.710 P1 Smart Meter: Using serial port: /dev/ttyUSB1
So far so good. in the hardware section i have enabled the "P1 Smart Meter USB" on USB1 but then ?... i dont see anything ?.
I would expect to see some new device in my devices section but nothing . what i'am doing wrong .

extra info":
- smartmeter is from "Enexis" about 3 months ago is this one placed here
- Domoticz is version 4.9700 (also with previous version same issue)
- OS is Raspbian
- kabel is a P1 USB cable
- i try setting 9600 Baud and 11500 baud.

settings Domoticz
slimmemeter01.jpg
slimmemeter01.jpg (46.21 KiB) Viewed 756 times
smart meter / slimme meter
slimmemeter02.jpg
slimmemeter02.jpg (27.81 KiB) Viewed 756 times
Last edited by TheCub3 on Sunday 24 June 2018 18:45, edited 1 time in total.

TheCub3
Posts: 35
Joined: Saturday 24 February 2018 19:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: P1 (slimme meter) Smartmeter cant get it working ?

Post by TheCub3 » Saturday 23 June 2018 12:30

Niemand ?
Nobody ?

FrankVZ
Posts: 35
Joined: Sunday 27 May 2018 12:01
Target OS: -
Domoticz version:
Contact:

Re: P1 (slimme meter) Smartmeter cant get it working ?

Post by FrankVZ » Sunday 24 June 2018 15:05

TheCub3 wrote:Niemand ?
Nobody ?
Maybe, but not always promptly after posting a question.
This is a forum not everyone is continuously monitoring questions.

Anyway, I think the meter is not recognised by Domoticz.
Could be OR the wrong usb port (already tried the other one?)
OR you didn't limit the rate.
You have a ersm meter, that might have longer telegraphs then your pi can handle.

Try with limit 10? (10 seconds per message)

Is there any info at the log?

User avatar
gizmocuz
Posts: 8677
Joined: Thursday 11 July 2013 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Top of the world
Contact:

Re: P1 (slimme meter) Smartmeter cant get it working ?

Post by gizmocuz » Sunday 24 June 2018 15:49

Did you enable 'accept new hardware' in the settings ?

>>kabel is a P1 USB cable<<

Kabel is a cable ... but where did you buy it from ? Mine is from here (http://www.smartmeterdashboard.nl/webshop) and it always works

If accept new hardware was disabled, you might have to try with both baudrates again (9600 works with mine)
Quality outlives Quantity!

TheCub3
Posts: 35
Joined: Saturday 24 February 2018 19:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: P1 (slimme meter) Smartmeter cant get it working ?

Post by TheCub3 » Sunday 24 June 2018 18:36

FrankVZ wrote:
Sunday 24 June 2018 15:05
TheCub3 wrote:Niemand ?
Nobody ?
Maybe, but not always promptly after posting a question.
This is a forum not everyone is continuously monitoring questions.

Anyway, I think the meter is not recognised by Domoticz.
Could be OR the wrong usb port (already tried the other one?)
OR you didn't limit the rate.
You have a ersm meter, that might have longer telegraphs then your pi can handle.

Try with limit 10? (10 seconds per message)

Is there any info at the log?
he Frank, you right sorry but this is tha last thing then i can sale my "homewizard ( already got a buyer for it) .
i tryed various usb but still the same, in Linux with CU i see only connected and no input at all.
the changing of limit did i try without any luck.

when i do lsusb i see
pi@raspberrypi:~ $ lsusb
Bus 001 Device 005: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
Bus 001 Device 004: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


when i do CU is see
pi@raspberrypi:~ $ cu -l /dev/ttyUSB0 -s 115200
Connected.

(also try 9600 BD but the same)

the LOG only is saying this about the P1 cable,
2018-06-24 18:39:55.504 Status: P1 Smart Meter: Using serial port: /dev/ttyUSB1

-A
Last edited by TheCub3 on Sunday 24 June 2018 18:41, edited 1 time in total.

TheCub3
Posts: 35
Joined: Saturday 24 February 2018 19:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: P1 (slimme meter) Smartmeter cant get it working ?

Post by TheCub3 » Sunday 24 June 2018 18:38

gizmocuz wrote:
Sunday 24 June 2018 15:49
Did you enable 'accept new hardware' in the settings ?

>>kabel is a P1 USB cable<<

Kabel is a cable ... but where did you buy it from ? Mine is from here (http://www.smartmeterdashboard.nl/webshop) and it always works

If accept new hardware was disabled, you might have to try with both baudrates again (9600 works with mine)
i send that webshop a question about the cable about 2 weeks ago never got any answer back so no its not from that shop.
but do you have the same meter like i have (zie my topic "starter" .

-A

FrankVZ
Posts: 35
Joined: Sunday 27 May 2018 12:01
Target OS: -
Domoticz version:
Contact:

Re: P1 (slimme meter) Smartmeter cant get it working ?

Post by FrankVZ » Monday 25 June 2018 0:55

A cable is a cable... not true.
As I understood, the data from the Sagem has to be inverted. That is done with hardware (resistors) within the FTDI connector.
Als0, I read about bad cables (specially the RJ connector). They suffer with bad connections between the cable and contact points. That was the cause of troubles.
That is why I ordered it at smartmeterdashboard and so far the supplied cable by them is doing its job perfectly and I got good and fast answers to my questions.

Not going too far into detail:/
You can try to make the USB connection persistent at your pi (for Syno see https://www.domoticz.com/wiki/PersistentUSBDevices)
use settings 115200/8/n/1 (see the documentation of ESMR5)
make the USB source persistent and check within domoticz of the right port is assigned to the hardware (see hardwarelist)
Set rate limit to 10

If this all does not work, go more back by elemination of the different parts, e.g. http://gejanssen.com/howto/Slimme-meter-uitlezen/ so you are sure it is not a Domoticz problem,

If that doesnt work, try a new cable (or make your own)

hth

TheCub3
Posts: 35
Joined: Saturday 24 February 2018 19:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: P1 (slimme meter) Smartmeter cant get it working ?

Post by TheCub3 » Tuesday 26 June 2018 19:22

Hi all,

this week i wil get a new cable (to test), as soon a have the cable i wilt test this and also wil test what @FrankVZ wrote about this.

-A

pwhooftman
Posts: 159
Joined: Monday 11 November 2013 19:04
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: P1 (slimme meter) Smartmeter cant get it working ?

Post by pwhooftman » Tuesday 26 June 2018 20:51

a simple 'cat /dev/ttyUSB1' will tell if any data is received. Issuing this command from the command prompt should produce readable output every 5 seconds or so.
Domoticz v 1.16xx
1X RFXtrx433 USB 433.92MHz Transceiver Firmware version: 71
1X Synology Nas DS412+ DSM 4.3 (2Gb RAM mod)

TheCub3
Posts: 35
Joined: Saturday 24 February 2018 19:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: P1 (slimme meter) Smartmeter cant get it working ?

Post by TheCub3 » Tuesday 26 June 2018 21:55

pwhooftman wrote:
Tuesday 26 June 2018 20:51
a simple 'cat /dev/ttyUSB1' will tell if any data is received. Issuing this command from the command prompt should produce readable output every 5 seconds or so.
Tnx i will try this when i have the new (test) cable

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests