Domoticz not showing HTTP and HTTPS in Debian 9.4

On various Hardware and OS systems: pi / windows / routers / nas, etc
Post Reply
marafado88
Posts: 6
Joined: Saturday 09 June 2018 3:16
Target OS: Linux
Domoticz version:
Contact:

Domoticz not showing HTTP and HTTPS in Debian 9.4

Post by marafado88 » Saturday 09 June 2018 3:38

Hello,

I have made my first fresh installation of Domoticz through,

sudo curl -L install.domoticz.com | bash

and use the default installation for HTTP at 8080 and HTTPS at 443, but still after a successful installation (no errors), I was unable to open any webservice at those ports, even at localhost.

Domoticz PID seems to be working,

avahi 398 0.0 0.3 47140 3492 ? Ss Jun08 0:00 avahi-daemon: running [domoticz.local]

Domoticz seems to be Ok but there is an error that I cannot figure out what it is,

fabio@domoticz:~$ sudo /etc/init.d/domoticz.sh status
● domoticz.service - LSB: Home Automation System
Loaded: loaded (/etc/init.d/domoticz.sh; generated; vendor preset: enabled)
Active: active (exited) since Sat 2018-06-09 02:10:00 WEST; 20min ago
Docs: man:systemd-sysv-generator(8)
Process: 3724 ExecStop=/etc/init.d/domoticz.sh stop (code=exited, status=0/SUCCESS)
Process: 3731 ExecStart=/etc/init.d/domoticz.sh start (code=exited, status=0/SUCCESS)

Jun 09 02:10:00 domoticz systemd[1]: Starting LSB: Home Automation System...
Jun 09 02:10:00 domoticz domoticz.sh[3731]: /home/fabio/domoticz/domoticz: error while loading shared libraries:…rectory
Jun 09 02:10:00 domoticz systemd[1]: Started LSB: Home Automation System.
Hint: Some lines were ellipsized, use -l to show in full.


So I tried to scan both 8080 and 443, and also there was no openned ports here.

I really dont know what can be happening, and dont know well where are domoticz logs, I have even uncomment at /etc/init.d/domoticz.sh the daemon log line but still there was no log to analize possible issues, and yes I have restarted that service after changes.

Anyone knows what can be? :roll:

marafado88
Posts: 6
Joined: Saturday 09 June 2018 3:16
Target OS: Linux
Domoticz version:
Contact:

Re: Domoticz not showing HTTP and HTTPS in Debian 9.4

Post by marafado88 » Saturday 09 June 2018 3:52

From what I am reading from other ppl that error came from a lib for ssl libssl1.0.0, who is only available in old debian versions(7,8), and not in Debian 9 where I already have libssl1.0.2. From other posts in this forum seems like to use HTTP, it should be installed that lib too. :(

Alceste
Posts: 3
Joined: Tuesday 12 June 2018 20:39
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Domoticz not showing HTTP and HTTPS in Debian 9.4

Post by Alceste » Friday 15 June 2018 15:48

My domoticz on raspberry pi say :
pi@domoticz:~ $ sudo service domoticz.sh status
* domoticz.service - LSB: Home Automation System
Loaded: loaded (/etc/init.d/domoticz.sh; generated; vendor preset: enabled)
Active: active (exited) since Fri 2018-06-15 15:25:15 CEST; 18min ago
Docs: man:systemd-sysv-generator(8)
Process: 499 ExecStart=/etc/init.d/domoticz.sh start (code=exited, status=0/SUCCESS)
CGroup: /system.slice/domoticz.service

juin 15 15:25:14 domoticz systemd[1]: Starting LSB: Home Automation System...
juin 15 15:25:15 domoticz domoticz.sh[499]: /home/pi/domoticz/domoticz: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory
juin 15 15:25:15 domoticz systemd[1]: Started LSB: Home Automation System.

There is a problem with libssl.so
there is no display with web browser.

Alceste
Posts: 3
Joined: Tuesday 12 June 2018 20:39
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Domoticz not showing HTTP and HTTPS in Debian 9.4

Post by Alceste » Saturday 16 June 2018 10:41

Solution :
sudo wget http://ftp.nl.debian.org/debian/pool/ma ... _armhf.deb
sudo dpkg -i libssl1.0.0_1.0.1t-1+deb8u7_armhf.deb
sudo curl -L install.domoticz.com | sudo bash

It's ok for me.
Have a good day !

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests