domoticz.sh does not run

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
glory50
Posts: 1
Joined: Thursday 07 June 2018 22:23
Target OS: Linux
Domoticz version:
Contact:

domoticz.sh does not run

Post by glory50 » Thursday 07 June 2018 22:44

Hello,

Version: 3.8153
Platform: Linux Mint 18.3 Cinnamon 64 bit
Description:

I deleted domoticz.sh from /etc/init.d/. After that, I copied it again from /home/user/domoticz/ folder. Then I did:

sudo cp domoticz.sh /etc/init.d
sudo chmod +x /etc/init.d/domoticz.sh
sudo update-rc.d domoticz.sh defaults

But the script does not run.

ho@dom ~ $ sudo service domoticz.sh status
\u25cf domoticz.service - LSB: Home Automation System
Loaded: loaded (/etc/init.d/domoticz.sh; bad; vendor preset: enabled)
Active: active (exited) since Thu 2018-06-07 22:15:09 CEST; 1min 23s ago
Docs: man:systemd-sysv-generator(8)
Process: 1702 ExecStart=/etc/init.d/domoticz.sh start (code=exited, status=0/SUCCESS)

I can run domoticz binary manually from bash with or without arguments, it works. It worked fine before, but after deleting and new copy to /etc/init.d, no execution. How could I debug it? There are no messages in syslog about it.

Any clue what could be wrong?

dextm80
Posts: 78
Joined: Tuesday 24 October 2017 18:32
Target OS: Linux
Domoticz version: 3.9527
Contact:

Re: domoticz.sh does not run

Post by dextm80 » Friday 08 June 2018 10:13

try cd domoticz
./domoticz

and post results
Domoticz on AsRock j3455-ITX 8gb ram - Aeotec ZWave Usb Stick - RFLink 433Mhz
1x Fibaro Wall Plug
1x Fibaro Motion Sensor
2x NeoCoolcam Wall Plug
Netatmo Weather Station - Netatmo Thermostat
Philips Hue Bridge

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests