Nefit Easy XMPP authentication failure

For heating/cooling related questions in Domoticz
SweetPants
Posts: 2350
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.10196
Location: The Netherlands
Contact:

Nefit Easy XMPP authentication failure

Post by SweetPants » Tuesday 29 May 2018 13:00

Since today there seems to be some issues with the nefit-easy-http-server resulting in XMPP authentication failures.
I already informed Robert Klep (author of the nefit-easy SW) about this and he acknowledged this. https://github.com/robertklep/nefit-eas ... /issues/12
There seems to be something changed at the server side as my Android client still works.

Edit: Last news is that Robert found a solution, but it will take some time to implement. Watch the repo for updates

Update: Update nefit-easy-http-server to v4.0.0 and associated utilities to latest version and problem is solved. Thanks to Robert Klep
Ubuntu 16.04.5 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

User avatar
felix63
Posts: 164
Joined: Monday 07 December 2015 10:30
Target OS: Raspberry Pi
Domoticz version: 3.8275
Location: Gouda
Contact:

Re: Nefit Easy XMPP authentication failure

Post by felix63 » Wednesday 30 May 2018 0:24

Wow... quick fix!

I used

Code: Select all

 sudo npm update nefit-easy-http-server -g
to update

User avatar
Bartb
Posts: 37
Joined: Monday 29 August 2016 22:19
Target OS: Raspberry Pi
Domoticz version: Beta
Location: NL
Contact:

Re: Nefit Easy XMPP authentication failure

Post by Bartb » Wednesday 30 May 2018 17:00

Brilliant! Works perfectly again.
Thanks!

mchangsp
Posts: 33
Joined: Wednesday 07 August 2013 0:12
Target OS: Raspberry Pi
Domoticz version: 3.4834
Contact:

Re: Nefit Easy XMPP authentication failure

Post by mchangsp » Friday 01 June 2018 21:57

Unfortunately afther the nefit easy upgrade I still get an "XMPP authentication error"
What can be wrong?

I already did:
sudo apt-get update
sudo apt-get upgrade

Here are the versions of my packages
npm -v: 6.1.0
node -v: v9.9.0
easy-server -v: 4.0.1

SweetPants
Posts: 2350
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.10196
Location: The Netherlands
Contact:

Re: Nefit Easy XMPP authentication failure

Post by SweetPants » Friday 01 June 2018 22:57

Works fine with:

node -v 6.14.2
npm -v 3.10.10
easy-server -v 4.0.1
Ubuntu 16.04.5 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

Milifax
Posts: 85
Joined: Friday 23 June 2017 9:27
Target OS: Raspberry Pi
Domoticz version: v3.8094
Location: The Netherlands
Contact:

Re: Nefit Easy XMPP authentication failure

Post by Milifax » Saturday 02 June 2018 9:39

Thanks for the fix.
Really appreciate it!

Jamie
Posts: 2
Joined: Saturday 02 June 2018 12:46
Target OS: -
Domoticz version:
Contact:

Re: Nefit Easy XMPP authentication failure

Post by Jamie » Saturday 02 June 2018 12:48

I updated as suggested, unfortunately I now get a:
module.js:549
throw err;
^
Error: Cannot find module '@xmpp/connection'

When running easy-server.
I tried cleaning, reinstalling, reinstalling NodeJS (8.11.2), but until now no success.

Any help appreciated.

NodeJS 8.11.2
NPM 2.15.11
easy-server > ERROR

SweetPants
Posts: 2350
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.10196
Location: The Netherlands
Contact:

Re: Nefit Easy XMPP authentication failure

Post by SweetPants » Saturday 02 June 2018 13:22

Did you get any errors installing Node.js? When I did it told me my npm version was too low. (sudo npm install npm -g) What tells easy-server -v?
Ubuntu 16.04.5 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

Jamie
Posts: 2
Joined: Saturday 02 June 2018 12:46
Target OS: -
Domoticz version:
Contact:

Re: Nefit Easy XMPP authentication failure

Post by Jamie » Sunday 03 June 2018 0:13

You are right! I removed every instance of NPM and Node(js), literely every file. Thereafter reinstalled with

Code: Select all

sudo aptitude install npm
then did a dist-upgrade and voila: latest NPM and latest Node(Js) AND after re-installing with the new NPM: a working Easy-Server!
Thanks!

PAHVelthuis
Posts: 10
Joined: Monday 11 May 2015 15:52
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Nefit Easy XMPP authentication failure

Post by PAHVelthuis » Tuesday 05 June 2018 22:09

Hi,

easy-server keeps reporting v3.0.0 after running the following command:

Code: Select all

sudo npm update nefit-easy-http-server -g
node -v v6.14.2
npm -v 3.10.10

What can I do?

SweetPants
Posts: 2350
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.10196
Location: The Netherlands
Contact:

Re: Nefit Easy XMPP authentication failure

Post by SweetPants » Wednesday 06 June 2018 16:09

Try:

sudo npm uninstall neffit-easy-http-server -g (this should remove the old one and dependencies)
sudo npm install nefit-easy-http-server -g (should install 4.0.1)

and probably

sudo npm install nefit-easy-commands -g
Ubuntu 16.04.5 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

PAHVelthuis
Posts: 10
Joined: Monday 11 May 2015 15:52
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Nefit Easy XMPP authentication failure

Post by PAHVelthuis » Wednesday 06 June 2018 22:44

Code: Select all

npm i nefit-easy-http-server -g


did the trick, thanks!

Biarritz
Posts: 7
Joined: Friday 08 June 2018 23:29
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Nefit Easy XMPP authentication failure

Post by Biarritz » Friday 08 June 2018 23:31

I tried this but still ending up with version 3.1.1
Before I had version 4.0.1 but received the Error: NefitEasy: Error getting http data!

SweetPants
Posts: 2350
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.10196
Location: The Netherlands
Contact:

Re: Nefit Easy XMPP authentication failure

Post by SweetPants » Saturday 09 June 2018 8:15

Biarritz wrote:
Friday 08 June 2018 23:31
I tried this but still ending up with version 3.1.1
Did you see any errors during install?
Biarritz wrote:
Friday 08 June 2018 23:31
Before I had version 4.0.1 but received the Error: NefitEasy: Error getting http data!
Don't know about this one, could be a temporary issue. I noticed the Bosch backend servers are not always very reliable
Ubuntu 16.04.5 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

Biarritz
Posts: 7
Joined: Friday 08 June 2018 23:29
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Nefit Easy XMPP authentication failure

Post by Biarritz » Saturday 09 June 2018 10:12

This is what I get as return:

pi@Domoticz:~ $ sudo npm install nefit-easy-http-server -g
/usr/bin/easy-server -> /usr/lib/node_modules/nefit-easy-http-server/bin/easy-server
/usr/lib
└─┬ nefit-easy-http-server@3.1.1
├── bluebird@3.5.1
├─┬ body-parser@1.18.3
│ ├── bytes@3.0.0
│ ├── content-type@1.0.4
│ ├─┬ debug@2.6.9
│ │ └── ms@2.0.0
│ ├── depd@1.1.2
│ ├─┬ http-errors@1.6.3
│ │ ├── inherits@2.0.3
│ │ └── statuses@1.5.0
│ ├─┬ iconv-lite@0.4.23
│ │ └── safer-buffer@2.1.2
│ ├─┬ on-finished@2.3.0
│ │ └── ee-first@1.1.1
│ ├── qs@6.5.2
│ ├─┬ raw-body@2.3.3
│ │ └── unpipe@1.0.0
│ └─┬ type-is@1.6.16
│ ├── media-typer@0.3.0
│ └─┬ mime-types@2.1.18
│ └── mime-db@1.33.0
├─┬ cors@2.8.4
│ ├── object-assign@4.1.1
│ └── vary@1.1.2
├── docopt@0.6.2
├─┬ express@4.16.3
│ ├─┬ accepts@1.3.5
│ │ └── negotiator@0.6.1
│ ├── array-flatten@1.1.1
│ ├─┬ body-parser@1.18.2
│ │ ├── iconv-lite@0.4.19
│ │ └─┬ raw-body@2.3.2
│ │ └─┬ http-errors@1.6.2
│ │ ├── depd@1.1.1
│ │ └── setprototypeof@1.0.3
│ ├── content-disposition@0.5.2
│ ├── cookie@0.3.1
│ ├── cookie-signature@1.0.6
│ ├── encodeurl@1.0.2
│ ├── escape-html@1.0.3
│ ├── etag@1.8.1
│ ├─┬ finalhandler@1.1.1
│ │ └── statuses@1.4.0
│ ├── fresh@0.5.2
│ ├── merge-descriptors@1.0.1
│ ├── methods@1.1.2
│ ├── parseurl@1.3.2
│ ├── path-to-regexp@0.1.7
│ ├─┬ proxy-addr@2.0.3
│ │ ├── forwarded@0.1.2
│ │ └── ipaddr.js@1.6.0
│ ├── qs@6.5.1
│ ├── range-parser@1.2.0
│ ├── safe-buffer@5.1.1
│ ├─┬ send@0.16.2
│ │ ├── destroy@1.0.4
│ │ ├── mime@1.4.1
│ │ └── statuses@1.4.0
│ ├── serve-static@1.13.2
│ ├── setprototypeof@1.1.0
│ ├── statuses@1.4.0
│ └── utils-merge@1.0.1
├─┬ morgan@1.9.0
│ ├── basic-auth@2.0.0
│ └── on-headers@1.0.1
└─┬ nefit-easy-commands@1.8.2
├─┬ nefit-easy-core@2.0.1
│ ├── http-string-parser@0.0.5
│ ├─┬ node-xmpp-client@3.2.0
│ │ ├── browser-request@0.3.3
│ │ ├─┬ md5.js@1.3.4
│ │ │ └── hash-base@3.0.4
│ │ ├── minimist@1.2.0
│ │ ├─┬ node-xmpp-core@5.0.9
│ │ │ ├── @xmpp/jid@0.0.2
│ │ │ ├─┬ @xmpp/streamparser@0.0.6
│ │ │ │ └── ltx@2.7.1
│ │ │ ├── @xmpp/xml@0.1.3
│ │ │ ├── lodash.assign@4.2.0
│ │ │ ├── node-xmpp-tls-connect@1.0.1
│ │ │ └─┬ reconnect-core@0.0.1
│ │ │ └── backoff@2.3.0
│ │ ├─┬ request@2.87.0
│ │ │ ├── aws-sign2@0.7.0
│ │ │ ├── aws4@1.7.0
│ │ │ ├── caseless@0.12.0
│ │ │ ├─┬ combined-stream@1.0.6
│ │ │ │ └── delayed-stream@1.0.0
│ │ │ ├── extend@3.0.1
│ │ │ ├── forever-agent@0.6.1
│ │ │ ├─┬ form-data@2.3.2
│ │ │ │ └── asynckit@0.4.0
│ │ │ ├─┬ har-validator@5.0.3
│ │ │ │ ├─┬ ajv@5.5.2
│ │ │ │ │ ├── co@4.6.0
│ │ │ │ │ ├── fast-deep-equal@1.1.0
│ │ │ │ │ ├── fast-json-stable-stringify@2.0.0
│ │ │ │ │ └── json-schema-traverse@0.3.1
│ │ │ │ └── har-schema@2.0.0
│ │ │ ├─┬ http-signature@1.2.0
│ │ │ │ ├── assert-plus@1.0.0
│ │ │ │ ├─┬ jsprim@1.4.1
│ │ │ │ │ ├── extsprintf@1.3.0
│ │ │ │ │ ├── json-schema@0.2.3
│ │ │ │ │ └─┬ verror@1.10.0
│ │ │ │ │ └── core-util-is@1.0.2
│ │ │ │ └─┬ sshpk@1.14.2
│ │ │ │ ├── asn1@0.2.3
│ │ │ │ ├── bcrypt-pbkdf@1.0.1
│ │ │ │ ├── dashdash@1.14.1
│ │ │ │ ├── ecc-jsbn@0.1.1
│ │ │ │ ├── getpass@0.1.7
│ │ │ │ ├── jsbn@0.1.1
│ │ │ │ └── tweetnacl@0.14.5
│ │ │ ├── is-typedarray@1.0.0
│ │ │ ├── isstream@0.1.2
│ │ │ ├── json-stringify-safe@5.0.1
│ │ │ ├── oauth-sign@0.8.2
│ │ │ ├── performance-now@2.1.0
│ │ │ ├─┬ tough-cookie@2.3.4
│ │ │ │ └── punycode@1.4.1
│ │ │ ├── tunnel-agent@0.6.0
│ │ │ └── uuid@3.2.1
│ │ └─┬ ws@1.1.5
│ │ ├── options@0.0.6
│ │ └── ultron@1.0.2
│ └── promise-queue@2.2.5
└── require-all@2.2.0

pi@Domoticz:~ $

SweetPants
Posts: 2350
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.10196
Location: The Netherlands
Contact:

Re: Nefit Easy XMPP authentication failure

Post by SweetPants » Saturday 09 June 2018 12:37

Biarritz wrote:
Saturday 09 June 2018 10:12
This is what I get as return:

pi@Domoticz:~ $ sudo npm install nefit-easy-http-server -g
/usr/bin/easy-server -> /usr/lib/node_modules/nefit-easy-http-server/bin/easy-server
/usr/lib
└─┬ nefit-easy-http-server@3.1.1
├── bluebird@3.5.1
├─┬ body-parser@1.18.3
│ ├── bytes@3.0.0
│ ├── content-type@1.0.4
│ ├─┬ debug@2.6.9
│ │ └── ms@2.0.0
│ ├── depd@1.1.2
│ ├─┬ http-errors@1.6.3
│ │ ├── inherits@2.0.3
│ │ └── statuses@1.5.0
│ ├─┬ iconv-lite@0.4.23
│ │ └── safer-buffer@2.1.2
│ ├─┬ on-finished@2.3.0
│ │ └── ee-first@1.1.1
│ ├── qs@6.5.2
│ ├─┬ raw-body@2.3.3
│ │ └── unpipe@1.0.0
│ └─┬ type-is@1.6.16
│ ├── media-typer@0.3.0
│ └─┬ mime-types@2.1.18
│ └── mime-db@1.33.0
├─┬ cors@2.8.4
│ ├── object-assign@4.1.1
│ └── vary@1.1.2
├── docopt@0.6.2
├─┬ express@4.16.3
│ ├─┬ accepts@1.3.5
│ │ └── negotiator@0.6.1
│ ├── array-flatten@1.1.1
│ ├─┬ body-parser@1.18.2
│ │ ├── iconv-lite@0.4.19
│ │ └─┬ raw-body@2.3.2
│ │ └─┬ http-errors@1.6.2
│ │ ├── depd@1.1.1
│ │ └── setprototypeof@1.0.3
│ ├── content-disposition@0.5.2
│ ├── cookie@0.3.1
│ ├── cookie-signature@1.0.6
│ ├── encodeurl@1.0.2
│ ├── escape-html@1.0.3
│ ├── etag@1.8.1
│ ├─┬ finalhandler@1.1.1
│ │ └── statuses@1.4.0
│ ├── fresh@0.5.2
│ ├── merge-descriptors@1.0.1
│ ├── methods@1.1.2
│ ├── parseurl@1.3.2
│ ├── path-to-regexp@0.1.7
│ ├─┬ proxy-addr@2.0.3
│ │ ├── forwarded@0.1.2
│ │ └── ipaddr.js@1.6.0
│ ├── qs@6.5.1
│ ├── range-parser@1.2.0
│ ├── safe-buffer@5.1.1
│ ├─┬ send@0.16.2
│ │ ├── destroy@1.0.4
│ │ ├── mime@1.4.1
│ │ └── statuses@1.4.0
│ ├── serve-static@1.13.2
│ ├── setprototypeof@1.1.0
│ ├── statuses@1.4.0
│ └── utils-merge@1.0.1
├─┬ morgan@1.9.0
│ ├── basic-auth@2.0.0
│ └── on-headers@1.0.1
└─┬ nefit-easy-commands@1.8.2
├─┬ nefit-easy-core@2.0.1
│ ├── http-string-parser@0.0.5
│ ├─┬ node-xmpp-client@3.2.0
│ │ ├── browser-request@0.3.3
│ │ ├─┬ md5.js@1.3.4
│ │ │ └── hash-base@3.0.4
│ │ ├── minimist@1.2.0
│ │ ├─┬ node-xmpp-core@5.0.9
│ │ │ ├── @xmpp/jid@0.0.2
│ │ │ ├─┬ @xmpp/streamparser@0.0.6
│ │ │ │ └── ltx@2.7.1
│ │ │ ├── @xmpp/xml@0.1.3
│ │ │ ├── lodash.assign@4.2.0
│ │ │ ├── node-xmpp-tls-connect@1.0.1
│ │ │ └─┬ reconnect-core@0.0.1
│ │ │ └── backoff@2.3.0
│ │ ├─┬ request@2.87.0
│ │ │ ├── aws-sign2@0.7.0
│ │ │ ├── aws4@1.7.0
│ │ │ ├── caseless@0.12.0
│ │ │ ├─┬ combined-stream@1.0.6
│ │ │ │ └── delayed-stream@1.0.0
│ │ │ ├── extend@3.0.1
│ │ │ ├── forever-agent@0.6.1
│ │ │ ├─┬ form-data@2.3.2
│ │ │ │ └── asynckit@0.4.0
│ │ │ ├─┬ har-validator@5.0.3
│ │ │ │ ├─┬ ajv@5.5.2
│ │ │ │ │ ├── co@4.6.0
│ │ │ │ │ ├── fast-deep-equal@1.1.0
│ │ │ │ │ ├── fast-json-stable-stringify@2.0.0
│ │ │ │ │ └── json-schema-traverse@0.3.1
│ │ │ │ └── har-schema@2.0.0
│ │ │ ├─┬ http-signature@1.2.0
│ │ │ │ ├── assert-plus@1.0.0
│ │ │ │ ├─┬ jsprim@1.4.1
│ │ │ │ │ ├── extsprintf@1.3.0
│ │ │ │ │ ├── json-schema@0.2.3
│ │ │ │ │ └─┬ verror@1.10.0
│ │ │ │ │ └── core-util-is@1.0.2
│ │ │ │ └─┬ sshpk@1.14.2
│ │ │ │ ├── asn1@0.2.3
│ │ │ │ ├── bcrypt-pbkdf@1.0.1
│ │ │ │ ├── dashdash@1.14.1
│ │ │ │ ├── ecc-jsbn@0.1.1
│ │ │ │ ├── getpass@0.1.7
│ │ │ │ ├── jsbn@0.1.1
│ │ │ │ └── tweetnacl@0.14.5
│ │ │ ├── is-typedarray@1.0.0
│ │ │ ├── isstream@0.1.2
│ │ │ ├── json-stringify-safe@5.0.1
│ │ │ ├── oauth-sign@0.8.2
│ │ │ ├── performance-now@2.1.0
│ │ │ ├─┬ tough-cookie@2.3.4
│ │ │ │ └── punycode@1.4.1
│ │ │ ├── tunnel-agent@0.6.0
│ │ │ └── uuid@3.2.1
│ │ └─┬ ws@1.1.5
│ │ ├── options@0.0.6
│ │ └── ultron@1.0.2
│ └── promise-queue@2.2.5
└── require-all@2.2.0

pi@Domoticz:~ $
Ok, remove this one first and re-install.

sudo npm uninstall nefit-easy-http-server -g
sudo npm install nefit-easy-http-server -g

This should give you 4.0.1
Ubuntu 16.04.5 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

Biarritz
Posts: 7
Joined: Friday 08 June 2018 23:29
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Nefit Easy XMPP authentication failure

Post by Biarritz » Sunday 10 June 2018 10:31

Did this serveral times already, but 3.1.1 is what I get

Biarritz
Posts: 7
Joined: Friday 08 June 2018 23:29
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Nefit Easy XMPP authentication failure

Post by Biarritz » Sunday 10 June 2018 11:03

I have completely removed /usr/lib/node_modules/nefit-easy-http-server directory
started installation of Nefit easy from scratch
Have now version 4.0.1 running but still receive the Error: NefitEasy: Error getting http data!

SweetPants
Posts: 2350
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.10196
Location: The Netherlands
Contact:

Re: Nefit Easy XMPP authentication failure

Post by SweetPants » Sunday 10 June 2018 12:36

What do you see when starting the easy-server manually with -V (verbose) and domoticz tries to access it?
Ubuntu 16.04.5 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

Biarritz
Posts: 7
Joined: Friday 08 June 2018 23:29
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Nefit Easy XMPP authentication failure

Post by Biarritz » Sunday 10 June 2018 13:34

Hmm, this is what I get:

pi@Domoticz:~ $ easy-server --serial=your-xxxx --access-key=xxxx --password=xxxx --host=127.0.0.1
{ SASLError: not-authorized
at XMPPError (/usr/lib/node_modules/nefit-easy-http-server/node_modules/@xmpp/connection/index.js:10:5)
at SASLError (/usr/lib/node_modules/nefit-easy-http-server/node_modules/@xmpp/plugins/sasl/index.js:14:5)
at EventEmitter.handler (/usr/lib/node_modules/nefit-easy-http-server/node_modules/@xmpp/plugins/sasl/index.js:144:15)
at emitOne (events.js:101:20)
at EventEmitter.emit (events.js:188:7)
at Client.EventEmitter.(anonymous function) [as emit] (/usr/lib/node_modules/nefit-easy-http-server/node_modules/@xmpp/events/lib/EventEmitter.js:46:24)
at Parser.listeners.element.element (/usr/lib/node_modules/nefit-easy-http-server/node_modules/@xmpp/connection/index.js:118:12)
at emitOne (events.js:96:13)
at Parser.emit (events.js:188:7)
at Parser.onEndElement (/usr/lib/node_modules/nefit-easy-http-server/node_modules/@xmpp/connection-tcp/node_modules/@xmpp/xml/lib/Parser.js:54:12)
at SaxLtx.Parser.parser.on.name (/usr/lib/node_modules/nefit-easy-http-server/node_modules/@xmpp/connection-tcp/node_modules/@xmpp/xml/lib/Parser.js:33:14)
at emitOne (events.js:96:13)
at SaxLtx.emit (events.js:188:7)
at SaxLtx._handleTagOpening (/usr/lib/node_modules/nefit-easy-http-server/node_modules/ltx/lib/parsers/ltx.js:38:12)
at SaxLtx.write (/usr/lib/node_modules/nefit-easy-http-server/node_modules/ltx/lib/parsers/ltx.js:127:18)
at Parser.write (/usr/lib/node_modules/nefit-easy-http-server/node_modules/@xmpp/connection-tcp/node_modules/@xmpp/xml/lib/Parser.js:67:17)
name: 'SASLError',
condition: 'not-authorized',
text: '',
element:
Element {
name: 'failure',
parent:
Element {
name: 'stream:stream',
parent: null,
children: [Object],
attrs: [Object] },
children: [ [Object] ],
attrs: { xmlns: 'urn:ietf:params:xml:ns:xmpp-sasl' } } }
pi@Domoticz:~ $

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests