Installation on Ubuntu Topic is solved

On various Hardware and OS systems: pi / windows / routers / nas, etc
Post Reply
tre4bax
Posts: 55
Joined: Tuesday 23 September 2014 10:18
Target OS: Raspberry Pi
Domoticz version:
Contact:

Installation on Ubuntu

Post by tre4bax » Saturday 26 May 2018 23:36

I am trying to install Domoticz on Ubuntu (18.04).

All seemed to go okay and it seemed to install. It said it started and yet I cannot get anything to connect to the web server platform. How do I verify that Domoticz is actually working? I can't find it when I do a ps -A or anything that simple and the scripts "seem" to make it start and stop, yet nothing will attach to it.

Any help with this mystery would be gratefully received.

seansco
Posts: 11
Joined: Tuesday 01 March 2016 21:51
Target OS: Linux
Domoticz version:
Contact:

Re: Installation on Ubuntu

Post by seansco » Wednesday 30 May 2018 22:49

do you have a file called domoticz.sh in /etc/init.d ?


try "service domoticz.sh status"

tre4bax
Posts: 55
Joined: Tuesday 23 September 2014 10:18
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Installation on Ubuntu

Post by tre4bax » Thursday 31 May 2018 17:38

Yes l do. haven't tried that though so l will tonight. l was planning to try the build it yourself instructions tonight. That might fix it too.

Ta for the pointer I will let you know later.

Trev

tre4bax
Posts: 55
Joined: Tuesday 23 September 2014 10:18
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Installation on Ubuntu

Post by tre4bax » Saturday 02 June 2018 14:15

Just finished rebuilding it all from scratch following the wiki to the letter. Still there is no web server on 8080 on that server.

I have tried the ./domoticz.sh status and it says the service is running. It is not though. I can't find anything using ps -A that suggests it is. Just not sure if that is right or wrong. Everything looks good. It is simply not doing anything.

SweetPants
Posts: 2087
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.9701
Location: The Netherlands
Contact:

Re: Installation on Ubuntu

Post by SweetPants » Saturday 02 June 2018 14:28

tre4bax wrote:
Saturday 02 June 2018 14:15
Just finished rebuilding it all from scratch following the wiki to the letter. Still there is no web server on 8080 on that server.

I have tried the ./domoticz.sh status and it says the service is running. It is not though. I can't find anything using ps -A that suggests it is. Just not sure if that is right or wrong. Everything looks good. It is simply not doing anything.
post the output of ps -ef | grep domoticz

Have you tried another port (-www 8888) ? Maybe this one is already occupied?
Ubuntu 16.04.3 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (source)

tre4bax
Posts: 55
Joined: Tuesday 23 September 2014 10:18
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Installation on Ubuntu

Post by tre4bax » Sunday 03 June 2018 22:00

Having trouble getting back on the machine to do any of this.

I have a feeling it is still compiling domoticz, just very slowly. hence why it does not seem to be running. I plan to just leave it for a couple of days and see if it frees up. If not I will start from scratch. Once I get in again I will post the results from PS etc. if it is not all miraculously working of course.

maomanna
Posts: 108
Joined: Monday 30 November 2015 17:21
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Installation on Ubuntu

Post by maomanna » Monday 04 June 2018 11:32

are all packages installed with the correct version?
Cause of 18.04, you have newer packages then 16.04.

tre4bax
Posts: 55
Joined: Tuesday 23 September 2014 10:18
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Installation on Ubuntu

Post by tre4bax » Thursday 07 June 2018 22:16

Hi All,

It is now up and running and I am happy. Have transfered my config from the Raspberry pi and it happily controls lights etc. Only challenge I have left is that the UI page does not update after a command and has to be refreshed before it works.

The issue here was just how much processing power the compile was taking. I made the assumption it had compiled when it actually had not finished. Now after nearly a week it is working :-) Will ask about the update issue in another thread. Thanks for all your help and suggestions.

gordonb3
Posts: 99
Joined: Saturday 31 March 2018 22:24
Target OS: Linux
Domoticz version: Custom
Location: Delft, NL
Contact:

Re: Installation on Ubuntu

Post by gordonb3 » Thursday 07 June 2018 23:18

Unsure about your problem. You say Ubuntu, yet your profile states Raspberry. I don't think Ubuntu has a release for Pi? So assuming you are on Ubuntu it has to be something bigger in CPU and I usually (cross)compile Domoticz in about ten minutes, so I'm confused about you needing a week for that?

tre4bax
Posts: 55
Joined: Tuesday 23 September 2014 10:18
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Installation on Ubuntu

Post by tre4bax » Thursday 07 June 2018 23:44

I'm moving it from my Raspberry PI to an Ubuntu computer. Once I'm happy it is working I will need to update my signature ;-)

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests