MDAH and v3.9501 no connection to devices

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
User avatar
waaren
Posts: 702
Joined: Tuesday 03 January 2017 15:18
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: MDAH and v3.9501 no connection to devices

Post by waaren » Tuesday 29 May 2018 12:21

opened issue https://github.com/empierre/MyDomoAtHome/issues/169 (was already reported as a domoticz issue)
Raspberry (debian stretch via berryboot on Synology DS916+) , Domoticz (almost) latest Beta, , dzVents 2.6, RFLink, RFXtrx433e, P1, Youless, Harmony, Hue, Yeelight, Xiaomi, HomeWizard, Zwave, Amazon echo

User avatar
epierre
Posts: 809
Joined: Wednesday 05 March 2014 14:16
Target OS: Linux
Domoticz version:
Location: France
Contact:

Re: MDAH and v3.9501 no connection to devices

Post by epierre » Tuesday 29 May 2018 12:22

Hello,

Has this being identified by gizmocuz or is that a wanted behavior ?
ImperiHome & MyDomoAtHome on top of:
868.42Mhz - Vera Lite - Fibaro SS-101, S-211, K-101, FWP - Fortress SSA2
433Mhz - Cubie Domoticz + RFXtrx + Oregon || Foscam 9821W
2,4Ghz - Cubie MySensors Gateway + COV + TempHumidity + Pressure + WaterMeter

vulbas
Posts: 46
Joined: Tuesday 20 February 2018 18:59
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MDAH and v3.9501 no connection to devices

Post by vulbas » Tuesday 29 May 2018 12:43

waaren wrote:
Tuesday 29 May 2018 12:21
opened issue https://github.com/empierre/MyDomoAtHome/issues/169 (was already reported as a domoticz issue)
thank you, I had not thought to put on the github MDAH

merci, je n'avais pas pensé à mettre sur le github MDAH

User avatar
epierre
Posts: 809
Joined: Wednesday 05 March 2014 14:16
Target OS: Linux
Domoticz version:
Location: France
Contact:

Re: MDAH and v3.9501 no connection to devices

Post by epierre » Thursday 31 May 2018 16:06

Hi all,

fix done, package tonight, stay tuned !
ImperiHome & MyDomoAtHome on top of:
868.42Mhz - Vera Lite - Fibaro SS-101, S-211, K-101, FWP - Fortress SSA2
433Mhz - Cubie Domoticz + RFXtrx + Oregon || Foscam 9821W
2,4Ghz - Cubie MySensors Gateway + COV + TempHumidity + Pressure + WaterMeter

User avatar
epierre
Posts: 809
Joined: Wednesday 05 March 2014 14:16
Target OS: Linux
Domoticz version:
Location: France
Contact:

Re: MDAH and v3.9501 no connection to devices

Post by epierre » Thursday 31 May 2018 19:46

package 0.2.38 is out !
ImperiHome & MyDomoAtHome on top of:
868.42Mhz - Vera Lite - Fibaro SS-101, S-211, K-101, FWP - Fortress SSA2
433Mhz - Cubie Domoticz + RFXtrx + Oregon || Foscam 9821W
2,4Ghz - Cubie MySensors Gateway + COV + TempHumidity + Pressure + WaterMeter

vulbas
Posts: 46
Joined: Tuesday 20 February 2018 18:59
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MDAH and v3.9501 no connection to devices

Post by vulbas » Thursday 31 May 2018 20:32

I no longer have access to the MDAH page

Code: Select all

pi@raspberrypi:~ $ curl http://192.168.1.225:3002/devices
curl: (7) Failed to connect to 192.168.1.225 port 3002: Connexion refusée
pi@raspberrypi:~ $ curl http://192.168.1.225:3002
curl: (7) Failed to connect to 192.168.1.225 port 3002: Connexion refusée

Code: Select all

pi@raspberrypi:~ $ node --version
v4.2.2
pi@raspberrypi:~ $ npm --version
2.15.12
pi@raspberrypi:~ $ sudo service mydomoathome status
● mydomoathome.service - MDAH ISS Rest interface for Domoticz to Imperihome
   Loaded: loaded (/etc/systemd/system/mydomoathome.service; enabled; vendor pre
   Active: active (running) since Thu 2018-05-31 20:26:15 CEST; 7min ago
  Process: 3424 ExecStartPre=/bin/chmod 755 /run/mydomoathome (code=exited, stat
  Process: 3421 ExecStartPre=/bin/chown www-data:www-data /etc/mydomoathome/conf
  Process: 3418 ExecStartPre=/bin/chown www-data:www-data /run/mydomoathome (cod
  Process: 3415 ExecStartPre=/bin/mkdir -p /run/mydomoathome (code=exited, statu
 Main PID: 3427 (mydomoathome)
   CGroup: /system.slice/mydomoathome.service
           ├─3427 /bin/bash /usr/share/mydomoathome/bin/mydomoathome
           ├─3428 node /usr/local/bin/forever --minUptime 5000 --spinSleepTime 2
           └─4580 /usr/bin/node /usr/share/mydomoathome/app/mdah.js

mai 31 20:33:35 raspberrypi MDAH[3427]:     at Module.require (module.js:366:17)
mai 31 20:33:35 raspberrypi MDAH[3427]:     at require (module.js:385:17)
mai 31 20:33:35 raspberrypi MDAH[3427]:     at Object.<anonymous> (/usr/share/my
mai 31 20:33:35 raspberrypi MDAH[3427]:     at Module._compile (module.js:435:26
mai 31 20:33:35 raspberrypi MDAH[3427]:     at Object.Module._extensions..js (mo
mai 31 20:33:35 raspberrypi MDAH[3427]:     at Module.load (module.js:356:32)
mai 31 20:33:35 raspberrypi MDAH[3427]:     at Function.Module._load (module.js:
mai 31 20:33:35 raspberrypi MDAH[3427]:     at Function.Module.runMain (module.j
mai 31 20:33:35 raspberrypi MDAH[3427]: error: Forever detected script exited wi
mai 31 20:33:38 raspberrypi MDAH[3427]: error: Script restart attempt #102
lines 1-23...skipping...
● mydomoathome.service - MDAH ISS Rest interface for Domoticz to Imperihome
   Loaded: loaded (/etc/systemd/system/mydomoathome.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2018-05-31 20:26:15 CEST; 7min ago
  Process: 3424 ExecStartPre=/bin/chmod 755 /run/mydomoathome (code=exited, status=0/SUCCESS)
  Process: 3421 ExecStartPre=/bin/chown www-data:www-data /etc/mydomoathome/config.json (code=exited, status=0/SUCCESS)
  Process: 3418 ExecStartPre=/bin/chown www-data:www-data /run/mydomoathome (code=exited, status=0/SUCCESS)
  Process: 3415 ExecStartPre=/bin/mkdir -p /run/mydomoathome (code=exited, status=0/SUCCESS)
 Main PID: 3427 (mydomoathome)
   CGroup: /system.slice/mydomoathome.service
           ├─3427 /bin/bash /usr/share/mydomoathome/bin/mydomoathome
           ├─3428 node /usr/local/bin/forever --minUptime 5000 --spinSleepTime 2000 --max-old-space-size=128 -a -l /var/log/mydomoathome/mdah.log /usr/share/mydomoathome/app/mdah.js
           └─4580 /usr/bin/node /usr/share/mydomoathome/app/mdah.js

mai 31 20:33:35 raspberrypi MDAH[3427]:     at Module.require (module.js:366:17)
mai 31 20:33:35 raspberrypi MDAH[3427]:     at require (module.js:385:17)
mai 31 20:33:35 raspberrypi MDAH[3427]:     at Object.<anonymous> (/usr/share/mydomoathome/app/mdah.js:38:16)
mai 31 20:33:35 raspberrypi MDAH[3427]:     at Module._compile (module.js:435:26)
mai 31 20:33:35 raspberrypi MDAH[3427]:     at Object.Module._extensions..js (module.js:442:10)
mai 31 20:33:35 raspberrypi MDAH[3427]:     at Module.load (module.js:356:32)
mai 31 20:33:35 raspberrypi MDAH[3427]:     at Function.Module._load (module.js:311:12)
mai 31 20:33:35 raspberrypi MDAH[3427]:     at Function.Module.runMain (module.js:467:10)
mai 31 20:33:35 raspberrypi MDAH[3427]: error: Forever detected script exited with code: 1
mai 31 20:33:38 raspberrypi MDAH[3427]: error: Script restart attempt #102

User avatar
epierre
Posts: 809
Joined: Wednesday 05 March 2014 14:16
Target OS: Linux
Domoticz version:
Location: France
Contact:

Re: MDAH and v3.9501 no connection to devices

Post by epierre » Thursday 31 May 2018 21:03

right, dependency issue, I'm pushing 0.2.39 now
ImperiHome & MyDomoAtHome on top of:
868.42Mhz - Vera Lite - Fibaro SS-101, S-211, K-101, FWP - Fortress SSA2
433Mhz - Cubie Domoticz + RFXtrx + Oregon || Foscam 9821W
2,4Ghz - Cubie MySensors Gateway + COV + TempHumidity + Pressure + WaterMeter

vulbas
Posts: 46
Joined: Tuesday 20 February 2018 18:59
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MDAH and v3.9501 no connection to devices

Post by vulbas » Thursday 31 May 2018 21:21

pppeeerrrfffeeeccctttttttttt

thank you :D :D :D :D :D :D

User avatar
epierre
Posts: 809
Joined: Wednesday 05 March 2014 14:16
Target OS: Linux
Domoticz version:
Location: France
Contact:

Re: MDAH and v3.9501 no connection to devices

Post by epierre » Thursday 31 May 2018 21:23

:D :D :D :D
ImperiHome & MyDomoAtHome on top of:
868.42Mhz - Vera Lite - Fibaro SS-101, S-211, K-101, FWP - Fortress SSA2
433Mhz - Cubie Domoticz + RFXtrx + Oregon || Foscam 9821W
2,4Ghz - Cubie MySensors Gateway + COV + TempHumidity + Pressure + WaterMeter

scorp99fr
Posts: 1
Joined: Saturday 26 May 2018 11:55
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MDAH and v3.9501 no connection to devices

Post by scorp99fr » Thursday 31 May 2018 22:55

Wouhouuuu it works again very fine !!! :D
Thank you very much for your work :D

KingOfIce
Posts: 1
Joined: Thursday 31 May 2018 23:13
Target OS: NAS (Synology & others)
Domoticz version:
Contact:

Re: MDAH and v3.9501 no connection to devices

Post by KingOfIce » Thursday 31 May 2018 23:15

I confirm it works on Synology too. Thanks a lot !

User avatar
EdddieN
Posts: 344
Joined: Wednesday 16 November 2016 12:31
Target OS: Raspberry Pi
Domoticz version: 4.9700
Location: Scotland
Contact:

Re: MDAH and v3.9501 no connection to devices

Post by EdddieN » Wednesday 11 July 2018 0:53

Is this working again on the RPI? using 4.9700 and I get:

Code: Select all

curl: (52) Empty reply from server
tried to install everything and start over as per https://github.com/empierre/MyDomoAtHome
node v: 4.2.2
npm v: 2.14.7
11101101 - www.machinon.com

User avatar
epierre
Posts: 809
Joined: Wednesday 05 March 2014 14:16
Target OS: Linux
Domoticz version:
Location: France
Contact:

Re: MDAH and v3.9501 no connection to devices

Post by epierre » Sunday 15 July 2018 20:17

Hello,

in 4.9785 it works fine for me, can you confirm ?
ImperiHome & MyDomoAtHome on top of:
868.42Mhz - Vera Lite - Fibaro SS-101, S-211, K-101, FWP - Fortress SSA2
433Mhz - Cubie Domoticz + RFXtrx + Oregon || Foscam 9821W
2,4Ghz - Cubie MySensors Gateway + COV + TempHumidity + Pressure + WaterMeter

User avatar
EdddieN
Posts: 344
Joined: Wednesday 16 November 2016 12:31
Target OS: Raspberry Pi
Domoticz version: 4.9700
Location: Scotland
Contact:

Re: MDAH and v3.9501 no connection to devices

Post by EdddieN » Monday 16 July 2018 12:04

I installed on a spare RPI with 4.9700 and all working fine. I guess I must have some libraries broken.

Using much higher node and npm -v than stated on the instructions there
11101101 - www.machinon.com

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests