Xiaomi Cube - XiaomiGateway: unhandled model: sensor_cube.aqgl01

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
MarFan
Posts: 40
Joined: Monday 02 September 2013 15:09
Target OS: Raspberry Pi
Domoticz version:
Contact:

Xiaomi Cube - XiaomiGateway: unhandled model: sensor_cube.aqgl01

Post by MarFan » Tuesday 15 May 2018 10:10

Version: 3.9389 (beta)
Platform: Pi
Plugin/Hardware: Pi
Description: added (on a working GW) the (new arrived) cube.
In Mi Home, everything is working,
In the log I see the error message : XiaomiGateway: unhandled model: sensor_cube.aqgl01
No device is created.
MarFan / NL / 3x RasPi / RfXcom / RfLink / S0PCM-5 / P1

marigo
Posts: 35
Joined: Sunday 31 May 2015 11:04
Target OS: Raspberry Pi
Domoticz version: V3.9527
Location: The Netherlands, Veenendaal
Contact:

Re: Xiaomi Cube - XiaomiGateway: unhandled model: sensor_cube.aqgl01

Post by marigo » Tuesday 15 May 2018 10:38

Exact same problem here. Found https://github.com/Danielhiversen/PyXia ... /issues/67 , but don't know how to manually add this.

MarFan
Posts: 40
Joined: Monday 02 September 2013 15:09
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Xiaomi Cube - XiaomiGateway: unhandled model: sensor_cube.aqgl01

Post by MarFan » Tuesday 15 May 2018 10:54

Thanks,
I think we have to wait for new beta version with this included ?
MarFan / NL / 3x RasPi / RfXcom / RfLink / S0PCM-5 / P1

marigo
Posts: 35
Joined: Sunday 31 May 2015 11:04
Target OS: Raspberry Pi
Domoticz version: V3.9527
Location: The Netherlands, Veenendaal
Contact:

Re: Xiaomi Cube - XiaomiGateway: unhandled model: sensor_cube.aqgl01

Post by marigo » Tuesday 15 May 2018 11:13

Yep, think so too. Just updated to last beta, but still no luck.

1981nick1981
Posts: 12
Joined: Friday 23 March 2018 9:29
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Xiaomi Cube - XiaomiGateway: unhandled model: sensor_cube.aqgl01

Post by 1981nick1981 » Wednesday 16 May 2018 20:16

Yesterday I added the model to domoticz on Github. Does it work now? Can not check it.

See: https://github.com/domoticz/domoticz/pull/2393

MarFan
Posts: 40
Joined: Monday 02 September 2013 15:09
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Xiaomi Cube - XiaomiGateway: unhandled model: sensor_cube.aqgl01

Post by MarFan » Thursday 17 May 2018 10:01

I updated to version 9445, but no new device
Also the error message does not appear anymore,
I do have [Accept new Hardware Devices ] enabled
MarFan / NL / 3x RasPi / RfXcom / RfLink / S0PCM-5 / P1

1981nick1981
Posts: 12
Joined: Friday 23 March 2018 9:29
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Xiaomi Cube - XiaomiGateway: unhandled model: sensor_cube.aqgl01

Post by 1981nick1981 » Thursday 17 May 2018 18:47

MarFan wrote:
Thursday 17 May 2018 10:01
I updated to version 9445, but no new device
Also the error message does not appear anymore,
I do have [Accept new Hardware Devices ] enabled
I do indeed have the same problem. The error message in the log is gone, but it can not be found in the list of devices. Is there someone who knows how to solve this?

marigo
Posts: 35
Joined: Sunday 31 May 2015 11:04
Target OS: Raspberry Pi
Domoticz version: V3.9527
Location: The Netherlands, Veenendaal
Contact:

Re: Xiaomi Cube - XiaomiGateway: unhandled model: sensor_cube.aqgl01

Post by marigo » Thursday 17 May 2018 20:13

Updated to the last beta and also no log message anymore, but also no cube.
Tried to remove the cube and add it again; still no luck.

Any suggestions?

1981nick1981
Posts: 12
Joined: Friday 23 March 2018 9:29
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Xiaomi Cube - XiaomiGateway: unhandled model: sensor_cube.aqgl01

Post by 1981nick1981 » Friday 18 May 2018 21:01

The problem is still present see the presence of the cube in the log but in devices it is still not visible.

2018-05-18 20:49:09.879 {"cmd":"heartbeat","model":"sensor_cube.aqgl01","sid":"****","short_id":****,"data":"{\"voltage\":2975}"}

Link to Github xiaomi location domoticz:
https://github.com/domoticz/domoticz/bl ... ateway.cpp

marigo
Posts: 35
Joined: Sunday 31 May 2015 11:04
Target OS: Raspberry Pi
Domoticz version: V3.9527
Location: The Netherlands, Veenendaal
Contact:

Re: Xiaomi Cube - XiaomiGateway: unhandled model: sensor_cube.aqgl01

Post by marigo » Monday 28 May 2018 16:22

Installed last beta today "9527" but the new cube isn't recognized by domoticz.
Can it be implemented by the developers?

joostnl
Posts: 52
Joined: Wednesday 03 February 2016 20:22
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Xiaomi Cube - XiaomiGateway: unhandled model: sensor_cube.aqgl01

Post by joostnl » Monday 28 May 2018 17:41

Could we owners supply some debug for an smarter developer?

1981nick1981
Posts: 12
Joined: Friday 23 March 2018 9:29
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Xiaomi Cube - XiaomiGateway: unhandled model: sensor_cube.aqgl01

Post by 1981nick1981 » Monday 28 May 2018 20:08

The same problem exists in home-assistant and would have to do with the new "Gateway LAN communication protocol V2.0" This is not supported by gateway v2 so the signals are not sent over the network and are only available in the mi home app. At the moment the cube can only be read through solutions such as Zigate and zigbee2mqtt. The Air Conditioning Controller can also handle this signal.

Link to discussion Github:
https://github.com/home-assistant/home- ... pull/14393

marigo
Posts: 35
Joined: Sunday 31 May 2015 11:04
Target OS: Raspberry Pi
Domoticz version: V3.9527
Location: The Netherlands, Veenendaal
Contact:

Re: Xiaomi Cube - XiaomiGateway: unhandled model: sensor_cube.aqgl01

Post by marigo » Monday 28 May 2018 20:38

Ok, so options are:

Buy a Aqara gateway 3 or a Zigate stick or the hardware needed for zigbee2mqtt?

Is it just not possible for Mi/Aqara to support the V2 protocol via a firmware update?

1981nick1981
Posts: 12
Joined: Friday 23 March 2018 9:29
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Xiaomi Cube - XiaomiGateway: unhandled model: sensor_cube.aqgl01

Post by 1981nick1981 » Monday 28 May 2018 21:02

I do not know. I have now ordered the components to build the zigbee2mqtt solution. Hopefully here is someone with programming skills who knows the answer.

marigo
Posts: 35
Joined: Sunday 31 May 2015 11:04
Target OS: Raspberry Pi
Domoticz version: V3.9527
Location: The Netherlands, Veenendaal
Contact:

Re: Xiaomi Cube - XiaomiGateway: unhandled model: sensor_cube.aqgl01

Post by marigo » Monday 28 May 2018 21:11

Ok, check!
I just wait a few days/weeks to think about it and to do some investigation.

Thank you for support!

dragstere42
Posts: 1
Joined: Monday 28 May 2018 22:47
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Xiaomi Cube - XiaomiGateway: unhandled model: sensor_cube.aqgl01

Post by dragstere42 » Monday 28 May 2018 22:51

I found it on the jeedom plugin:

Version du 25 mai 2018
Ajout de la nouvelle version du Cube Aqara (actuellement le firmware de la gateway ne renvoit pas les infos, uniquement la batterie)

It said that for now the gateway firmware version only send batterie information for aqua cube.
Maybe we just need to wait a new gateway version for aqua cube ?

I will try to contact xiaomi.

whatisk
Posts: 25
Joined: Sunday 15 October 2017 6:13
Target OS: Linux
Domoticz version: 3.9224
Location: Australia
Contact:

Re: Xiaomi Cube - XiaomiGateway: unhandled model: sensor_cube.aqgl01

Post by whatisk » Thursday 14 June 2018 12:50

dragstere42 wrote:
Monday 28 May 2018 22:51
I will try to contact xiaomi.
Did you get in contact with Xiaomi and has there been any response?
I just received a Xiaomi Aqara Cube today. I thought I had read somewhere it was compatible but obviously not.
I'm even finding it very sluggish through the MiHome App (China server) responding to any actions. To the point where it isn't really useful in setting up to do anything.

Post Reply

Who is online

Users browsing this forum: No registered users and 17 guests