Turn off light after x sexonds dows not work as expected

Post Reply
burton666
Posts: 104
Joined: Monday 17 August 2015 21:25
Target OS: Raspberry Pi
Domoticz version:
Contact:

Turn off light after x sexonds dows not work as expected

Post by burton666 » Friday 11 May 2018 9:04

I am trying to configure the blocky so that every time motion is detected the "countdown timer" gets reset to 900 sec. But as it works now it flickers off/on very quickly from time to time. Should it work theoreticly as I want or have I made any error?
domoticz.PNG
domoticz.PNG (29.52 KiB) Viewed 589 times

Cybertom
Posts: 12
Joined: Tuesday 13 October 2015 10:04
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Turn off light after x sexonds dows not work as expected

Post by Cybertom » Friday 11 May 2018 12:57

1e line: first motion must be off before resetting counter thats not what you want.
you want everytime there is moiton reset the counter to 900.

So you have to Remove Datorrum motion=Off

burton666
Posts: 104
Joined: Monday 17 August 2015 21:25
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Turn off light after x sexonds dows not work as expected

Post by burton666 » Monday 14 May 2018 7:49

I tried changing it to "when motion = ON and Light = ON, turn off after 900 sec" but it still flickers off/on quite often. So it seams that the 900 second timer does not reset after each new movement.

snellejellep
Posts: 105
Joined: Tuesday 16 May 2017 13:05
Target OS: Raspberry Pi
Domoticz version: 3.97xx
Location: The Neterlands
Contact:

Re: Turn off light after x sexonds dows not work as expected

Post by snellejellep » Monday 14 May 2018 14:32

what will work is a dummy switch with a turn off timer that you turn on instead off the block with 900 seconds. the dummy switch will reset its timer when turned on if it is still on. i struggled with this too and that was the solution for me.
raspberry pi | xiaomi gateway/vacuum | yeelight | philips hue | zwave |ubiquiti unifi | harmony

kuifje
Posts: 16
Joined: Wednesday 25 October 2017 16:38
Target OS: Windows
Domoticz version:
Contact:

Re: Turn off light after x sexonds dows not work as expected

Post by kuifje » Monday 14 May 2018 14:36

viewtopic.php?f=62&t=20048
Mabey this will help. I had the same problem but solved with this.
Greetsz
Kuifje

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests