Domoticz opens firefox at startup

On various Hardware and OS systems: pi / windows / routers / nas, etc
Post Reply
Skwi
Posts: 6
Joined: Thursday 10 May 2018 9:37
Target OS: Windows
Domoticz version:
Contact:

Domoticz opens firefox at startup

Post by Skwi » Thursday 10 May 2018 9:44

Hi, I'm new on domoticz and I installed it on my Windows 10 (as an app not service if that can help).
When I start my computer now, firefox (default nav) starts too on the domoticz page plus makes freeze firefox and I have to kill it in the task mgr.
I couldn't find in the parameters where I can disable that behaviour. An idea?

Thanks

SweetPants
Posts: 2178
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.9913
Location: The Netherlands
Contact:

Re: Domoticz opens firefox at startup

Post by SweetPants » Thursday 10 May 2018 10:56

This is not a domoticz thing but a browser/OS issue.
Ubuntu 16.04.3 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

gordonb3
Posts: 129
Joined: Saturday 31 March 2018 22:24
Target OS: Linux
Domoticz version: Custom
Location: Delft, NL
Contact:

Re: Domoticz opens firefox at startup

Post by gordonb3 » Thursday 10 May 2018 11:14

if you had run `domoticz /?` you would have found there is a command line switch to disable automatic browser startup.

Skwi
Posts: 6
Joined: Thursday 10 May 2018 9:37
Target OS: Windows
Domoticz version:
Contact:

Re: Domoticz opens firefox at startup

Post by Skwi » Thursday 10 May 2018 15:47

SweetPants wrote:
Thursday 10 May 2018 10:56
This is not a domoticz thing but a browser/OS issue.
Before I installed domoticz my browser didn't start when my computer turn on, so it's directly linked to domoticz (plus my default web page isn't domoticz)
gordonb3 wrote:
Thursday 10 May 2018 11:14
if you had run `domoticz /?` you would have found there is a command line switch to disable automatic browser startup.
Where can I run such a command on windows? This is not a recognised command, maybve I need to add a varaible path but I don't know which one.

Ok so I find out how to do so on Windows :
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp
Edit the properties and add in target :
"C:\Program Files (x86)\Domoticz\domoticz.exe" -startupdelay 10 -www 8080 -sslwww 443 -nobrowser

(found the option on this thread : http://www.domoticz.com/forum/viewtopic.php?t=13141)

gordonb3
Posts: 129
Joined: Saturday 31 March 2018 22:24
Target OS: Linux
Domoticz version: Custom
Location: Delft, NL
Contact:

Re: Domoticz opens firefox at startup

Post by gordonb3 » Thursday 10 May 2018 18:07

You would have to run that previously mentioned command in the scary black screen that only (very) old people know how to work with ;)

Skwi
Posts: 6
Joined: Thursday 10 May 2018 9:37
Target OS: Windows
Domoticz version:
Contact:

Re: Domoticz opens firefox at startup

Post by Skwi » Sunday 13 May 2018 11:59

gordonb3 wrote:
Thursday 10 May 2018 18:07
You would have to run that previously mentioned command in the scary black screen that only (very) old people know how to work with ;)
If you are talking about windows cmd I of course did try it. I get in the right folder but when I run "domoticz /?" nothing is displayed and domotic just start as usual. If you are talking about another console specific to domoticz I don't know where I can find that (I can only show/hide display console but cannot type anything in it)

gordonb3
Posts: 129
Joined: Saturday 31 March 2018 22:24
Target OS: Linux
Domoticz version: Custom
Location: Delft, NL
Contact:

Re: Domoticz opens firefox at startup

Post by gordonb3 » Tuesday 15 May 2018 10:45

That's not what you posted before. You said it was `not a recognised command`

In any case, the `/?` should have given you the help screen on Windows. If it didn't I don't know why. Alternate parameters for displaying the help screen are `-h` or `--help`

Skwi
Posts: 6
Joined: Thursday 10 May 2018 9:37
Target OS: Windows
Domoticz version:
Contact:

Re: Domoticz opens firefox at startup

Post by Skwi » Thursday 17 May 2018 20:31

Yeah, not a recognised command, but how would I have this information if I didn't tried this in a console? :/

For more details, if I open cmd in windows and type only "domoticz" with any command (/? -h -help etc.) I got this :
C:\Users\Skwi>domoticz /?
'domoticz' n’est pas reconnu en tant que commande interne
ou externe, un programme exécutable ou un fichier de commandes.

If i go in the folder where domoticz is installed if domoticz is off it just turns on without any information in cmd (even with /?)
If it's on I got : Another instance of Domoticz is already running!

It's probably a windows issue for not getting the help with this cmd, I need to install domoticz on my rpi anyway.

gordonb3
Posts: 129
Joined: Saturday 31 March 2018 22:24
Target OS: Linux
Domoticz version: Custom
Location: Delft, NL
Contact:

Re: Domoticz opens firefox at startup

Post by gordonb3 » Thursday 17 May 2018 20:58

All I can say is that it should display the help and finish. If it doesn't I don't know why. Also, the nobrowser option is Windows only so you will not see that when running it on a Pi or other Linux machine.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests