Python Plugin: Python Plugin Manager

Python and python framework
misko903
Posts: 50
Joined: Thursday 27 September 2018 22:58
Target OS: Raspberry Pi
Domoticz version: Latest
Location: Trencin, Slovakia
Contact:

Re: Python Plugin: Python Plugin Manager

Post by misko903 » Sunday 04 November 2018 21:17

ycahome wrote:
Tuesday 30 October 2018 14:23
misko903 wrote:
Tuesday 30 October 2018 11:22
plus I can't see the latest published zigbee2mqqt plugin. Is there way to update?
zigbee2mqqt plugin just added.

In order to add plugin to PP Manager you should raise a "Pull Request" on github

TO CONTRIBUTE YOUR PLUGINS:
In order to add your plugins to PP-Manager, make a "pull request" with your lines added:

Under 'label="Domoticz Plugin"' in alphabetical order by 'label' and

Under 'self.plugindata' in alphabetical order by 'pluginText'
repeated the steps to install PPManager. Now I can see zigbee2mqtt!
thanks

misko903
Posts: 50
Joined: Thursday 27 September 2018 22:58
Target OS: Raspberry Pi
Domoticz version: Latest
Location: Trencin, Slovakia
Contact:

Re: Python Plugin: Python Plugin Manager

Post by misko903 » Sunday 04 November 2018 21:19

ycahome wrote:
Tuesday 30 October 2018 14:20
misko903 wrote:
Monday 29 October 2018 9:15
what about updates of plugins?
after every restart, my RPi is telling me, that update for ebusd plugin is available. How can i update it?

Thank you,
Michal
Read the very first post for usage:
"Auto Update" Options (After every change press "Update")

"All": Continuously update all plugins

"Selected":Continuously update selected plugin (You should first select desired plugin from "Domoticz Plugin" field)

"All (NotifyOnly)": Check all plugins for updates and generate notification email.

"Selected (NotifyOnly)":Check selected plugin for updates and generate notification email. (You should first select desired plugin from "Domoticz Plugin" field)
Thanks, I am using Slovak translation of DZ, it is partially translated, therefor I was confused. Now setted up correctly and it does not bother me again...

dextm80
Posts: 139
Joined: Tuesday 24 October 2017 18:32
Target OS: Linux
Domoticz version: 4.10159
Contact:

Re: Python Plugin: Python Plugin Manager

Post by dextm80 » Thursday 08 November 2018 9:10

dextm80 wrote:
Saturday 03 November 2018 17:45

Code: Select all

2018-11-03 16:45:10.005 Error: Python Plugin Manager hardware (13) thread seems to have ended unexpectedly 
why?
i've already this error, anyone who known this error mean?
Domoticz on AsRock j3455-ITX 8gb ram - Aeotec ZWave Usb Stick - RFLink 433Mhz
1x Fibaro Wall Plug
1x Fibaro Motion Sensor
x NeoCoolcam Wall Plug
Netatmo Weather Station - Netatmo Thermostat
Philips Hue Bridge

User avatar
ycahome
Posts: 217
Joined: Sunday 12 February 2017 11:55
Target OS: Linux
Domoticz version: lat Beta
Contact:

Re: Python Plugin: Python Plugin Manager

Post by ycahome » Thursday 08 November 2018 10:10

dextm80 wrote:
Thursday 08 November 2018 9:10
dextm80 wrote:
Saturday 03 November 2018 17:45

Code: Select all

2018-11-03 16:45:10.005 Error: Python Plugin Manager hardware (13) thread seems to have ended unexpectedly 
why?
i've already this error, anyone who known this error mean?
This is a generic Domoticz alert. Can you post your settings in order to see if there is something wrong? Have you set "Data Timeout" to "Disabled"?

User avatar
ycahome
Posts: 217
Joined: Sunday 12 February 2017 11:55
Target OS: Linux
Domoticz version: lat Beta
Contact:

Re: Python Plugin: Python Plugin Manager

Post by ycahome » Friday 09 November 2018 11:21

Version 1.5.13 is out


v.1.5.13
---------
Added: "eQ-3 MAX!" plugin (Thanks to @mvzut)
Added: "SmogTok Air Quality monitor" plugin (Thanks to @smogtok)

dextm80
Posts: 139
Joined: Tuesday 24 October 2017 18:32
Target OS: Linux
Domoticz version: 4.10159
Contact:

Re: Python Plugin: Python Plugin Manager

Post by dextm80 » Sunday 11 November 2018 19:45

ycahome wrote:
Thursday 08 November 2018 10:10
dextm80 wrote:
Thursday 08 November 2018 9:10
dextm80 wrote:
Saturday 03 November 2018 17:45

Code: Select all

2018-11-03 16:45:10.005 Error: Python Plugin Manager hardware (13) thread seems to have ended unexpectedly 
why?
i've already this error, anyone who known this error mean?
This is a generic Domoticz alert. Can you post your settings in order to see if there is something wrong? Have you set "Data Timeout" to "Disabled"?
yes, data timeout is disabled, other settings are default. i've upgrade 1.5.13 but the error stay here yet
Domoticz on AsRock j3455-ITX 8gb ram - Aeotec ZWave Usb Stick - RFLink 433Mhz
1x Fibaro Wall Plug
1x Fibaro Motion Sensor
x NeoCoolcam Wall Plug
Netatmo Weather Station - Netatmo Thermostat
Philips Hue Bridge

User avatar
ycahome
Posts: 217
Joined: Sunday 12 February 2017 11:55
Target OS: Linux
Domoticz version: lat Beta
Contact:

Re: Python Plugin: Python Plugin Manager

Post by ycahome » Sunday 11 November 2018 20:06

PP-Manager is Hardware Idx 13?

nono212
Posts: 31
Joined: Sunday 18 December 2016 14:47
Target OS: Linux
Domoticz version: 3.6179
Contact:

Re: Python Plugin: Python Plugin Manager

Post by nono212 » Monday 12 November 2018 18:00

this is not working with Synology
I tryed to install eq-3 max
I had some errors
I can be a beta tester for Synology if needed

To make it work I had to launch the command my self ... but in sudo mode
Attachments
max.jpg
max.jpg (62.09 KiB) Viewed 491 times
Last edited by nono212 on Monday 12 November 2018 18:50, edited 1 time in total.

mvzut
Posts: 452
Joined: Thursday 12 November 2015 11:55
Target OS: Raspberry Pi
Domoticz version: Beta
Location: The Netherlands
Contact:

Re: Python Plugin: Python Plugin Manager

Post by mvzut » Monday 12 November 2018 19:14

nono212 wrote:
Monday 12 November 2018 18:00
this is not working with Synology
I tryed to install eq-3 max
I had some errors
I can be a beta tester for Synology if needed

To make it work I had to launch the command my self ... but in sudo mode
Others have successfully installed the plugin (directly) on Synology. So I assume your errors have to do with the Plugin Manager. If there is anything I can do (as eQ-3 Max! plugin author) please let me know.
Raspberry Pi 3 - RFXtrx433 - Aeon Z-Stick gen5 - Opentherm Gateway - P1 smart meter - Netatmo - Philips Hue - ELV Max! - ESP8266 DIY water meter - Xiaomi Gateway - Sonos - IP cameras - Wall mounted tablet + Imperihome - Alexa - MANY switches/sensors

User avatar
ycahome
Posts: 217
Joined: Sunday 12 February 2017 11:55
Target OS: Linux
Domoticz version: lat Beta
Contact:

Re: Python Plugin: Python Plugin Manager

Post by ycahome » Tuesday 13 November 2018 12:41

ok,

maybe we found something here.
So, the question is:
"is there anyone that had -even a single- plugin installed on Synology Based Domoticz via PP-Manager (or without sudo?)?"

nono212
Posts: 31
Joined: Sunday 18 December 2016 14:47
Target OS: Linux
Domoticz version: 3.6179
Contact:

Re: Python Plugin: Python Plugin Manager

Post by nono212 » Tuesday 13 November 2018 16:53

Sorry the name is not correct in the image ...
the name MaxCube is not correct it should be pp_manager

dextm80
Posts: 139
Joined: Tuesday 24 October 2017 18:32
Target OS: Linux
Domoticz version: 4.10159
Contact:

Re: Python Plugin: Python Plugin Manager

Post by dextm80 » Wednesday 14 November 2018 23:44

ycahome wrote:
Sunday 11 November 2018 20:06
PP-Manager is Hardware Idx 13?
yes
Domoticz on AsRock j3455-ITX 8gb ram - Aeotec ZWave Usb Stick - RFLink 433Mhz
1x Fibaro Wall Plug
1x Fibaro Motion Sensor
x NeoCoolcam Wall Plug
Netatmo Weather Station - Netatmo Thermostat
Philips Hue Bridge

RickU09
Posts: 2
Joined: Monday 10 December 2018 20:22
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Python Plugin: Python Plugin Manager

Post by RickU09 » Monday 10 December 2018 20:26

How can I uninstall PP-Manager?

I'm new to Domoticz/RPi

I tried
-Cd domoticz/plugins
-pip uninstall PP-MANAGER

No result, Domoticz stopped working after installing this plugin manager.


Cannot switch to python 3.4 (Which should solve the problem??)
pi@raspberrypi:~ $ sudo apt-get install python3.4
Reading package lists... Error!
E: Splitting of file /var/lib/apt/lists/raspbian.raspberrypi.org_raspbian_dists_stretch_InRelease failed as it doesn't contain all expected parts 0 1 0
E: The package lists or status file could not be parsed or opened.

Also tried
pi@raspberrypi:~ $ sudo apt-get update
Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
Err:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Splitting up /var/lib/apt/lists/raspbian.raspberrypi.org_raspbian_dists_stretch_InRelease into data and signature faile d
Err:2 http://archive.raspberrypi.org/debian stretch InRelease
Splitting up /var/lib/apt/lists/archive.raspberrypi.org_debian_dists_stretch_InRelease into data and signature failed
Reading package lists... Error!
W: An error occurred during the signature verification. The repository is not updated and the previous index files will b e used. GPG error: http://raspbian.raspberrypi.org/raspbian stretch InRelease: Splitting up /var/lib/apt/lists/raspbian.r aspberrypi.org_raspbian_dists_stretch_InRelease into data and signature failed
W: An error occurred during the signature verification. The repository is not updated and the previous index files will b e used. GPG error: http://archive.raspberrypi.org/debian stretch InRelease: Splitting up /var/lib/apt/lists/archive.raspb errypi.org_debian_dists_stretch_InRelease into data and signature failed
W: Failed to fetch http://raspbian.raspberrypi.org/raspbia ... /InRelease Splitting up /var/lib/apt/lists/rasp bian.raspberrypi.org_raspbian_dists_stretch_InRelease into data and signature failed
W: Failed to fetch http://archive.raspberrypi.org/debian/d ... /InRelease Splitting up /var/lib/apt/lists/archive .raspberrypi.org_debian_dists_stretch_InRelease into data and signature failed
W: Some index files failed to download. They have been ignored, or old ones used instead.
E: Splitting of file /var/lib/apt/lists/raspbian.raspberrypi.org_raspbian_dists_stretch_InRelease failed as it doesn't co ntain all expected parts 0 1 0
E: The package lists or status file could not be parsed or opened.

Then did this:

pi@raspberrypi:~ $ sudo apt-get clean
pi@raspberrypi:~ $ sudo rm-vf /var/lib/apt/lists/*
sudo: rm-vf: command not found
pi@raspberrypi:~ $ sudo rm -vf /var/lib/apt/lists/*
removed '/var/lib/apt/lists/archive.raspberrypi.org_debian_dists_stretch_InRelease'
removed '/var/lib/apt/lists/archive.raspberrypi.org_debian_dists_stretch_main_binary-armhf_Packages'
removed '/var/lib/apt/lists/archive.raspberrypi.org_debian_dists_stretch_ui_binary-armhf_Packages'
removed '/var/lib/apt/lists/lock'
rm: cannot remove '/var/lib/apt/lists/partial': Is a directory
removed '/var/lib/apt/lists/raspbian.raspberrypi.org_raspbian_dists_stretch_contrib_binary-armhf_Packages'
removed '/var/lib/apt/lists/raspbian.raspberrypi.org_raspbian_dists_stretch_InRelease'
removed '/var/lib/apt/lists/raspbian.raspberrypi.org_raspbian_dists_stretch_main_binary-armhf_Packages'
removed '/var/lib/apt/lists/raspbian.raspberrypi.org_raspbian_dists_stretch_non-free_binary-armhf_Packages'
removed '/var/lib/apt/lists/raspbian.raspberrypi.org_raspbian_dists_stretch_rpi_binary-armhf_Packages'
pi@raspberrypi:~ $ sudo rm -vf /var/lib/apt/lists/partial/*
pi@raspberrypi:~ $ sudo apt-get update
Get:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15.0 kB]
Get:2 http://archive.raspberrypi.org/debian stretch InRelease [25.3 kB]
Get:3 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages [11.7 MB]
Get:4 http://archive.raspberrypi.org/debian stretch/main armhf Packages [200 kB]
Get:5 http://archive.raspberrypi.org/debian stretch/ui armhf Packages [40.3 kB]
Get:6 http://raspbian.raspberrypi.org/raspbian stretch/contrib armhf Packages [56.9 kB]
Get:7 http://raspbian.raspberrypi.org/raspbian stretch/non-free armhf Packages [95.5 kB]
Get:8 http://raspbian.raspberrypi.org/raspbian stretch/rpi armhf Packages [1,360 B]
Fetched 12.1 MB in 36s (329 kB/s)
Reading package lists... Done
pi@raspberrypi:~ $ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
base-files geany geany-common gtk2-engines-clearlookspix libbasicusageenvironment1 libgroupsock8 libgs9 libgs9-common liblivemedia57 libobrender32v5 libobt2v5 libperl5.24
libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libsmbclient libssl1.1 libtiff5 libusageenvironment3 libwbclient0 openbox openssl perl perl-base
perl-modules-5.24 pi-greeter pipanel policykit-1 python-rpi.gpio python3-rpi.gpio raspberrypi-sys-mods raspberrypi-ui-mods raspi-config rp-prefapps rpi-chromium-mods
samba-common samba-libs zenity zenity-common
39 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 39.8 MB of archives.
After this operation, 155 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.raspberrypi.org/debian stretch/ui armhf rpi-chromium-mods armhf 20181204 [9,174 kB]
Get:2 http://mirror.serverius.net/raspbian/raspbian stretch/main armhf base-files armhf 9.9+rpi1+deb9u6 [67.5 kB]
Get:3 http://mirror.proserve.nl/raspbian/raspbian stretch/main armhf libperl5.24 armhf 5.24.1-3+deb9u5 [2,837 kB]
Get:4 http://mirror.serverius.net/raspbian/raspbian stretch/main armhf perl armhf 5.24.1-3+deb9u5 [219 kB]
Get:6 http://mirror.transip.net/raspbian/raspbian stretch/main armhf perl-modules-5.24 all 5.24.1-3+deb9u5 [2,722 kB]
Get:8 http://mirror.serverius.net/raspbian/raspbian stretch/main armhf libsmbclient armhf 2:4.5.12+dfsg-2+deb9u4 [144 kB]
Get:5 http://mirror.proserve.nl/raspbian/raspbian stretch/main armhf perl-base armhf 5.24.1-3+deb9u5 [1,198 kB]
Get:9 http://mirror.serverius.net/raspbian/raspbian stretch/main armhf samba-libs armhf 2:4.5.12+dfsg-2+deb9u4 [4,379 kB]
Get:7 http://mirror.proserve.nl/raspbian/raspbian stretch/main armhf libwbclient0 armhf 2:4.5.12+dfsg-2+deb9u4 [121 kB]
Get:11 http://mirror.proserve.nl/raspbian/raspbian stretch/main armhf libssl1.1 armhf 1.1.0j-1~deb9u1 [1,115 kB]
Get:10 http://mirror.serverius.net/raspbian/raspbian stretch/main armhf samba-common all 2:4.5.12+dfsg-2+deb9u4 [172 kB]
Get:12 http://mirror.serverius.net/raspbian/raspbian stretch/main armhf libbasicusageenvironment1 armhf 2016.11.28-1+deb9u1 [19.7 kB]
Get:14 http://mirror.serverius.net/raspbian/raspbian stretch/main armhf libtiff5 armhf 4.0.8-2+deb9u4 [220 kB]
Get:13 http://mirror.transip.net/raspbian/raspbian stretch/main armhf libgroupsock8 armhf 2016.11.28-1+deb9u1 [24.8 kB]
Get:15 http://mirror.nl.leaseweb.net/raspbian/raspbian stretch/main armhf libgs9 armhf 9.26~dfsg-0+deb9u1 [1,863 kB]
Get:16 http://mirror.transip.net/raspbian/raspbian stretch/main armhf libgs9-common all 9.26~dfsg-0+deb9u1 [5,140 kB]
Get:17 http://mirror.nl.leaseweb.net/raspbian/raspbian stretch/main armhf liblivemedia57 armhf 2016.11.28-1+deb9u1 [265 kB]
Get:20 http://mirror.serverius.net/raspbian/raspbian stretch/main armhf libpolkit-backend-1-0 armhf 0.105-18+deb9u1 [39.8 kB]
Get:21 http://mirror.serverius.net/raspbian/raspbian stretch/main armhf libpolkit-gobject-1-0 armhf 0.105-18+deb9u1 [37.8 kB]
Get:22 http://mirror.serverius.net/raspbian/raspbian stretch/main armhf libusageenvironment3 armhf 2016.11.28-1+deb9u1 [12.2 kB]
Get:23 http://mirror.serverius.net/raspbian/raspbian stretch/main armhf openssl armhf 1.1.0j-1~deb9u1 [712 kB]
Get:24 http://archive.raspberrypi.org/debian stretch/ui armhf geany armhf 1.29-1+rpt2 [1,224 kB]
Get:18 http://mirror.transip.net/raspbian/raspbian stretch/main armhf policykit-1 armhf 0.105-18+deb9u1 [61.7 kB]
Get:19 http://mirror.transip.net/raspbian/raspbian stretch/main armhf libpolkit-agent-1-0 armhf 0.105-18+deb9u1 [22.3 kB]
Get:25 http://archive.raspberrypi.org/debian stretch/ui armhf geany-common all 1.29-1+rpt2 [2,461 kB]
Get:26 http://archive.raspberrypi.org/debian stretch/ui armhf gtk2-engines-clearlookspix armhf 1:2.20.7 [66.0 kB]
Get:27 http://archive.raspberrypi.org/debian stretch/ui armhf libobt2v5 armhf 3.6.1-4+rpi8 [62.3 kB]
Get:28 http://archive.raspberrypi.org/debian stretch/ui armhf libobrender32v5 armhf 3.6.1-4+rpi8 [69.7 kB]
Get:29 http://archive.raspberrypi.org/debian stretch/ui armhf openbox armhf 3.6.1-4+rpi8 [281 kB]
Get:30 http://archive.raspberrypi.org/debian stretch/ui armhf pi-greeter armhf 0.9 [40.8 kB]
Get:31 http://archive.raspberrypi.org/debian stretch/ui armhf zenity-common all 3.28.1-1.1~bpo9+rpt1 [4,126 kB]
Get:32 http://archive.raspberrypi.org/debian stretch/ui armhf zenity armhf 3.28.1-1.1~bpo9+rpt1 [268 kB]
Get:33 http://archive.raspberrypi.org/debian stretch/ui armhf pipanel armhf 20181126~094616 [19.2 kB]
Get:34 http://archive.raspberrypi.org/debian stretch/main armhf python-rpi.gpio armhf 0.6.5~stretch-1 [23.5 kB]
Get:35 http://archive.raspberrypi.org/debian stretch/main armhf python3-rpi.gpio armhf 0.6.5~stretch-1 [23.6 kB]
Get:36 http://archive.raspberrypi.org/debian stretch/main armhf raspberrypi-sys-mods armhf 20181127 [10.2 kB]
Get:37 http://archive.raspberrypi.org/debian stretch/ui armhf rp-prefapps armhf 0.5 [175 kB]
Get:38 http://archive.raspberrypi.org/debian stretch/ui armhf raspberrypi-ui-mods all 1.20181206 [318 kB]
Get:39 http://archive.raspberrypi.org/debian stretch/ui armhf raspi-config all 20181118 [20.2 kB]
Fetched 39.8 MB in 12s (3,302 kB/s)
Reading changelogs... Done
Extracting templates from packages: 100%
Preconfiguring packages ...
dpkg: unrecoverable fatal error, aborting:
files list file for package 'openvpn' is missing final newline
E: Sub-process /usr/bin/dpkg returned an error code (2)

And then:...
pi@raspberrypi:~ $ sudo apt-get install python3.4
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
libpython3.4-minimal libpython3.4-stdlib python3.4-minimal
Suggested packages:
python3.4-venv python3.4-doc binfmt-support
The following NEW packages will be installed:
libpython3.4-minimal libpython3.4-stdlib python3.4 python3.4-minimal
0 upgraded, 4 newly installed, 0 to remove and 39 not upgraded.
Need to get 0 B/4,049 kB of archives.
After this operation, 20.7 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Selecting previously unselected package libpython3.4-minimal:armhf.
dpkg: unrecoverable fatal error, aborting:
files list file for package 'openvpn' is missing final newline
E: Sub-process /usr/bin/dpkg returned an error code (2)
pi@raspberrypi:~ $ compgen -c python
python3.5-config
python3.5m
python2.7
python3.5
python3-config
python
python3
python2.7-config
python2-config
python3.5m-config
python3m
python3m-config
python-config
python2
pi@raspberrypi:~ $

Still no Python3.4????
Not getting it to work properly...

User avatar
ycahome
Posts: 217
Joined: Sunday 12 February 2017 11:55
Target OS: Linux
Domoticz version: lat Beta
Contact:

Re: Python Plugin: Python Plugin Manager

Post by ycahome » Monday 10 December 2018 21:31

RickU09 wrote:
Monday 10 December 2018 20:26
How can I uninstall PP-Manager?

I'm new to Domoticz/RPi

I tried
-Cd domoticz/plugins
-pip uninstall PP-MANAGER
Just like any other plugin. Delete plugin folder(PP-Manager).

RickU09
Posts: 2
Joined: Monday 10 December 2018 20:22
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Python Plugin: Python Plugin Manager

Post by RickU09 » Wednesday 12 December 2018 20:51

I've tried again with a new fresh install.

I've managed to install 3.4 and remove 3.5.
After installing Python Plugin Manager again I cannot find it in domoticz. Like there is not running any version of python anymore?
Also my Sony Bravia plugin is not working anymore.

My last tries:
pi@raspberrypi:~ $ sudo update-alternatives --install /usr/bin/python python /usr/bin/python3.4 4
update-alternatives: using /usr/bin/python3.4 to provide /usr/bin/python (python) in auto mode
pi@raspberrypi:~ $ sudo update-alternatives --config python
There is only one alternative in link group python (providing /usr/bin/python): /usr/bin/python3.4
Nothing to configure.

User avatar
ycahome
Posts: 217
Joined: Sunday 12 February 2017 11:55
Target OS: Linux
Domoticz version: lat Beta
Contact:

Re: Python Plugin: Python Plugin Manager

Post by ycahome » Wednesday 12 December 2018 21:30

check for the prerequisites of python framework.
You need the also relative python3-dev

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests