error while loading shared libraries: libudev.so.1:

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
marcel_dj
Posts: 9
Joined: Friday 03 October 2014 8:49
Target OS: Raspberry Pi
Domoticz version:
Contact:

error while loading shared libraries: libudev.so.1:

Post by marcel_dj » Wednesday 30 August 2017 9:32

I have the following error after installing the latest beta:

[....] Restarting Domoticz Home Automation System: domoticz/home/pi/domoticz/domoticz: error while loading shared libraries: libudev.so.1: cannot open shared object file: No such file or directory

I can see that in 2016 the same issue occured but the sollutions then mentioned did not help.

Version : latest Beta
Platform : Raspberry / Jessy
Plugin/Hardware : RFXCOM and MySensors

jackisidore
Posts: 144
Joined: Friday 12 July 2013 15:52
Target OS: Raspberry Pi
Domoticz version:
Location: NL
Contact:

Re: error while loading shared libraries: libudev.so.1:

Post by jackisidore » Wednesday 30 August 2017 10:52

I have the same issue after upgrading yesterday

jackisidore
Posts: 144
Joined: Friday 12 July 2013 15:52
Target OS: Raspberry Pi
Domoticz version:
Location: NL
Contact:

Re: error while loading shared libraries: libudev.so.1:

Post by jackisidore » Wednesday 30 August 2017 11:11

./updaterelease worked for me. I'll wait with a new beta until this is solved.

Oxyd
Posts: 33
Joined: Sunday 29 September 2013 7:36
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: error while loading shared libraries: libudev.so.1:

Post by Oxyd » Wednesday 30 August 2017 11:33

Same problem for me.
Backswitch to release and working again :roll:

marcel_dj
Posts: 9
Joined: Friday 03 October 2014 8:49
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: error while loading shared libraries: libudev.so.1:

Post by marcel_dj » Wednesday 30 August 2017 14:30

It works after ./updaterelease for now I'm up and running.

bickel
Posts: 20
Joined: Wednesday 14 January 2015 23:16
Target OS: Raspberry Pi
Domoticz version:
Location: Sirjansland, Netherlands
Contact:

error while loading shared libraries: libudev.so.1:

Post by bickel » Wednesday 30 August 2017 15:44

Today i upgraded to 8373 and got the same issue which brought me to this article.
Same workaround also works for me..thanks for that.

roblom
Posts: 562
Joined: Wednesday 26 February 2014 16:28
Target OS: Raspberry Pi
Domoticz version:
Location: the Netherlands
Contact:

Re: error while loading shared libraries: libudev.so.1:

Post by roblom » Thursday 31 August 2017 8:26

Same error here. Got 100+ mails from monit....

niki_lauda
Posts: 139
Joined: Saturday 31 August 2013 14:48
Target OS: Raspberry Pi
Domoticz version: beta
Location: Eindhoven (NL)
Contact:

Re: error while loading shared libraries: libudev.so.1:

Post by niki_lauda » Thursday 31 August 2017 16:43

+1
....] Restarting Domoticz Home Automation System: domoticz/home/pi/domoticz/domoticz:
error while loading shared libraries: libudev.so.1:
cannot open shared object file: No such file or directory

Version : latest Beta
Platform : Raspberry / Wheezy
Plugin/Hardware : RFXCOM

updaterelease worked
Last edited by niki_lauda on Friday 01 September 2017 11:48, edited 1 time in total.

danjardmathieu
Posts: 22
Joined: Friday 09 October 2015 18:49
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: error while loading shared libraries: libudev.so.1:

Post by danjardmathieu » Thursday 31 August 2017 18:53

+1
Same issue
Hope the new beta will fix the problem soon ... :-| :roll:

kurniawan77
Posts: 79
Joined: Wednesday 21 January 2015 21:23
Target OS: Raspberry Pi
Domoticz version:
Location: Netherlands
Contact:

Re: error while loading shared libraries: libudev.so.1:

Post by kurniawan77 » Friday 01 September 2017 10:33

The same here....

Code: Select all

pi@raspberrypi ~ $ sudo service domoticz.sh status
[FAIL] domoticz is not running ... failed!
pi@raspberrypi ~ $ sudo service domoticz.sh start
/home/pi/domoticz/domoticz: error while loading shared libraries: libudev.so.1:                                             cannot open shared object file: No such file or directory
pi@raspberrypi ~ $ ^C
pi@raspberrypi ~ $ sudo find / -name "libudev.so*"
/lib/arm-linux-gnueabihf/libudev.so.0
/lib/arm-linux-gnueabihf/libudev.so.0.13.0
pi@raspberrypi ~ $  sudo find / -name "libudev.so.1"
pi@raspberrypi ~ $
When searching for libudev.so.1, it doesn't seem to exist.

kurniawan77
Posts: 79
Joined: Wednesday 21 January 2015 21:23
Target OS: Raspberry Pi
Domoticz version:
Location: Netherlands
Contact:

Re: error while loading shared libraries: libudev.so.1:

Post by kurniawan77 » Friday 01 September 2017 14:54

gordonb3 wrote:Are you sure you are running Jessie?

This libudev version seems rather old - like Wheezy old. I think Jessie should have libudev1 package installed which will provide the correct library.
Yes, running wheezy indeed. Do you have any advice? Running on a pi2 b+. Installed Domoticz 2 or 3 years ago from an SD image provided on the Domoticz website. Once in a while I do update and upgrade and have always updated Domoticz.


Sent from my Nexus 6P using Tapatalk


danjardmathieu
Posts: 22
Joined: Friday 09 October 2015 18:49
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: error while loading shared libraries: libudev.so.1:

Post by danjardmathieu » Friday 01 September 2017 14:56

I was under Wheezzy wih the issue then i update/upgrade to jessie, no more problem now.
Solution, upgrade to jessie :D

kurniawan77
Posts: 79
Joined: Wednesday 21 January 2015 21:23
Target OS: Raspberry Pi
Domoticz version:
Location: Netherlands
Contact:

Re: error while loading shared libraries: libudev.so.1:

Post by kurniawan77 » Friday 01 September 2017 16:11

gordonb3 wrote:Yes, or as this appears to be bound to zwave support: build from source without it (provided you do not need zwave support)
I need zwave. So I have to upgrade to Jessy seems to be the solution. Any tips on that?

Sent from my Nexus 6P using Tapatalk



niki_lauda
Posts: 139
Joined: Saturday 31 August 2013 14:48
Target OS: Raspberry Pi
Domoticz version: beta
Location: Eindhoven (NL)
Contact:

Re: error while loading shared libraries: libudev.so.1:

Post by niki_lauda » Friday 01 September 2017 18:38

danjardmathieu wrote:
Friday 01 September 2017 14:56
I was under Wheezzy wih the issue then i update/upgrade to jessie, no more problem now.
Solution, upgrade to jessie :D
Which steps to upgrade Wheezy-> Jessie? Have you a link that worked for your Domoticz sD?

kurniawan77
Posts: 79
Joined: Wednesday 21 January 2015 21:23
Target OS: Raspberry Pi
Domoticz version:
Location: Netherlands
Contact:

Re: error while loading shared libraries: libudev.so.1:

Post by kurniawan77 » Friday 01 September 2017 19:27

gordonb3 wrote:May still try. Of course in that case you will need to get the openzwave library as well. Can't tell if there are any version dependencies though, but otherwise it should compile okay with the older libraries ( run cmake with `-DUSE_STATIC_OPENZWAVE=NO` )
Hmmmm, I'm not so familiar with that. Could you guide me? Or someone else?

Sent from my Nexus 6P using Tapatalk


User avatar
jvdz
Posts: 1418
Joined: Tuesday 30 December 2014 20:25
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Westland/Netherlands
Contact:

Re: error while loading shared libraries: libudev.so.1:

Post by jvdz » Friday 01 September 2017 19:54

kurniawan77 wrote:
Friday 01 September 2017 19:27
Hmmmm, I'm not so familiar with that. Could you guide me? Or someone else?
I have followed this upgrade process on both an RPI2 and RPI3 with an original Domoticz SD image after making n full image of the SDCARD before the upgrade process: https://raspberrypi.stackexchange.com/q ... ssie#27859
Both are working fine for a couple of months.

Jos

roblom
Posts: 562
Joined: Wednesday 26 February 2014 16:28
Target OS: Raspberry Pi
Domoticz version:
Location: the Netherlands
Contact:

Re: error while loading shared libraries: libudev.so.1:

Post by roblom » Saturday 02 September 2017 13:03

Can someone of the dev team confirm that the latest beta will not be running on wheezy anymore. And if so, is this temporary or is it mandatory to update to Jessie?

User avatar
Derik
Posts: 2167
Joined: Friday 18 October 2013 23:33
Target OS: Raspberry Pi
Domoticz version: BETA
Location: Arnhem/Nijmegen Nederland
Contact:

Re: error while loading shared libraries: libudev.so.1:

Post by Derik » Sunday 03 September 2017 9:47

do have the same error to....
grrrr

Only go back to a release version from a Beta, can corrupt you DB...

So i hope there is a solution ....

Anyone?
Xu4: Beta Extreme antenna RFXcomE,WU Fi Ping ip P1 Gen5 PVOutput Harmony HUE SolarmanPv OTG Winddelen Alive ESP Buienradar MySensors WOL Winddelen counting RPi: Beta SMAspot RFlinkTest Domoticz ...Different backups

User avatar
a3vd
Posts: 67
Joined: Tuesday 25 February 2014 15:02
Target OS: Raspberry Pi
Domoticz version: beta
Location: Noordwijk, The Netherlands
Contact:

Re: error while loading shared libraries: libudev.so.1:

Post by a3vd » Sunday 03 September 2017 20:11

Same problem here on my pi's with domoticz latest beta crashed all systems.
Raspberry B / Raspberry B+ / Raspberry 2 / Raspberry 3 / Raspberry 3+
P1 smartcable / RFXtrx433 FW 182 / Several 1 wire Temp Sensors /DHT12
Several Kaku switches/ Weather Underground / Razberry / 2 Everspring 142 dimmers

User avatar
cyberclwn
Posts: 124
Joined: Thursday 20 August 2015 22:53
Target OS: Raspberry Pi
Domoticz version: beta
Location: The Netherlands
Contact:

Re: error while loading shared libraries: libudev.so.1:

Post by cyberclwn » Monday 04 September 2017 18:02

Hi,

I had the same error after updating the beta to the latest.

But didn't want to go back to the stable so this is how i fixed it:

Code: Select all

cd /lib/arm-linux-gnueabihf/
sudo cp libudev.so.0 libudev.so.1
btw: USE AT OWN RISK!!
And remember to remove the file after it is fixed in the beta.
This is only a temporary fix, and i am not sure if there are other problems this may introduce.
3xPi 2B (Domoticz "live", Domoticz "sandbox", PhotoFrame)
RFXCom433(E), KaKu, Oregon Scientific, Keyes 2-relay, Logitech Media Server, MiLight, Smartwares heating controller(2x), IR Send/Receive, Keyes PIR, XH-M131 DuskSensor, DHT22/11

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 5 guests