EventSystem - Python: Failed dynamic library load, install the latest libpython3.x library that is available

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
User avatar
Conn-artist
Posts: 80
Joined: Saturday 12 July 2014 12:06
Target OS: Raspberry Pi
Domoticz version: 3.8367
Location: 127.0.0.1
Contact:

Re: EventSystem - Python: Failed dynamic library load, install the latest libpython3.x library that is available

Post by Conn-artist » Saturday 02 September 2017 8:30

Nickkkk72 wrote:
Thursday 31 August 2017 10:13
[...]
I love the situation one month ago, where everything was stable for me.
If you have any advice... Thanks a lot in advance
My advice is:
- make a copy of domoticz.db and any customizations you may have made (like scripts for example)
- install the latest version of Domoticz that worked for you
- copy the domoticz.db backup that you made back to that working version

You may not have all the latest (beta) features but at least you'll have well running system.
--
Martijn

qwerk
Posts: 293
Joined: Tuesday 22 July 2014 7:21
Target OS: Raspberry Pi
Domoticz version: beta
Location: Netherlands
Contact:

Re: EventSystem - Python: Failed dynamic library load, install the latest libpython3.x library that is available

Post by qwerk » Monday 04 September 2017 20:20

funny, just went back to version 8315 and my mail works again. On my raspberry 3, running jessie
all my python issues are gone. no errors in log, and the plugins are back.

domoticz 8315 ( precompiled) is only 10316 K large and after that it grew to 13518K in version 8369 and 13379K in version 8373.

SweetPants
Posts: 2350
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.10196
Location: The Netherlands
Contact:

Re: EventSystem - Python: Failed dynamic library load, install the latest libpython3.x library that is available

Post by SweetPants » Tuesday 05 September 2017 11:33

Hi, I'm on Linux Ubuntu 16.04 LTS and compile from source and get the same message when starting V3.8380 on my test machine after enabling Python support. However, my system has:
libpython3.5 is already the newest version (3.5.2-2ubuntu0~16.04.1).
libpython3.5-dbg is already the newest version (3.5.2-2ubuntu0~16.04.1).
libpython3.5-dev is already the newest version (3.5.2-2ubuntu0~16.04.1).
libpython3.5-minimal is already the newest version (3.5.2-2ubuntu0~16.04.1).
libpython3.5-stdlib is already the newest version (3.5.2-2ubuntu0~16.04.1).
libpython3.5-testsuite is already the newest version (3.5.2-2ubuntu0~16.04.1).
any thoughts why this fails?

Edit: it looks like it is searching for PythonLibs 3.4 only
Ubuntu 16.04.5 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

nickous
Posts: 9
Joined: Wednesday 28 January 2015 17:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: EventSystem - Python: Failed dynamic library load, install the latest libpython3.x library that is available

Post by nickous » Sunday 19 November 2017 12:48

juste to say that on a fresh stretch raspbian install (easy way method) with .updatebeta
still have to add install python3-dev
that's all folk 8-)

dio45rus
Posts: 5
Joined: Thursday 24 May 2018 15:53
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: EventSystem - Python: Failed dynamic library load, install the latest libpython3.x library that is available

Post by dio45rus » Thursday 24 May 2018 15:56

Solved: install libpython3.4-dev that was not been installed. Error message disappear, plug-in system started.

sineverba
Posts: 26
Joined: Saturday 22 July 2017 17:25
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: EventSystem - Python: Failed dynamic library load, install the latest libpython3.x library that is available

Post by sineverba » Tuesday 10 July 2018 7:12

dio45rus wrote:
Thursday 24 May 2018 15:56
Solved: install libpython3.4-dev that was not been installed. Error message disappear, plug-in system started.
I can confirm on beta 4.9732 that this solved issue. You know, but exact command is

Code: Select all

sudo apt-get install libpython3.4-dev

seansco
Posts: 19
Joined: Tuesday 01 March 2016 21:51
Target OS: Linux
Domoticz version:
Contact:

Re: EventSystem - Python: Failed dynamic library load, install the latest libpython3.x library that is available

Post by seansco » Friday 20 July 2018 22:10

I am running on ubuntu 18.04 lts and this fixed it for me:

Code: Select all

sudo apt install libpython3.6-dev 

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests