Plugin - Homewizard

Python and python framework
smaus
Posts: 3
Joined: Sunday 18 February 2018 10:32
Target OS: NAS (Synology & others)
Domoticz version:
Contact:

Re: Plugin - Homewizard

Post by smaus » Wednesday 28 February 2018 21:18

:D top its working :lol:

Thanks

MrPenthouse
Posts: 2
Joined: Tuesday 06 March 2018 22:48
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Plugin - Homewizard

Post by MrPenthouse » Tuesday 06 March 2018 22:51

Wow, this did not even cost me more than a minute and it worked straight away! Excellent job and now my HomeWizard has an extended live, much thanks!

webmagic
Posts: 2
Joined: Monday 19 February 2018 21:47
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Plugin - Homewizard

Post by webmagic » Sunday 11 March 2018 15:09

I like this plug-in very much! Will there be support for the Smartware XQ-lite Led lamps which are using 868 mhz. I would like to set the lamp dim setting via Domoticz.

WWortel
Posts: 1
Joined: Sunday 06 May 2018 15:25
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Plugin - Homewizard

Post by WWortel » Sunday 06 May 2018 15:42

Hi,
This plugin looks very promising!!! I hope you can help me getting the plugin up-and-running.

Version: Linux raspberrypi 4.14.34-v7+ #1110 SMP Mon Apr 16 15:18:51 BST 2018 armv7l GNU/Linux
Beta Domoticz Version: 3.9389-
dzVents Version: 2.4.5
Python Version: 3.5.3
Platform: Raspberry 3B+

I’ve installed the plugin and did a setup of the hardware Homewizard. I get this message: ‘Homewizard created, devices can be found …’ :D
When I go to devices, I get this message: ‘Problem retrieving devices!’ :?
When I go back to hardware, the homewizard I just created is not shown anymore and Homewizard can’t be selected anymore for a new setup of hardware.
To be able to start it correctly again I did: mv plugin.py plugin.py.old Now I can start and remove the created hardware of homewizard in domotics. Next I do a Restart and I’m back to where I started.

Note when I start it via ./domotics, then I see this message:
2018-05-06 14:52:09.993 Error: WebServer(SSL) startup failed on address 0.0.0.0 with port: 443: bind: Permission denied
2018-05-06 14:52:09.993 Error: WebServer(SSL) check privileges for opening ports below 1024
(I don’t see this message in logs when starting via sudo service domoticz.sh start)
I also tried running the stable version (3.8153). However then I’m not able to setup the Homewizard hardware.

I hope somebody has a clue what is going wrong.

Regards,
WWortel

TheCub3
Posts: 23
Joined: Saturday 24 February 2018 19:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Plugin - Homewizard

Post by TheCub3 » Saturday 09 June 2018 18:30

hi,

i did the steps:
cd domoticz/plugins
git clone https://github.com/rvdvoorde/domoticz-homewizard.git
sudo systemctl restart domoticz
and i see in my raspbian,
raspbian.jpg
raspbian.jpg (13.63 KiB) Viewed 90 times
but i dont see in in Hardware antthing of homewizard ?,i already try a reset in domoticz

i use the beta version that is needed but i see in the log
2018-06-11 19:33:36.208 Status: Domoticz V3.9625 (c)2012-2018 GizMoCuz
2018-06-11 19:33:36.209 Status: Build Hash: 529bd73d, Date: 2018-06-11 06:30:28
2018-06-11 19:33:36.209 Status: Startup Path: /home/pi/domoticz/
2018-06-11 19:33:36.390 Status: EventSystem: reset all events...
2018-06-11 19:33:36.391 Status: PluginSystem: Failed dynamic library load, install the latest libpython3.x library that is available for your platform.
i think that is the problem but how can i make sure that the library is running correct ?
what am I doing wrong ?

update,
solved the problem, if you also got the same error like above go to Putty and install manual Python with the commando sudo apt-get install python3-pip




tnx,

A,

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests