Domoticz does not open port 8080

On various Hardware and OS systems: pi / windows / routers / nas, etc
Post Reply
MasWetens
Posts: 3
Joined: Sunday 03 September 2017 20:10
Target OS: Raspberry Pi
Domoticz version:
Contact:

Domoticz does not open port 8080

Post by MasWetens » Sunday 03 September 2017 20:17

Dear Domoticz,

I installed Domoticz already several times using the following command:
"Sudo curl -L install.domoticz.com | (sudo) bash"

When I check the installation using:
"wget localhost"
Isn't the port 8080 showing up, but I set in de setting that popped up when I installed it at port 8080.
What can I do to solve this problem????

pvm
Posts: 858
Joined: Tuesday 17 June 2014 22:14
Target OS: NAS (Synology & others)
Domoticz version: Stable
Location: NL
Contact:

Re: Domoticz does not open port 8080

Post by pvm » Sunday 03 September 2017 21:48

Code: Select all

wget localhost:8080
does not result in an index.html file?
Synology NAS, PI3, ZWave, Xiamo zigbee devices, BTLE plant sensor

MasWetens
Posts: 3
Joined: Sunday 03 September 2017 20:10
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Domoticz does not open port 8080

Post by MasWetens » Monday 04 September 2017 16:56

When I do

Code: Select all

wget localhost:8080
Get I a return as follows:

Code: Select all

--2017-09-04 16:55:52--  http://localhost:8080/
Resolving localhost (localhost)... ::1, 127.0.0.1
Connecting to localhost (localhost)|::1|:8080... failed: Connection refused.
Connecting to localhost (localhost)|127.0.0.1|:8080... failed: Connection refused.
Thank you for your reaction pvm.

Elvana
Posts: 1
Joined: Tuesday 12 September 2017 11:12
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Domoticz does not open port 8080

Post by Elvana » Tuesday 12 September 2017 13:47

Hi, I had the same issue.
As a NOOB it took me some time to work this out... which is why I am sharing the following in boring detail.
On a new 16 GB SDcard I had installed Raspbian Stretch from https://www.raspberrypi.org/downloads/raspbian/
Upon starting the partition size was automically adjusted.
After opening a terminal window I ran sudo raspi-config and changed password, timezone, ssh access and screen resolution and overscan (last three under interfacing options).
Then rebooted in the terminal window by issuing

Code: Select all

sudo reboot
I then installed Domoticz "The Easy Way" according to https://www.domoticz.com/wiki/Installin ... e_easy_way with

Code: Select all

sudo curl -L install.domoticz.com | sudo bash
This ran successfully but yielded Domoticz inaccessible (with and without https enabled - no difference).

Like the topic starter - after a reboot I could not access Domoticz on either port 8080 or 443:

Code: Select all

[email protected]:~ $ wget localhost:8080
--2017-09-12 11:10:09--  http://localhost:8080/
Resolving localhost (localhost)... ::1, 127.0.0.1
Connecting to localhost (localhost)|::1|:8080... failed: Connection refused.
Connecting to localhost (localhost)|127.0.0.1|:8080... failed: Connection refused.

I found this topic as well as this other one viewtopic.php?t=18020 and my error message read:

Code: Select all

sudo service domoticz.sh status
● domoticz.service - LSB: Home Automation System
   Loaded: loaded (/etc/init.d/domoticz.sh; generated; vendor preset: enabled)
   Active: active (exited) since Tue 2017-09-12 11:08:28 CEST; 6min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 1100 ExecStop=/etc/init.d/domoticz.sh stop (code=exited, status=0/SUCCESS)
  Process: 1110 ExecStart=/etc/init.d/domoticz.sh start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/domoticz.service

Sep 12 11:08:27 domoticzR1 systemd[1]: Starting LSB: Home Automation System...
Sep 12 11:08:28 domoticzR1 domoticz.sh[1110]: /home/pi/domoticz/domoticz: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file:
Sep 12 11:08:28 domoticzR1 systemd[1]: Started LSB: Home Automation System.
From a browser window on the raspberry I downloaded the armhf version of libssl.so.1.0.0 from https://packages.debian.org/jessie/libssl1.0.0
In a terminal window I installed the package:

Code: Select all

[email protected]:~ $ cd Downloads
[email protected]:~/Downloads $ sudo dpkg -i libssl1.0.0*
Selecting previously unselected package libssl1.0.0:armhf.
(Reading database ... 122756 files and directories currently installed.)
Preparing to unpack libssl1.0.0_1.0.1t-1+deb8u6_armhf.deb ...
Unpacking libssl1.0.0:armhf (1.0.1t-1+deb8u6) ...
Setting up libssl1.0.0:armhf (1.0.1t-1+deb8u6) ...
stopped and restarted Domoticz (a reboot should also work):

Code: Select all

[email protected]:~/Downloads $ cd ..
[email protected]:~ $ sudo service domoticz.sh stop
[email protected]:~ $ sudo service domoticz.sh start
then checked availability of Domoticz on port 8080:

Code: Select all

[email protected]:~ $ wget 127.0.0.1:8080
--2017-09-12 12:01:53--  http://127.0.0.1:8080/
Connecting to 127.0.0.1:8080... connected.
HTTP request sent, awaiting response... 200 OK
Length: 90327 (88K) [text/html]
Saving to: ‘index.html’

index.html          100%[===================>]  88.21K  --.-KB/s    in 0.002s  

2017-09-12 12:01:53 (57.4 MB/s) - ‘index.html’ saved [90327/90327]
after this I could also access Domoticz from other devices.

wegen
Posts: 4
Joined: Wednesday 13 September 2017 6:24
Target OS: -
Domoticz version:
Contact:

Re: Domoticz does not open port 8080

Post by wegen » Wednesday 13 September 2017 7:13

hello,

sorry for this simple question...

how did you put libssl.so.1.0.0 in the download directory?
wich version of this lib did you use?

Many thanks for your answers

koowee
Posts: 63
Joined: Thursday 29 December 2016 19:17
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Finland
Contact:

Re: Domoticz does not open port 8080

Post by koowee » Wednesday 13 September 2017 7:27


wegen
Posts: 4
Joined: Wednesday 13 September 2017 6:24
Target OS: -
Domoticz version:
Contact:

Re: Domoticz does not open port 8080

Post by wegen » Wednesday 13 September 2017 17:15

koowee wrote:
Wednesday 13 September 2017 7:27
here is one way how you can do it
http://www.domoticz.com/forum/viewtopic ... 20#p150258
Many thanks for your help. I did it but I still become this page : Apache2 Debian Default Page

Any idea?

SweetPants
Posts: 1484
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V3.8441
Location: The Netherlands
Contact:

Re: Domoticz does not open port 8080

Post by SweetPants » Wednesday 13 September 2017 19:20

wegen wrote:
Wednesday 13 September 2017 17:15
Many thanks for your help. I did it but I still become this page : Apache2 Debian Default Page Any idea?
Ehhh "Apache2 Debian Default page" suggests you have apache installed too. Domoticz has it's own web server (not apache). Does that run on 8080 too? Try starting domoticz manually with a different "-www port"

wegen
Posts: 4
Joined: Wednesday 13 September 2017 6:24
Target OS: -
Domoticz version:
Contact:

Re: Domoticz does not open port 8080

Post by wegen » Wednesday 13 September 2017 20:56

SweetPants wrote:
Wednesday 13 September 2017 19:20
wegen wrote:
Wednesday 13 September 2017 17:15
Many thanks for your help. I did it but I still become this page : Apache2 Debian Default Page Any idea?
Ehhh "Apache2 Debian Default page" suggests you have apache installed too. Domoticz has it's own web server (not apache). Does that run on 8080 too? Try starting domoticz manually with a different "-www port"
I really need your help. Could you contact me private?

wegen
Posts: 4
Joined: Wednesday 13 September 2017 6:24
Target OS: -
Domoticz version:
Contact:

Re: Domoticz does not open port 8080

Post by wegen » Sunday 17 September 2017 22:29

I still don't get it:

Code: Select all

[email protected]:~/domoticz $ wget 192.168.1.112:8080
--2017-09-17 20:20:40--  http://192.168.1.112:8080/
Connecting to 192.168.1.112:8080... failed: Connection refused.
I followed those steps:

Install Raspbian desktop edition
activate ssh by creating ssh file in boot
connect via putty, user pi
run command

Code: Select all

sudo curl -L install.domoticz.com | sudo bash
run command

Code: Select all

cd domoticz
./updaterelease

Code: Select all

wget http://mirrordirector.raspbian.org/raspbian/pool/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u6_armhf.deb
sudo dpkg -i libssl1.0.0_1.0.1t-1+deb8u6_armhf.deb

Code: Select all

sudo curl -L install.domoticz.com
I cannot reach my roboticz at the adress: 192.168.1.112:8080
ping on 192.168.1.112 works
I use RPI3

Many thanks for your help

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests