Switch Selector Name Length

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
Posts: 41
Joined: Wednesday 26 October 2016 21:01
Target OS: Raspberry Pi
Domoticz version: 3.5877

Switch Selector Name Length

Post by borgkitty » Wednesday 08 March 2017 14:04

Domoticz v 3.5877
Platform : raspberry pi

I have a weird issue with the domoticz switch selector
When I setup a selector switch it will let me create a name for each button like normal. It will work with any name length of 1- whatever the max is.
So I have named some of the buttons R, G, B, Y. These are just colors of an LED I want changed for a project.
I am able to name each button with a single letter just fine. However one time I added 2 letters. I went to the little pencil on the side of it and to edit it to change it to a single letter. But when I do that it wont let me hit the rename if its 1 letter, if i do 2 or more it will rename it.

I have confirmed this by redoing it multiple times. i would like others to confirm if they can't change a button name to 1 letter?
if so I dont know which would be a bug. Is it a bug that you allow 1 letter to be submitted for a name or is it a bug that it wont let you rename it to a single character. I hope this makes sense I can add pictures or a walk through if needed.

One other issue. What is the max amount of buttons you can have on a selector switch? as I think I have hit it. Currently I have 18 buttons but when i get to the 13th button it doesn't send codes anymore. I confirmed this that it doesn't send the codes to an ESP via the logs ,all buttons 1-12 work (including the built in off or "0" action) so technically 0-11 work and I look in the logs and it gives errors like

Code: Select all

2017-03-06 00:21:51.633 Error: Setting a wrong level value 110 to Selector device 13062918318095155281
2017-03-06 00:21:51.633 (LED Candles) Light/Switch (LED Candles)
If I remember right i think 12 is the max on the sliders... so i would assume this is not a coincidence?

Posts: 340
Joined: Friday 03 April 2015 20:44
Target OS: Raspberry Pi
Domoticz version:
Location: Germany (near dutch border)

Re: Switch Selector Name Length

Post by DutchHans » Thursday 14 December 2017 11:44

I've noticed the same. Is there a reason that the name must be more than one character? It is now not possible to work with IFTTT variables with only one character and parse them via a webrequest. For example preset 1 to 9.

If someone knows a workaround...?

Regards, Hans

Posts: 780
Joined: Friday 02 October 2015 12:12
Target OS: Raspberry Pi
Domoticz version: beta
Location: Finland

Re: Switch Selector Name Length

Post by Nautilus » Friday 15 December 2017 1:49

You can add level with one character by entering e.g. "1 " (that is, 1 followed by a space). Domoticz will then allow you to save it, but the space does not remain in the actual level name (at least the event system sees it as "1").

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest