Mi_light Ibox v6 (API) not working

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
ArieKanarie
Posts: 48
Joined: Saturday 12 December 2015 14:25
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by ArieKanarie » Thursday 09 February 2017 17:40

On the bulb it says "6w RGB WW Led bulb" and I have this remote.
Image

The last time I connected them using the app only.

I tried the scripts from the "Strontvlieg" github (the selector looked appealing) but that doesn't do anything too...

running manually:

Code: Select all

pi@raspberrypi:~/domoticz/scripts/python $ python milight.py 01 ON
 [DEBUG] start command1           : 01
[DEBUG] start command2           : ON
[DEBUG] received session message : 28000000110002F0FE6B1E34C0721DEB6600014C0000
[DEBUG] sessionID1               : 4C
[DEBUG] sessionID2               : 00
[DEBUG] cycle number             : 00
[DEBUG] light command            : 31 00 00 08 04 01 00 00 00
[DEBUG] zone                     : 01
[DEBUG] checksum                 : 3F
[DEBUG] sending command          : 80 00 00 00 11 4C 00 00 00 00 31 00 00 08 04 01 00 00 00 01 00 3F
[DEBUG] received message         : 8800000003000000

Nautilus
Posts: 792
Joined: Friday 02 October 2015 12:12
Target OS: Raspberry Pi
Domoticz version: beta
Location: Finland
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by Nautilus » Thursday 09 February 2017 19:22

ArieKanarie wrote:On the bulb it says "6w RGB WW Led bulb" and I have this remote.

The last time I connected them using the app only.

I tried the scripts from the "Strontvlieg" github (the selector looked appealing) but that doesn't do anything too...
Hmm, I'm pretty sure for this bulb you need to select RGBW and not RGBWW as the mode in Domoticz hardware. And did you also select this remote as the type in the app?

CaptainSlow
Posts: 80
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by CaptainSlow » Thursday 09 February 2017 19:43

Im pretty sure i selected the newest remote in the milight 3 app as this is the only remote i have. Ive got 1 rgbww bulb and 2 rgbw bulbs. All in the same group/zone and they all work.
Im starting to think itd the remote and remote you choose in the app when linking your bulbs.
____________________________________________________________________
Raspberry PI 3, Domoticz Beta, Open Therm Gateway with ESP wifi-bridge, Milight Ibox(V6), Wundermap

Nautilus
Posts: 792
Joined: Friday 02 October 2015 12:12
Target OS: Raspberry Pi
Domoticz version: beta
Location: Finland
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by Nautilus » Thursday 09 February 2017 20:19

CaptainSlow wrote:Im pretty sure i selected the newest remote in the milight 3 app as this is the only remote i have. Ive got 1 rgbww bulb and 2 rgbw bulbs. All in the same group/zone and they all work.
Im starting to think itd the remote and remote you choose in the app when linking your bulbs.
True, if the bulbs are new (produced post Aug 2016 or something like that) they work with v6 protocol as well. But older RGBW(Warm) bulbs do not work, there's some sort of "protection" nowadays...

ArieKanarie
Posts: 48
Joined: Saturday 12 December 2015 14:25
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by ArieKanarie » Thursday 09 February 2017 20:40

Well, beats me, changing the hardware mode to V6/RGBW indeed did the trick!
But then both the RGBW and the RGBWW devices work for the same bulb, so i'm completely lost now in the RGBW(W) forrest :lol:
But it works in Domoticz so I'm a happy man, now find an alternative for the 'Strontvlieg' git script, as this one still wont't work with these bulbs.

Thanks for the patience and the help!

matv
Posts: 23
Joined: Sunday 08 January 2017 19:26
Target OS: Raspberry Pi
Domoticz version: 3.5877
Location: EU
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by matv » Thursday 09 February 2017 21:09

Did someone already manage to change the brightness (or turn on / off) of both the bulbs and the iBox with one button?
I learned that the iBox can not be part of a 'zone' and I think that that's the underlying problem..

CaptainSlow
Posts: 80
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by CaptainSlow » Thursday 09 February 2017 21:33

ArieKanarie wrote:Well, beats me, changing the hardware mode to V6/RGBW indeed did the trick!
But then both the RGBW and the RGBWW devices work for the same bulb, so i'm completely lost now in the RGBW(W) forrest :lol:
But it works in Domoticz so I'm a happy man, now find an alternative for the 'Strontvlieg' git script, as this one still wont't work with these bulbs.

Thanks for the patience and the help!
beats me too.... :D :D :D :D :D :D :D Funny things these milights but I like them a lot...Glad you got it working. I bought my 2 RGBW (9w E27) bulbs at alieexpress 2 months ago and the 2 weeks the IBOX2 (V6) without light and the RGBWW (8W E27) bulb at Applamp.

You'll probably run into problems when you buy new bulbs having to switch the set mode from RGBW to RGBWW if you put them in 1 group.
In seperate groups the domoticz might find a solution adding a setting option per device (rgbw old, rgbw new, rgb...etc..). Not sure if that makes sense but we would achieve backwards compatibility I would think
____________________________________________________________________
Raspberry PI 3, Domoticz Beta, Open Therm Gateway with ESP wifi-bridge, Milight Ibox(V6), Wundermap

RayAmsterdam
Posts: 190
Joined: Sunday 11 January 2015 17:40
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by RayAmsterdam » Thursday 09 February 2017 23:22

You can add the same bridge as multiple hardware devices in Domoticz. One for v5, one for v6, etc.

burton666
Posts: 107
Joined: Monday 17 August 2015 21:25
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by burton666 » Friday 10 February 2017 22:03

Sorry if I have missed it but can I control the leds in the ibox somehow? I tried adding a milight v6 with the correct ip and port 8899 and selected RGBW. (port 8899 and STA-mode is default in the webui.)

But I only get 4x AppLamp Group in the devices and I dont understand how to control it, I can control it from the android app.

Nautilus
Posts: 792
Joined: Friday 02 October 2015 12:12
Target OS: Raspberry Pi
Domoticz version: beta
Location: Finland
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by Nautilus » Saturday 11 February 2017 0:00

burton666 wrote:Sorry if I have missed it but can I control the leds in the ibox somehow? I tried adding a milight v6 with the correct ip and port 8899 and selected RGBW. (port 8899 and STA-mode is default in the webui.)

But I only get 4x AppLamp Group in the devices and I dont understand how to control it, I can control it from the android app.
In Domoticz set port 5987 and choose type RGBWW. I think this should create an additional device to control the iBox lamp. Note, no need to change the port id in bridge setup from 8899.

gerardwr
Posts: 76
Joined: Saturday 28 January 2017 12:30
Target OS: -
Domoticz version:
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by gerardwr » Saturday 11 February 2017 16:59

Version: 3.6572
Platform : RPi + RFLink R45
Milight iBox1 + RGBWW light

Controlling the iBox1 light and the RGB section of the RGBWW light from Domoticz works great, when you select the V6 bridge and the RGBWW device.

But controlling just the W/WW section of the RGBWW light (so no color leds but only the W/WW leds) seems not possible now.

The UI has a radio button for RGB and WHITE but selecting WHITE does not seem to have any influence. Perhaps this is a feature that is meant for the older RGBW lights.
Schermafbeelding 2017-02-11 om 00.29.51.png
Schermafbeelding 2017-02-11 om 00.29.51.png (74.09 KiB) Viewed 1923 times
Should the Domoticz code be changed for controlling the W/WW leds of the RGBWW light, or do I miss something?

midomot
Posts: 19
Joined: Sunday 12 February 2017 14:27
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by midomot » Sunday 12 February 2017 14:47

gerardwr wrote:Version: 3.6572
Platform : RPi + RFLink R45
Milight iBox1 + RGBWW light
My setup:
Domoticz V3.6694 on Raspberry - apparently latest version at this time.
Wifi Ibox1 set up in hardware as "Limitless/AppLamp/Mi Light with LAN/WiFi interface"
Mode = Bridge Type V6 and Type= RGBWW

All lamps (devices) as Switch Type= dimmer

If I go to Switches, and click on the icon of the App LampBridge, I get
Image
If I go to Edit for the App LampBridge, I get
Image

Same pictures respectively when click on icon of App LampGroup1, or on Edit for App LampGroup1

The only time I get same pictures as yours (with more menus) is when I got to Edit for AppLampAll
BUT, it looks like only RGB + color selection is currently working.


I have a little blockly to turn on the LampBridge before sunset and then off after sunrise.
It just goes on of off with what was the last color chosen
Do you know a way to force a specific color such as 00ff22 for example ?

gerardwr
Posts: 76
Joined: Saturday 28 January 2017 12:30
Target OS: -
Domoticz version:
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by gerardwr » Sunday 12 February 2017 15:08

midomot wrote: The only time I get same pictures as yours (with more menus) is when I got to Edit for AppLampAll
BUT, it looks like only RGB + color selection is currently working.
Yes, same here!
Do you know a way to force a specific color such as 00ff22 for example ?
Yes, without a Blocky, I use it in a Scene. The scene has a timer switching on at sunset.

- edit the scene
- select the Milight lamp in the scene
- select the color you want
- press UPDATE
- the line of the Milight lamp is now updated with the selected color.

When the scene is started the Milight lamp switches to the defined color.

Hope this helps.
Schermafbeelding 2017-02-12 om 14.03.23.png
Schermafbeelding 2017-02-12 om 14.03.23.png (247.36 KiB) Viewed 1887 times

Misterik
Posts: 30
Joined: Sunday 11 December 2016 19:30
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by Misterik » Sunday 12 February 2017 17:52

gerardwr wrote: Yes, without a Blocky, I use it in a Scene. The scene has a timer switching on at sunset.

- edit the scene
- select the Milight lamp in the scene
- select the color you want
- press UPDATE
- the line of the Milight lamp is now updated with the selected color.

When the scene is started the Milight lamp switches to the defined color.

Hope this helps.
I use this way also to turn on the lamp in my house. I have multiple scenes (when its dark, when its dark and i come home eg.)I have also some new CCT lamps and noticed that with the Ibox these lamps switch to cold white light when a scene is started and a different brightness is used. Anyone have an idea how in a scene the lamp can be turned to Warm White. Is there perhaps a hex-value i can use?
RPI-3 + RFLink + NRF24L01
Milight lamps (Wifi Controler v4 & Iboxv6, GU10, MR16, E27, ledstrip)
Kaku devices (APA3-1500, ACM-2300h, AMST-606, AWST-6000, APIR215)

pcc9
Posts: 12
Joined: Tuesday 17 March 2015 16:00
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by pcc9 » Monday 13 February 2017 17:30

Hi to all,

I have a mi light box V6 with 2 RGBW strips. I managed to make them work with the milight 3.0 android APP. Link is Ok, STA mode with a fix IP and port well configured.
I downloaded the app for windows to test the end to end solution ( http://www.limitlessled.com/dev/ ).
I can communicate with the bridge and all the parameter seem to be good.

I created a hardware in Domoticz with the fixed IP of my iBox V6 and parameter of the udp port 5987. And Domoticz created all the Applamp and bridge are visible as devices.

When I try to pilot the strips, it seems the command goes to the bridge as the bridge is answering OK ( Usinf the Windows app comming from the web site ), but no command goes to the strip.

So , the strip is reacting and can be piloted by the Andoid APP but I can't make in work with Domiticz or with the windows test app.
Any Clue?

thanks for your help.
Pierre

midomot
Posts: 19
Joined: Sunday 12 February 2017 14:27
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by midomot » Wednesday 15 February 2017 15:22

gerardwr wrote: Hope this helps.
Thank you Gerard
I did learn something, and I'm also now playing with a python script (https://github.com/Strontvlieg/miLight- ... 2-Domoticz)
Great !

gerardwr
Posts: 76
Joined: Saturday 28 January 2017 12:30
Target OS: -
Domoticz version:
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by gerardwr » Wednesday 15 February 2017 15:47

midomot wrote:
Thank you Gerard
I did learn something, and I'm also now playing with a python script (https://github.com/Strontvlieg/miLight- ... 2-Domoticz)
Great !
You're welcome.

Here's another python script that works well too.
https://github.com/bwydoogh/domoticz-scripts

Have fun!

WaMeLiNoS
Posts: 5
Joined: Monday 20 February 2017 22:01
Target OS: Raspberry Pi
Domoticz version: BETA
Location: Netherlands
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by WaMeLiNoS » Monday 20 February 2017 22:05

First post, and completely new user ;-)
First of all I have been reading a lot and I would like to thank all people making these nice scripts for us, and me as a beginner. It helps me understanding the basics, so hopefully in time I can also make / modify my own scripts.

Recently started with Domoticz, also with the Milight sets. I have a E14 and E27 set, but they are RBGW and RBGWW.

At this point within the MiLight App and DomoticZ I am now able to control only 1 at a time, when switching operating mode. Does this mean I should add another wifi box, so the RBGW is controlled by 1 and the RBGWW is controlled by the other? Or is there a workaround to get both working withing the same box (v6) ?

RayAmsterdam
Posts: 190
Joined: Sunday 11 January 2015 17:40
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: RE: Re: Mi_light Ibox v6 (API) not working

Post by RayAmsterdam » Monday 20 February 2017 22:17

WaMeLiNoS wrote:First post, and completely new user ;-)
First of all I have been reading a lot and I would like to thank all people making these nice scripts for us, and me as a beginner. It helps me understanding the basics, so hopefully in time I can also make / modify my own scripts.

Recently started with Domoticz, also with the Milight sets. I have a E14 and E27 set, but they are RBGW and RBGWW.

At this point within the MiLight App and DomoticZ I am now able to control only 1 at a time, when switching operating mode. Does this mean I should add another wifi box, so the RBGW is controlled by 1 and the RBGWW is controlled by the other? Or is there a workaround to get both working withing the same box (v6) ?
You can add multiple Milight's in the hardware menu. One for each mode (of the same controller).

cverhoef
Posts: 26
Joined: Sunday 13 November 2016 12:03
Target OS: Linux
Domoticz version: Dev
Contact:

Re: RE: Re: RE: Re: Mi_light Ibox v6 (API) not working

Post by cverhoef » Monday 20 February 2017 22:29

RayAmsterdam wrote:
WaMeLiNoS wrote:First post, and completely new user ;-)
First of all I have been reading a lot and I would like to thank all people making these nice scripts for us, and me as a beginner. It helps me understanding the basics, so hopefully in time I can also make / modify my own scripts.

Recently started with Domoticz, also with the Milight sets. I have a E14 and E27 set, but they are RBGW and RBGWW.

At this point within the MiLight App and DomoticZ I am now able to control only 1 at a time, when switching operating mode. Does this mean I should add another wifi box, so the RBGW is controlled by 1 and the RBGWW is controlled by the other? Or is there a workaround to get both working withing the same box (v6) ?
You can add multiple Milight's in the hardware menu. One for each mode (of the same controller).
I'm writing on the native hardware code for V6 (ibox). It's not completely ready at the moment but it will run RGBW and RGBWW with the same instance of limitlessled hardware. I hope we can put it into beta soon. For now you should at the hardware (ibox) for each type (RGBW &RGBWW) from the beta code.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest