Dashticz, framb0ise,default.html - Settings help needed

antipiot
Posts: 40
Joined: Wednesday 03 January 2018 16:08
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Switzerland
Contact:

Dashticz, framb0ise,default.html - Settings help needed

Post by antipiot » Wednesday 31 January 2018 21:25

Hello mates!
i'm running the latests Domotictz Stable version:

I Recently (today :-) ) find i cant play with thoses interfaces and went ahead to try it since it was easy to install and well documented but i've found myself stuck and don't know what to do:
I did some research about but could'nt find anything :-(

I tried thoses 3 frontpages/dashboards: Dashticz 2.0, framb0ise 2.0 and default.html

I'not able to get any of them seeing/getting my devices.

For Dashticz and Framboise:
- I'not able to save the settings: they go back to default as soon as i refresh.
- i can edit the config.js - my modifications are taken.
- If i edit correctly my config.js and save it i still dont have any devices: for example:

Code: Select all

var config = {}
config['domoticz_ip'] = 'https://xxxxxxxx:xxxxxxxxxxx@10.0.0.40:8888';
config['app_title'] = 'Dashticz';
config['domoticz_refresh'] = '5';
config['dashticz_refresh'] = '60';
As said before for all thoses frontpages // dashbords, i'm not able to edit the config from within the web interface.
i also modified the rights to 775 with no luck.



I've read that they should get my devices by themselves when correctly connected but i cant get any.

trying this from my PC is working and return values: https://xxxxxxxx:xxxxxxxxxxx@10.0.0.40: ... ces&plan=3, working too without credentials when network is whitlisted.

I tried to take a look in logs for connections but couldn't see anything.

Am i doing something wrong? Did i missed something?

I hope my explanations are clear enough for somebody to help me :-)

Thanks in advance! :D

CaesarPL
Posts: 116
Joined: Tuesday 08 November 2016 15:03
Target OS: Raspberry Pi
Domoticz version:
Location: Poland
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by CaesarPL » Thursday 01 February 2018 10:23

That's a bit strange. There is a chance that you've configured Dashticz in a wrong way, but framb0ise just works...

I will take a look when back home and try to find some suggestions.
HW:Raspberry PiB+,Pi3,PiB,RFLink,FA20RF,DCS-930L,DCS-935L,Clarus switches,RF Temp sensors,Owl Micro+,Mi Flora,Kerui,Yeelight,Xiaomi,Broadlink RMM3,Alexa
SF:Jessie,Dmtcz 3.8153,Logitech Media srv,PiCorePlayers,Dashticz,Max2Play,InfluxDB,Grafana,HABridge

antipiot
Posts: 40
Joined: Wednesday 03 January 2018 16:08
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Switzerland
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by antipiot » Thursday 01 February 2018 20:05

Thanks for your help:-)
i'm feeling that my trouble are all related to the fact that i'm not able to save the configurations. that should just work.... but....

User avatar
jvdz
Posts: 1295
Joined: Tuesday 30 December 2014 20:25
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Westland/Netherlands
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by jvdz » Thursday 01 February 2018 21:00

antipiot wrote:
Wednesday 31 January 2018 21:25
Framboise:
- I'not able to save the settings: they go back to default as soon as i refresh.
- i can edit the config.js - my modifications are taken.
- If i edit correctly my config.js and save it i still dont have any devices: for example:
You do have some Rooms setup in Domoticz as that is what Framboise is using?
The settings are saved in either the browser Application Cache or in a Domoticz uservariable depending of the tickbox in the setup.

Jos

antipiot
Posts: 40
Joined: Wednesday 03 January 2018 16:08
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Switzerland
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by antipiot » Thursday 01 February 2018 21:04

jvdz wrote:
Thursday 01 February 2018 21:00
antipiot wrote:
Wednesday 31 January 2018 21:25
Framboise:
- I'not able to save the settings: they go back to default as soon as i refresh.
- i can edit the config.js - my modifications are taken.
- If i edit correctly my config.js and save it i still dont have any devices: for example:
You do have some Rooms setup in Domoticz as that is what Framboise is using?
The settings are saved in either the browser Application Cache or in a Domoticz uservariable depending of the tickbox in the setup.

Jos
I do have room plans setted up and working as i can get statuses.
for the settings, i cant tick any boxes :-( as soon as i hitz f5 everything dissapear and related paramters in settings are not changed.

Thanks for your suggestions! :-)

EDIT: Did some more test on Framb0ise:
Seems everything get registred but links: as domoticz URL and RSS feeds links.
Panel color selector doesent register new values aswell

I did a apt-get updat/upgrade today aswell.
Last edited by antipiot on Thursday 01 February 2018 21:12, edited 1 time in total.

User avatar
jvdz
Posts: 1295
Joined: Tuesday 30 December 2014 20:25
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Westland/Netherlands
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by jvdz » Thursday 01 February 2018 21:09

Have you checked in chrome to see what is stored in the Application storage, by pressing F12 and checking tab Application?

Jos

antipiot
Posts: 40
Joined: Wednesday 03 January 2018 16:08
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Switzerland
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by antipiot » Thursday 01 February 2018 21:16

is this interesting? :-)

Code: Select all

jquery.min.js:4 GET https://10.0.0.13:8900/framb0ise/undefined/json.htm?type=hardware 404 (Not Found)
send @ jquery.min.js:4
ajax @ jquery.min.js:4
r.(anonymous function) @ jquery.min.js:4
getJSON @ jquery.min.js:4
readHardware @ framboise.js:374
(anonymous) @ framboise.js:1103
j @ jquery.min.js:2
k @ jquery.min.js:2
setTimeout (async)
(anonymous) @ jquery.min.js:2
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
fire @ jquery.min.js:2
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
ready @ jquery.min.js:2
S @ jquery.min.js:3
jquery.min.js:4 GET https://10.0.0.13:8900/json.htm?type=command&param=getuservariables 401 (Unauthorized)
send @ jquery.min.js:4
ajax @ jquery.min.js:4
r.(anonymous function) @ jquery.min.js:4
getJSON @ jquery.min.js:4
loadsettingsfromdomoticz @ framboise.js:1016
(anonymous) @ framboise.js:1101
j @ jquery.min.js:2
k @ jquery.min.js:2
setTimeout (async)
(anonymous) @ jquery.min.js:2
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
fire @ jquery.min.js:2
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
ready @ jquery.min.js:2
S @ jquery.min.js:3
jquery.min.js:4 GET https://10.0.0.13:8900/framb0ise/undefined/json.htm?type=plans&displayhidden=1 404 (Not Found)
send @ jquery.min.js:4
ajax @ jquery.min.js:4
r.(anonymous function) @ jquery.min.js:4
getJSON @ jquery.min.js:4
createRooms @ framboise.js:535
(anonymous) @ framboise.js:1104
j @ jquery.min.js:2
k @ jquery.min.js:2
setTimeout (async)
(anonymous) @ jquery.min.js:2
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
fire @ jquery.min.js:2
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
ready @ jquery.min.js:2
S @ jquery.min.js:3
jquery.min.js:4 GET https://10.0.0.13:8900/framb0ise/undefined/json.htm?type=cameras 404 (Not Found)
when opening whitelisted IP url i get
http://10.0.0.13:8080/framb0ise/undefin ... ayhidden=1

404 not found

but this works:
https://10.0.0.13:8900/json.htm?type=devices&plan=3 but
http://10.0.0.13:8080/json.htm?type=devices&plan=3 DONT :-/

antipiot
Posts: 40
Joined: Wednesday 03 January 2018 16:08
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Switzerland
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by antipiot » Thursday 01 February 2018 21:27

jvdz wrote:
Thursday 01 February 2018 21:09
Have you checked in chrome to see what is stored in the Application storage, by pressing F12 and checking tab Application?

Jos
Nothing inside.
Cant reproduce under chrome what i've said before with the ticker's getting correctly registered: Was probably a cache bait.

antipiot
Posts: 40
Joined: Wednesday 03 January 2018 16:08
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Switzerland
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by antipiot » Thursday 01 February 2018 21:30

with https://10.0.0.13:8900/framb0ise/

Code: Select all

jquery.min.js:4 GET https://10.0.0.13:8900/framb0ise/undefined/json.htm?type=plans&displayhidden=1 404 (Not Found)
send @ jquery.min.js:4
ajax @ jquery.min.js:4
r.(anonymous function) @ jquery.min.js:4
getJSON @ jquery.min.js:4
createRooms @ framboise.js:535
(anonymous) @ framboise.js:1104
j @ jquery.min.js:2
k @ jquery.min.js:2
setTimeout (async)
(anonymous) @ jquery.min.js:2
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
fire @ jquery.min.js:2
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
ready @ jquery.min.js:2
S @ jquery.min.js:3
framboise.js:1017 Uncaught TypeError: Cannot read property 'forEach' of undefined
    at Object.success (framboise.js:1017)
    at i (jquery.min.js:2)
    at Object.fireWith [as resolveWith] (jquery.min.js:2)
    at A (jquery.min.js:4)
    at XMLHttpRequest.<anonymous> (jquery.min.js:4)
(anonymous) @ framboise.js:1017
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
A @ jquery.min.js:4
(anonymous) @ jquery.min.js:4
XMLHttpRequest.send (async)
send @ jquery.min.js:4
ajax @ jquery.min.js:4
r.(anonymous function) @ jquery.min.js:4
getJSON @ jquery.min.js:4
loadsettingsfromdomoticz @ framboise.js:1016
(anonymous) @ framboise.js:1101
j @ jquery.min.js:2
k @ jquery.min.js:2
setTimeout (async)
(anonymous) @ jquery.min.js:2
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
fire @ jquery.min.js:2
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
ready @ jquery.min.js:2
S @ jquery.min.js:3
jquery.min.js:4 GET https://10.0.0.13:8900/framb0ise/undefined/json.htm?type=cameras 404 (Not Found)
send @ jquery.min.js:4
ajax @ jquery.min.js:4
r.(anonymous function) @ jquery.min.js:4
getJSON @ jquery.min.js:4
readCams @ framboise.js:81
(anonymous) @ framboise.js:1105
j @ jquery.min.js:2
k @ jquery.min.js:2
setTimeout (async)
(anonymous) @ jquery.min.js:2
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
fire @ jquery.min.js:2
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
ready @ jquery.min.js:2
S @ jquery.min.js:3
jquery.min.js:4 GET https://10.0.0.13:8900/framb0ise/undefined/json.htm?type=hardware 404 (Not Found)
send @ jquery.min.js:4
ajax @ jquery.min.js:4
r.(anonymous function) @ jquery.min.js:4
getJSON @ jquery.min.js:4
readHardware @ framboise.js:374
(anonymous) @ framboise.js:1103
j @ jquery.min.js:2
k @ jquery.min.js:2
setTimeout (async)
(anonymous) @ jquery.min.js:2
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
fire @ jquery.min.js:2
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
ready @ jquery.min.js:2
S @ jquery.min.js:3
jquery.min.js:4 GET https://10.0.0.13:8900/framb0ise/undefined/json.htm?type=plans&displayhidden=1 404 (Not Found)
send @ jquery.min.js:4
ajax @ jquery.min.js:4
r.(anonymous function) @ jquery.min.js:4
getJSON @ jquery.min.js:4
checkWidgets @ framboise.js:505
setInterval (async)
(anonymous) @ framboise.js:519
jquery.min.js:4 GET https://10.0.0.13:8900/framb0ise/undefined/json.htm?type=plans&displayhidden=1 404 (Not Found)
send @ jquery.min.js:4
ajax @ jquery.min.js:4
r.(anonymous function) @ jquery.min.js:4
getJSON @ jquery.min.js:4
checkWidgets @ framboise.js:505
setInterval (async)
(anonymous) @ framboise.js:519
jquery.min.js:4 GET https://10.0.0.13:8900/framb0ise/undefined/json.htm?type=plans&displayhidden=1 404 (Not Found)
with http://10.0.0.13:8080/framb0ise/

Code: Select all

:8080/json.htm?type=command&param=getuservariables Failed to load resource: the server responded with a status of 401 (Unauthorized)
:8080/framb0ise/undefined/json.htm?type=hardware Failed to load resource: the server responded with a status of 404 (Not Found)
:8080/framb0ise/undefined/json.htm?type=plans&displayhidden=1 Failed to load resource: the server responded with a status of 404 (Not Found)
:8080/framb0ise/undefined/json.htm?type=cameras Failed to load resource: the server responded with a status of 404 (Not Found)
6:8080/framb0ise/undefined/json.htm?type=plans&displayhidden=1 Failed to load resource: the server responded with a status of 404 (Not Found)

User avatar
jvdz
Posts: 1295
Joined: Tuesday 30 December 2014 20:25
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Westland/Netherlands
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by jvdz » Thursday 01 February 2018 21:40

The "/framb0ise/undefined" shouldn't be there...right?
What have you defined in the settings page?
The domoticz server url should only have: https://10.0.0.13:8900

Jos

antipiot
Posts: 40
Joined: Wednesday 03 January 2018 16:08
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Switzerland
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by antipiot » Thursday 01 February 2018 21:45

jvdz wrote:
Thursday 01 February 2018 21:40
The "/framb0ise/undefined" shouldn't be there...right?
What have you defined in the settings page?
The domoticz server url should only have: https://10.0.0.13:8900

Jos
I think you're right:
Did some test on mozzila:
When i apply my settings i get

Code: Select all

Loading mixed (insecure) active content “http://www.domoticz.com/forum/assets/fonts/fontawesome-webfont.woff2?v=4.7.0” on a secure page
[Learn More]
framb0ise
TypeError: data.result is undefined
[Learn More]
framboise.js:1017:3
loadsettingsfromdomoticz/<
https://10.0.0.13:8900/framb0ise/framboise.js:1017:3
i
https://10.0.0.13:8900/framb0ise/bower_components/jquery/dist/jquery.min.js:2:28012
fireWith
https://10.0.0.13:8900/framb0ise/bower_components/jquery/dist/jquery.min.js:2:28783
A
https://10.0.0.13:8900/framb0ise/bower_components/jquery/dist/jquery.min.js:4:14033
c/<
https://10.0.0.13:8900/framb0ise/bower_components/jquery/dist/jquery.min.js:4:16323
I only get:

Code: Select all

404
GET
json.htm?type=plans&displayhidden=1
10.0.0.13:8900
JS
xhr
html
233 B
85 B
→ 42 ms
404
GET
json.htm?type=plans&displayhidden=1
10.0.0.13:8900
JS
xhr
html
233 B
85 B
→ 42 ms
404
GET
json.htm?type=plans&displayhidden=1
10.0.0.13:8900
JS
xhr
html
233 B
85 B
→ 43 ms
404
GET
json.htm?type=plans&displayhidden=1
10.0.0.13:8900
JS
xhr
html
233 B
85 B
→ 43 ms
404
GET
json.htm?type=plans&displayhidden=1
10.0.0.13:8900
JS
xhr
html
233 B
85 B
And:

Code: Select all

XML Parsing Error: no root element found
Location: https://10.0.0.13:8900/framb0ise/undefined/json.htm?type=plans&displayhidden=1
Line Number 1, Column 1:
this undefined again :-/ Under Mozilla

May this be the problem?
but why do i get 404

User avatar
jvdz
Posts: 1295
Joined: Tuesday 30 December 2014 20:25
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Westland/Netherlands
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by jvdz » Thursday 01 February 2018 21:51

You are sure you can read that Domoticz url without providing a Userid/Password?

Jos

antipiot
Posts: 40
Joined: Wednesday 03 January 2018 16:08
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Switzerland
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by antipiot » Thursday 01 February 2018 22:09

jvdz wrote:
Thursday 01 February 2018 21:51
You are sure you can read that Domoticz url without providing a Userid/Password?

Jos
Thoses doesent work:

https://10.0.0.13:8900/framb0ise/undefi ... ayhidden=1
https://10.0.0.13:8900/framb0ise/json.h ... ayhidden=1

This one work:
https://10.0.0.13:8900/json.htm?type=devices&plan=3

User avatar
jvdz
Posts: 1295
Joined: Tuesday 30 December 2014 20:25
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Westland/Netherlands
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by jvdz » Thursday 01 February 2018 22:20

Those will never work as they are invalid. Thought we went through that issue before!
/framb0ise doesn't belong there and will only show up there when you have the setting for the Domoticz URL wrong.... i think.
So do you have the proper settings in the setup window of framb0ise?

Jos

antipiot
Posts: 40
Joined: Wednesday 03 January 2018 16:08
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Switzerland
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by antipiot » Thursday 01 February 2018 22:37

jvdz wrote:
Thursday 01 February 2018 22:20
Those will never work as they are invalid. Thought we went through that issue before!
/framb0ise doesn't belong there and will only show up there when you have the setting for the Domoticz URL wrong.... i think.
So do you have the proper settings in the setup window of framb0ise?

Jos
I can't save anything in the settings windows. nothing stay.

Did a fresh installation on a new card and raspberry and could reporduce the problem.
I'm probably doing something wrong... but what.

What i did is:
fresh install of domoticz reachable at: http://test:test@10.0.0.10:8080
set admin password
create dummy switch
set new roomplan and add dummy switch

install framboise with:
ssh into your domoticz server;

cd </your/domoticz/dir>

cd www

git clone https://github.com/safi78/framb0ise

point your browser to: http://test:test@10.0.0.10:8080/framb0ise/

Same problem. Is this correct? :-)

EDIT: tried beta: same problem :D

thanks for your help again, it's really appreciated.

User avatar
jvdz
Posts: 1295
Joined: Tuesday 30 December 2014 20:25
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Westland/Netherlands
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by jvdz » Thursday 01 February 2018 22:55

You still haven't answered the simple basic question unless I missed it:
What have you filled in in the Framb0ise Setup window in the field: domoticz server ?
The rest in not important on this moment!

Jos

antipiot
Posts: 40
Joined: Wednesday 03 January 2018 16:08
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Switzerland
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by antipiot » Thursday 01 February 2018 23:28

jvdz wrote:
Thursday 01 February 2018 22:55
You still haven't answered the simple basic question unless I missed it:
What have you filled in in the Framb0ise Setup window in the field: domoticz server ?
The rest in not important on this moment!

Jos
Excuse me If my answers where Not clear.

Yes i Did. The value i put in doesent get registred.

User avatar
jvdz
Posts: 1295
Joined: Tuesday 30 December 2014 20:25
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Westland/Netherlands
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by jvdz » Friday 02 February 2018 13:01

antipiot wrote:
Thursday 01 February 2018 23:28
Excuse me If my answers where Not clear.
No need to apologize, I just want to understand what you did exactly! ;)
jvdz wrote:
Thursday 01 February 2018 22:55
What have you filled in in the Framb0ise Setup window in the field: domoticz server ?
antipiot wrote:
Thursday 01 February 2018 23:28
Yes i Did. The value i put in doesent get registred.
Did what? What did you put in that field?

Jos

antipiot
Posts: 40
Joined: Wednesday 03 January 2018 16:08
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Switzerland
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by antipiot » Friday 02 February 2018 14:22

Did what? What did you put in that field?
Jos
I click on the settings wheel - Under domoticz adress i put http://10.0.0.13:8080 or any other adress and click save.
i click again on the wheel - the domoticz adress is empty.

This apply for any value i can put.

CaesarPL
Posts: 116
Joined: Tuesday 08 November 2016 15:03
Target OS: Raspberry Pi
Domoticz version:
Location: Poland
Contact:

Re: Dashticz, framb0ise,default.html - Settings help needed

Post by CaesarPL » Friday 02 February 2018 14:26

Try storing framb0ise config in Domoticz.
HW:Raspberry PiB+,Pi3,PiB,RFLink,FA20RF,DCS-930L,DCS-935L,Clarus switches,RF Temp sensors,Owl Micro+,Mi Flora,Kerui,Yeelight,Xiaomi,Broadlink RMM3,Alexa
SF:Jessie,Dmtcz 3.8153,Logitech Media srv,PiCorePlayers,Dashticz,Max2Play,InfluxDB,Grafana,HABridge

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests