Error: "Double check path to domoticz in settings!"

Dashticz, alternative dashboard based on HTML, CSS, jQuery

Moderators: robgeerts, htilburgs

Post Reply
tomasz
Posts: 6
Joined: Tuesday 19 June 2018 13:35
Target OS: Raspberry Pi
Domoticz version:
Contact:

Error: "Double check path to domoticz in settings!"

Post by tomasz » Friday 13 July 2018 23:25

Hi Guys!

With my fairly simple config, I am getting message "Double check path to domoticz in settings!". It pops up after few seconds of using dashticz. Everything is loaded & displayed properly, but still I did not manage to find the reason behind this annoying issues.

Maybe I missed something obvious? Could you take a look quickly?

Code: Select all

var config = {}
config['domoticz_ip'] = 'http://192.168.2.150:8080';
config['app_title'] = 'xyz';
config['domoticz_refresh'] = '5';
config['dashticz_refresh'] = '60';

var buttons = {}
buttons.buienradar = {width:12, isimage:true, image: 'https://api.buienradar.nl/image/1.0/RadarMapNL?w=285&h=256'};

var blocks = {}
blocks['58'] = {}
blocks['58']['icon'] ='fa-home';
blocks['58']['title'] = 'Cho';

blocks['47'] = {}
blocks['47']['icon'] ='fa-female';
blocks['47']['title'] = 'Gab';

blocks['1'] = {}
blocks['1']['icon'] ='fa-home';
blocks['1']['title'] = 'Local';

var columns = {}

columns[1] = {}
columns[1]['blocks'] = ['graph_1','graph_47','graph_58']
columns[1]['width'] = 5;

columns[2] = {}
columns[2]['blocks'] = [1,47,58]
columns[2]['width'] = 4; 

columns[3] = {}
columns[3]['blocks'] = [buttons.buienradar]
columns[3]['width'] = 2; 

var screens = {}
screens[1] = {}
screens[1]['background'] = 'iss2.jpg';
screens[1]['columns'] = [2,3]
Thanks in advance!
Tomasz

wergeld
Posts: 18
Joined: Friday 01 January 2016 0:29
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Error: "Double check path to domoticz in settings!"

Post by wergeld » Monday 01 October 2018 3:23

I am facing similar issue. Only ever shows the "Double check path to domoticz in settings!" in lower right. I am running latest 2.4 beta on latest Domoticz 4.97 clean install. I have several devices all showing under my main URL. My custom/CONFIG.js:

Code: Select all

var config = {}
config['domoticz_ip'] = 'http://192.168.1.102:8080';
config['user_name'] = 'xxxxxxxxxxxx';
config['pass_word'] = 'yyyyyyyyyyyy';
config['loginEnabled'] = 1;
config['app_title'] = 'Dashticz';
config['domoticz_refresh'] = '5';
config['dashticz_refresh'] = '60';

EastXIII
Posts: 19
Joined: Monday 08 October 2018 13:56
Target OS: Raspberry Pi
Domoticz version: Beta
Contact:

Re: Error: "Double check path to domoticz in settings!"

Post by EastXIII » Tuesday 23 October 2018 13:11

Same issue here. Can't figure out why....

User avatar
Minglarn
Posts: 167
Joined: Friday 21 August 2015 19:27
Target OS: Raspberry Pi
Domoticz version: v3.8153
Location: Stockholm / Sweden
Contact:

Re: Error: "Double check path to domoticz in settings!"

Post by Minglarn » Tuesday 30 October 2018 11:17

Hi!
Having the same issues with mine, but there I think i've found the fault...

When running the Dashticz on a low end computer as RPI on WiFi there seems that the connection to Domoticz server times out.
When running on my High-End computer i've never encounter this error....
See this error in Chrome runing in RPI:
Skärmklipp.PNG
Skärmklipp.PNG (33.75 KiB) Viewed 218 times
Maybe there should be an option to add something like this:

Code: Select all

config['domoticz_timeout_reload'] = '10';
Where the timeout is defined in seconds and Dasthicz should try to reload the data from Domoticz?
Now it just halts and does not even try to reload. Only when Dasthicz is refreshed it reloads the data ..
When you eliminate the impossible, whatever remains, however improbable, must be the truth.” -Spock in Star Trek VI

pvm
Posts: 962
Joined: Tuesday 17 June 2014 22:14
Target OS: NAS (Synology & others)
Domoticz version: Stable
Location: NL
Contact:

Re: Error: "Double check path to domoticz in settings!"

Post by pvm » Tuesday 30 October 2018 11:56

I have the same issue, running dashticz on a simple tablet and domoticz on a synology nas.
Synology NAS, PI3, ZWave, Xiamo zigbee devices, BTLE plant sensor

RapTile
Posts: 64
Joined: Saturday 10 March 2018 3:01
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Error: "Double check path to domoticz in settings!"

Post by RapTile » Tuesday 30 October 2018 12:10

Same here.

This is the first time i try to set this up.
I am using a username and password on domoticz so i set my config to:

Code: Select all

config['domoticz_ip'] = 'http://USERNAME:#rfvbgtu@domoticzip:8080';
I also tried %23 for url encoding for the dash (#) and offcourse this aint my real password...

Code: Select all

http://USERNAME:%23rfvbgtu@ip:8080
But nothing seems to work.
Also tried to add the domoticzip to the local networks so no UN/PW is required but that didnt solve my problem either.

rgroothuis
Posts: 226
Joined: Friday 03 April 2015 17:09
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Error: "Double check path to domoticz in settings!"

Post by rgroothuis » Sunday 04 November 2018 21:08

Same issue on my side as well. Hope there is a solution at some stage.

Lokonli
Posts: 142
Joined: Monday 29 August 2016 22:40
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Error: "Double check path to domoticz in settings!"

Post by Lokonli » Sunday 04 November 2018 22:37

rgroothuis wrote:
Sunday 04 November 2018 21:08
Same issue on my side as well. Hope there is a solution at some stage.
I propose to first test without username/password. In Domoticz you can set the subnets that don't require a user/password combination.

If it's working without user/password, then you may enable user/password checking again in Domoticz.
In Dashticz use the following settings in CONFIG.js:
config['user_name'] = 'username';
config['pass_word'] = 'password';

rgroothuis
Posts: 226
Joined: Friday 03 April 2015 17:09
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Error: "Double check path to domoticz in settings!"

Post by rgroothuis » Sunday 04 November 2018 22:40

Lokonli wrote:
Sunday 04 November 2018 22:37
rgroothuis wrote:
Sunday 04 November 2018 21:08
Same issue on my side as well. Hope there is a solution at some stage.
I propose to first test without username/password. In Domoticz you can set the subnets that don't require a user/password combination.

If it's working without user/password, then you may enable user/password checking again in Domoticz.
In Dashticz use the following settings in CONFIG.js:
config['user_name'] = 'username';
config['pass_word'] = 'password';
For connections from the local network I'm not making used of a login name and password.
Screen Shot 2018-11-04 at 21.39.57.png
Screen Shot 2018-11-04 at 21.39.57.png (114.65 KiB) Viewed 144 times

User avatar
Minglarn
Posts: 167
Joined: Friday 21 August 2015 19:27
Target OS: Raspberry Pi
Domoticz version: v3.8153
Location: Stockholm / Sweden
Contact:

Re: Error: "Double check path to domoticz in settings!"

Post by Minglarn » Sunday 04 November 2018 23:27

The same here... no user/pass for local networks.

The switches and all work, it just do not update status and time for switches and temperatures. Strange.
When you eliminate the impossible, whatever remains, however improbable, must be the truth.” -Spock in Star Trek VI

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests