Dashticz - Bug report

Dashticz, alternative dashboard based on HTML, CSS, jQuery

Moderators: robgeerts, htilburgs

aiolos
Posts: 129
Joined: Sunday 13 September 2015 18:58
Target OS: Raspberry Pi
Domoticz version: stable
Location: Sale, UK
Contact:

Re: Dashticz - Bug report

Post by aiolos » Thursday 23 November 2017 13:22

I think some default styling for images instead of icons is missing then. There have been changes in those parts and I don't have images as icons, so I didn't really notice
Contributor to Dashticz
More on my Github profile

User avatar
blacksn0w
Posts: 118
Joined: Friday 10 March 2017 23:27
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Germany
Contact:

Re: Dashticz - Bug report

Post by blacksn0w » Thursday 23 November 2017 13:23

EdwinK wrote:
Thursday 23 November 2017 13:16
Screen Shot 2017-11-23 at 12.15.02.pngNow I've got this little problem. Not to serious, just need to resize them myself ;)
Got the same, since im using the .svg resizing is not easy possible.
Migration in progress, hello Home Assistant.

aiolos
Posts: 129
Joined: Sunday 13 September 2015 18:58
Target OS: Raspberry Pi
Domoticz version: stable
Location: Sale, UK
Contact:

Re: Dashticz - Bug report

Post by aiolos » Thursday 23 November 2017 18:25

EdwinK wrote:
Thursday 23 November 2017 13:16
Screen Shot 2017-11-23 at 12.15.02.png
Now I've got this little problem. Not to serious, just need to resize them myself ;)
I created the fix for this, I expect it to be merged soon.
Contributor to Dashticz
More on my Github profile

User avatar
robgeerts
Posts: 1230
Joined: Saturday 24 January 2015 23:12
Target OS: NAS (Synology & others)
Domoticz version: 3.7067
Location: NL
Contact:

Re: Dashticz - Bug report

Post by robgeerts » Thursday 23 November 2017 18:26

Merged :)
Creator of Dashticz
Do you appreciate my work and want to buy me a beer?
Send:
- XVG to D8fwNbyV6YxJk1aSiXftWTtdaPipsKn2Fa
- ANY ERC20-TOKEN to 0x9b8ee84329d77765a28bca188218c6c793875a8a

or donate via PayPal: https://www.paypal.me/robgeerts

User avatar
EdwinK
Posts: 1154
Joined: Sunday 22 January 2017 22:46
Target OS: Raspberry Pi
Domoticz version: BETA
Location: Rhoon
Contact:

Re: Dashticz - Bug report

Post by EdwinK » Thursday 23 November 2017 23:21

Thanks Rob and aiolos

you rock
Running latest BETA on a Pi-3 | Toon Thermostat | RFxcom | Dashticz V2 |

User avatar
htilburgs
Posts: 509
Joined: Tuesday 03 November 2015 12:01
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Dashticz - Bug report

Post by htilburgs » Friday 01 December 2017 13:07

In the latest beta, Dashticz won't load correct / complete in IE11.
Missing a lot of switches.

Error (in dutch):
SCRIPT5008: Ongeldige linkerkant van toewijzing (incorrect assigning on the left side)
main.js (1050,33)

line 1049 - 1051:

Code: Select all

catch (err) {
             [html, addHTML] = handleDevice(device, idx);
            }
For as far as I can find:

this is a Illegal assignment (JavaScript)
You attempted to assign a value to a read-only identifier. You cannot assign a value to a read-only identifier. For example, host defined objects and external COM objects. To correct this error --> Do not assign values to read-only identifiers.
Hardware:
RPi3 - Aeon Labs Z-Stick GEN5 - Fibaro Dimmer 2 - Fibaro Roller Shutter 2 - Fibaro Smoke Sensor - Yeelight RGBW Led bulb - Yeelight Smart LED Light Strip - Neo Coolcam PIR Motion Sensor - Neo Coolcam PowerPlug - Nest Thermostat v3

User avatar
htilburgs
Posts: 509
Joined: Tuesday 03 November 2015 12:01
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Dashticz - Bug report

Post by htilburgs » Friday 01 December 2017 17:16

htilburgs wrote:
Friday 01 December 2017 13:07
In the latest beta, Dashticz won't load correct / complete in IE11.
Missing a lot of switches.

Error (in dutch):
SCRIPT5008: Ongeldige linkerkant van toewijzing (incorrect assigning on the left side)
main.js (1050,33)

line 1049 - 1051:

Code: Select all

catch (err) {
             [html, addHTML] = handleDevice(device, idx);
            }
For as far as I can find:

this is a Illegal assignment (JavaScript)
You attempted to assign a value to a read-only identifier. You cannot assign a value to a read-only identifier. For example, host defined objects and external COM objects. To correct this error --> Do not assign values to read-only identifiers.
Tried it also on Microsoft Edge, same problem.
In my case my dashboard is on a Microsoft Surface RT (windows 8.1), that only supports Edge and IE11
Hardware:
RPi3 - Aeon Labs Z-Stick GEN5 - Fibaro Dimmer 2 - Fibaro Roller Shutter 2 - Fibaro Smoke Sensor - Yeelight RGBW Led bulb - Yeelight Smart LED Light Strip - Neo Coolcam PIR Motion Sensor - Neo Coolcam PowerPlug - Nest Thermostat v3

aiolos
Posts: 129
Joined: Sunday 13 September 2015 18:58
Target OS: Raspberry Pi
Domoticz version: stable
Location: Sale, UK
Contact:

Re: Dashticz - Bug report

Post by aiolos » Friday 01 December 2017 17:28

htilburgs wrote:
Friday 01 December 2017 17:16
htilburgs wrote:
Friday 01 December 2017 13:07
In the latest beta, Dashticz won't load correct / complete in IE11.
Missing a lot of switches.

Error (in dutch):
SCRIPT5008: Ongeldige linkerkant van toewijzing (incorrect assigning on the left side)
main.js (1050,33)

line 1049 - 1051:

Code: Select all

catch (err) {
             [html, addHTML] = handleDevice(device, idx);
            }
For as far as I can find:

this is a Illegal assignment (JavaScript)
You attempted to assign a value to a read-only identifier. You cannot assign a value to a read-only identifier. For example, host defined objects and external COM objects. To correct this error --> Do not assign values to read-only identifiers.
Tried it also on Microsoft Edge, same problem.
In my case my dashboard is on a Microsoft Surface RT (windows 8.1), that only supports Edge and IE11
On IE11 I can reproduce it, on Edge it works (but that's windows 10, so that might be different.) What version of Edge do you use? (I testen on Edge 38)
It is easy to fix, but problems like this are more likely to happen if we want to use the functions of the newer Javascript versions. IE11 is a bit getting the new IE6...
Contributor to Dashticz
More on my Github profile

User avatar
htilburgs
Posts: 509
Joined: Tuesday 03 November 2015 12:01
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Dashticz - Bug report

Post by htilburgs » Friday 01 December 2017 17:41

I can't find the version of Edge on the Windows Surface RT. Even don't know if its the real Edge or just IE11 in another look.
For IE:

11.0.9600.18838
Update: 11.0.48 (KB4047206)

It would be disappointing if we could'nt use IE11 as browser for Dashticz.
Hardware:
RPi3 - Aeon Labs Z-Stick GEN5 - Fibaro Dimmer 2 - Fibaro Roller Shutter 2 - Fibaro Smoke Sensor - Yeelight RGBW Led bulb - Yeelight Smart LED Light Strip - Neo Coolcam PIR Motion Sensor - Neo Coolcam PowerPlug - Nest Thermostat v3

aiolos
Posts: 129
Joined: Sunday 13 September 2015 18:58
Target OS: Raspberry Pi
Domoticz version: stable
Location: Sale, UK
Contact:

Re: Dashticz - Bug report

Post by aiolos » Friday 01 December 2017 17:56

You can find the version on https://www.whatismybrowser.com/

And yes, it would be disappointing if it doesn't work in IE anymore, but on the other hand: it is an old browser and edge is now the one to use (if you are required to use a Microsoft browser). Nevertheless this needs to be fixed, but there might be a moment where it won't be, since the new javascript functions can make the code much more readable and faster. (it's a pity Microsoft still supports IE, it would be better if they drop it completely and fully focus on Edge).
Contributor to Dashticz
More on my Github profile

User avatar
htilburgs
Posts: 509
Joined: Tuesday 03 November 2015 12:01
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Dashticz - Bug report

Post by htilburgs » Saturday 02 December 2017 12:39

But for now, can you fix it? So I can update my dashboard with te latest settings.
Hardware:
RPi3 - Aeon Labs Z-Stick GEN5 - Fibaro Dimmer 2 - Fibaro Roller Shutter 2 - Fibaro Smoke Sensor - Yeelight RGBW Led bulb - Yeelight Smart LED Light Strip - Neo Coolcam PIR Motion Sensor - Neo Coolcam PowerPlug - Nest Thermostat v3

aiolos
Posts: 129
Joined: Sunday 13 September 2015 18:58
Target OS: Raspberry Pi
Domoticz version: stable
Location: Sale, UK
Contact:

Re: Dashticz - Bug report

Post by aiolos » Saturday 02 December 2017 20:11

Yes, a PR is waiting to be merged. But I'm also still wondering what Edge version also causes this problem.
Contributor to Dashticz
More on my Github profile

User avatar
robgeerts
Posts: 1230
Joined: Saturday 24 January 2015 23:12
Target OS: NAS (Synology & others)
Domoticz version: 3.7067
Location: NL
Contact:

Re: Dashticz - Bug report

Post by robgeerts » Saturday 02 December 2017 22:50

Merged, check latest beta!
Creator of Dashticz
Do you appreciate my work and want to buy me a beer?
Send:
- XVG to D8fwNbyV6YxJk1aSiXftWTtdaPipsKn2Fa
- ANY ERC20-TOKEN to 0x9b8ee84329d77765a28bca188218c6c793875a8a

or donate via PayPal: https://www.paypal.me/robgeerts

MariH
Posts: 3
Joined: Tuesday 15 August 2017 21:23
Target OS: Raspberry Pi
Domoticz version: beta
Location: NL
Contact:

Re: Dashticz - Bug report

Post by MariH » Sunday 03 December 2017 16:48

Latest Beta is not working correctly with groups/scene's
Activating this code in CONFIG.js:

Code: Select all

blocks['s1'] = {}
blocks['s1']['width'] = 4;
blocks['s1']['title'] = 'Zitkamer';
blocks['s1']['hide_data'] = true;
will not send an 'ON' or 'OFF' command to 'group 1' but to 'switch 1'
this it out the domoticz logging:

Code: Select all

2017-12-03 15:39:24.286 User: Admin initiated a switch command (1/Weer: Luchtdruk/Off)
status is reflected OK

this use to work in earlier versions
Hardware
1x Raspberry Pi 3
1x RaZberry2 Z-Wave Plus
1x SolarEdge convertor
1x FGBS-001 Binaire Sensor
2x FGK-101 Door sensor
1x Logitech Harmony Hub
1x Sony Bravia TV
31x FGS-221 Double Relay Switch
2x Danfoss LC0013

aiolos
Posts: 129
Joined: Sunday 13 September 2015 18:58
Target OS: Raspberry Pi
Domoticz version: stable
Location: Sale, UK
Contact:

Re: Dashticz - Bug report

Post by aiolos » Sunday 03 December 2017 21:08

MariH wrote:
Sunday 03 December 2017 16:48
Latest Beta is not working correctly with groups/scene's

...

this use to work in earlier versions
Good find! The big cleanup a few weeks ago caused this. I pushed a fix for it, which Rob will merge very soon I think.
Contributor to Dashticz
More on my Github profile

User avatar
robgeerts
Posts: 1230
Joined: Saturday 24 January 2015 23:12
Target OS: NAS (Synology & others)
Domoticz version: 3.7067
Location: NL
Contact:

Re: Dashticz - Bug report

Post by robgeerts » Sunday 03 December 2017 21:11

Merged!
Check out latest beta!
Creator of Dashticz
Do you appreciate my work and want to buy me a beer?
Send:
- XVG to D8fwNbyV6YxJk1aSiXftWTtdaPipsKn2Fa
- ANY ERC20-TOKEN to 0x9b8ee84329d77765a28bca188218c6c793875a8a

or donate via PayPal: https://www.paypal.me/robgeerts

aiolos
Posts: 129
Joined: Sunday 13 September 2015 18:58
Target OS: Raspberry Pi
Domoticz version: stable
Location: Sale, UK
Contact:

Re: Dashticz - Bug report

Post by aiolos » Sunday 03 December 2017 21:12

robgeerts wrote:
Sunday 03 December 2017 21:11
Merged!
Check out latest beta!
You're just waiting for my pull requests all day, aren't you?
Contributor to Dashticz
More on my Github profile

MariH
Posts: 3
Joined: Tuesday 15 August 2017 21:23
Target OS: Raspberry Pi
Domoticz version: beta
Location: NL
Contact:

Re: Dashticz - Bug report

Post by MariH » Sunday 03 December 2017 21:40

Guys,
thx for the quick fix, works as a charm!
Hardware
1x Raspberry Pi 3
1x RaZberry2 Z-Wave Plus
1x SolarEdge convertor
1x FGBS-001 Binaire Sensor
2x FGK-101 Door sensor
1x Logitech Harmony Hub
1x Sony Bravia TV
31x FGS-221 Double Relay Switch
2x Danfoss LC0013

User avatar
robgeerts
Posts: 1230
Joined: Saturday 24 January 2015 23:12
Target OS: NAS (Synology & others)
Domoticz version: 3.7067
Location: NL
Contact:

Re: Dashticz - Bug report

Post by robgeerts » Sunday 03 December 2017 22:47

aiolos wrote:
Sunday 03 December 2017 21:12
robgeerts wrote:
Sunday 03 December 2017 21:11
Merged!
Check out latest beta!
You're just waiting for my pull requests all day, aren't you?
Yes, I've nothing better to do ;)
No, I got notifications about new mail on my devices, as my laptop is almost always on I merge your request immediately :)
Creator of Dashticz
Do you appreciate my work and want to buy me a beer?
Send:
- XVG to D8fwNbyV6YxJk1aSiXftWTtdaPipsKn2Fa
- ANY ERC20-TOKEN to 0x9b8ee84329d77765a28bca188218c6c793875a8a

or donate via PayPal: https://www.paypal.me/robgeerts

User avatar
htilburgs
Posts: 509
Joined: Tuesday 03 November 2015 12:01
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Dashticz - Bug report

Post by htilburgs » Monday 04 December 2017 10:37

aiolos wrote:
Saturday 02 December 2017 20:11
Yes, a PR is waiting to be merged. But I'm also still wondering what Edge version also causes this problem.
Aiolos, first thanx for the fix. It works like a charm again.
I'm using a Microsoft Surface RT Windows 8.1. I'm not sure it's EDGE that is installed. Maybe it's just an other way to show IE11 on the Windows 8.1 way.
I've been searching, but cannot find any version information.
Hardware:
RPi3 - Aeon Labs Z-Stick GEN5 - Fibaro Dimmer 2 - Fibaro Roller Shutter 2 - Fibaro Smoke Sensor - Yeelight RGBW Led bulb - Yeelight Smart LED Light Strip - Neo Coolcam PIR Motion Sensor - Neo Coolcam PowerPlug - Nest Thermostat v3

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests