Domoboard - Bug reports

Domoboard is a dashboard for Domoticz based on Python Flask.

Moderator: wez3

Forum rules
Before posting here, make sure you are using the latest Beta or Stable version.

In order to fix issues or add features these have to be reported on the Domoboard Github pages.
This makes it possible to keep track of issues/features on a centralized place.

Refer to the issue of the github tracker when possible.

This subforum is meant to discuss issues and/or feature requests, or anything else related to Domoboard.
wez3
Posts: 50
Joined: Friday 30 December 2016 13:54
Target OS: Raspberry Pi
Domoticz version:
Contact:

Domoboard - Bug reports

Post by wez3 » Friday 20 January 2017 23:43

Hi,

This topic is used to discuss bug reports.In order to fix issues or add features these have to be reported on one of the the Domoboard Github pages:
https://github.com/wez3/domoboard
https://github.com/wez3/domoboard-plugins

This makes it possible to keep track of issues/features on a centralized place.

wez3

RFAH
Posts: 20
Joined: Monday 16 March 2015 12:10
Target OS: Raspberry Pi
Domoticz version: 3.6395
Location: Netherlands
Contact:

Re: Domoboard - Bug reports

Post by RFAH » Sunday 22 January 2017 15:03

Hello,

I have created a group in Domoticz which switch on or off all lights in the living room.
(The group exists of On/off switches and dimmers)
If one of the lights is on, Domoticz shows the term "mixed".
If all lights are off, Domoticz shows the term "Off"
And if all the lights are on, Domoticz shows the term "On".

But when i create a top_tile in Domoboard of that group, the group always shows a percentage.
(No matter what the status is in Domoticz.) I did expect the values On, Off and Mixed, like Domoticz does.
Is this a bug or the expected behaviour?

Kind regards,
René

(and thanks for creating Domoboard)

squandor
Posts: 200
Joined: Saturday 19 December 2015 23:34
Target OS: Raspberry Pi
Domoticz version: 3.5837
Contact:

Re: Domoboard - Bug reports

Post by squandor » Sunday 22 January 2017 16:28

Could you try to use the Status key in the config:

Code: Select all

Counter Woonkamer = 145, icon, Status

RFAH
Posts: 20
Joined: Monday 16 March 2015 12:10
Target OS: Raspberry Pi
Domoticz version: 3.6395
Location: Netherlands
Contact:

Re: Domoboard - Bug reports

Post by RFAH » Sunday 22 January 2017 16:58

squandor,

I changed my config accoording to your advice, but no luck.
The icon is added to the tile and i see the text Status for a brief moment, but than i see the percentage again.
a part of my config looks like:

Code: Select all

    [[[Verlichting]]]
      Woonkamer Verlichting = 118
      Woonkamer verlichting group = 1, info, Status
It is part of my top_tiles[Verlichting] section
I also tried status with no captital, but that didn't do the trick.

Thanks in advance,
René

squandor
Posts: 200
Joined: Saturday 19 December 2015 23:34
Target OS: Raspberry Pi
Domoticz version: 3.5837
Contact:

Re: Domoboard - Bug reports

Post by squandor » Sunday 22 January 2017 17:08

ah now i see.
The problem is that Scenes and Groups have different idx's so the value that you get is from the idx which corresponds with an device idx.

I will add it to the issues on GitHub because we don't support this feature in the top tiles right now.

RFAH
Posts: 20
Joined: Monday 16 March 2015 12:10
Target OS: Raspberry Pi
Domoticz version: 3.6395
Location: Netherlands
Contact:

Re: Domoboard - Bug reports

Post by RFAH » Sunday 22 January 2017 17:14

squandor,

Thanks for your help.
The percentage is indeed of an another idx.
Unfortunally i can not code, but if it needs to be tested i will be happy to do so.

Thanks again,
René

Snowtiger
Posts: 83
Joined: Tuesday 18 October 2016 13:15
Target OS: Raspberry Pi
Domoticz version: 3.8363
Contact:

Re: Domoboard - Bug reports

Post by Snowtiger » Monday 23 January 2017 18:45

The Wunderground, Condition is loading and gives an image, only the max and min values of temperature are always equal to the current temperature, maybe wrong vars selected ;)

squandor
Posts: 200
Joined: Saturday 19 December 2015 23:34
Target OS: Raspberry Pi
Domoticz version: 3.5837
Contact:

Re: Domoboard - Bug reports

Post by squandor » Monday 23 January 2017 18:58

Snowtiger wrote:The Wunderground, Condition is loading and gives an image, only the max and min values of temperature are always equal to the current temperature, maybe wrong vars selected ;)
Hmm could be an problem indeed ;) i will check it later in the evening

jaccov
Posts: 15
Joined: Saturday 22 February 2014 12:01
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Domoboard - Bug reports

Post by jaccov » Saturday 29 July 2017 9:38

Problem with afvalwijzer plugin.

I installed the afvalwijzer plugin, Domoboard doesn't start anymore
Error occured during loading imports for the plugin afvalwijzer: No module named BeautifulSoup. Install it with 'easy_install BeautifulSoup' or 'pip install BeautifulSoup'
I installed BeautifulSoup by
[email protected]:~/domoboard $ sudo easy_install BeautifulSoup
Searching for BeautifulSoup
Best match: BeautifulSoup 3.2.1
Processing BeautifulSoup-3.2.1-py2.7.egg
BeautifulSoup 3.2.1 is already the active version in easy-install.pth

Using /usr/local/lib/python2.7/dist-packages/BeautifulSoup-3.2.1-py2.7.egg
Processing dependencies for BeautifulSoup
Finished processing dependencies for BeautifulSoup
Now I start Domoboard, but still have the same problem, what is wrong.
Last edited by jaccov on Saturday 29 July 2017 9:40, edited 1 time in total.

squandor
Posts: 200
Joined: Saturday 19 December 2015 23:34
Target OS: Raspberry Pi
Domoticz version: 3.5837
Contact:

Re: Domoboard - Bug reports

Post by squandor » Saturday 29 July 2017 9:40

Did you start domoboard usong virtualenv by any chance?


Sent from my iPhone using Tapatalk

jaccov
Posts: 15
Joined: Saturday 22 February 2014 12:01
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Domoboard - Bug reports

Post by jaccov » Saturday 29 July 2017 9:44

Thanks for the replay, but not familiar with virtualenv, how should i do that?

squandor
Posts: 200
Joined: Saturday 19 December 2015 23:34
Target OS: Raspberry Pi
Domoticz version: 3.5837
Contact:

Re: Domoboard - Bug reports

Post by squandor » Saturday 29 July 2017 9:47

Well in that case how did you install domoboard? Did you use the bash install?


Sent from my iPhone using Tapatalk

squandor
Posts: 200
Joined: Saturday 19 December 2015 23:34
Target OS: Raspberry Pi
Domoticz version: 3.5837
Contact:

Re: Domoboard - Bug reports

Post by squandor » Saturday 29 July 2017 9:48

Or do you have an bin folder in you're domoboard folder?


Sent from my iPhone using Tapatalk

jaccov
Posts: 15
Joined: Saturday 22 February 2014 12:01
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Domoboard - Bug reports

Post by jaccov » Saturday 29 July 2017 9:52

sudo curl -L https://www.domoboard.nl/install | bash


yes I have the bin directory
Last edited by jaccov on Saturday 29 July 2017 9:53, edited 1 time in total.

squandor
Posts: 200
Joined: Saturday 19 December 2015 23:34
Target OS: Raspberry Pi
Domoticz version: 3.5837
Contact:

Re: Domoboard - Bug reports

Post by squandor » Saturday 29 July 2017 9:53

Than you should install the beautifulsoup module using the command bin/pip install BeautifulSoup


Sent from my iPhone using Tapatalk

squandor
Posts: 200
Joined: Saturday 19 December 2015 23:34
Target OS: Raspberry Pi
Domoticz version: 3.5837
Contact:

Re: Domoboard - Bug reports

Post by squandor » Saturday 29 July 2017 9:55

You are using an virtualenv which means that domoboard is running in an python environment in that folder and not of the os itself. So every time when you want to install an module you must use the pip version of you're environment which can be found in the bin folder


Sent from my iPhone using Tapatalk

jaccov
Posts: 15
Joined: Saturday 22 February 2014 12:01
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Domoboard - Bug reports

Post by jaccov » Saturday 29 July 2017 9:57

[email protected]:~/domoboard/bin $ sudo pip install BeautifulSoup
Requirement already satisfied (use --upgrade to upgrade): BeautifulSoup in /usr/local/lib/python2.7/dist-packages/BeautifulSoup-3.2.1-py2.7.egg
Cleaning up...

Still not running, I did't try it with virtualenv..yet

squandor
Posts: 200
Joined: Saturday 19 December 2015 23:34
Target OS: Raspberry Pi
Domoticz version: 3.5837
Contact:

Re: Domoboard - Bug reports

Post by squandor » Saturday 29 July 2017 9:59

And if you try you're command with --upgrade?


Sent from my iPhone using Tapatalk

jaccov
Posts: 15
Joined: Saturday 22 February 2014 12:01
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Domoboard - Bug reports

Post by jaccov » Saturday 29 July 2017 10:02

[email protected]:~/domoboard/bin $ sudo pip install BeautifulSoup
Requirement already satisfied (use --upgrade to upgrade): BeautifulSoup in /usr/local/lib/python2.7/dist-packages/BeautifulSoup-3.2.1-py2.7.egg
Cleaning up...
[email protected]:~/domoboard/bin $ sudo pip install BeautifulSoup --upgrade
Requirement already up-to-date: BeautifulSoup in /usr/local/lib/python2.7/dist-packages/BeautifulSoup-3.2.1-py2.7.egg
Cleaning up...

the same

squandor
Posts: 200
Joined: Saturday 19 December 2015 23:34
Target OS: Raspberry Pi
Domoticz version: 3.5837
Contact:

Re: Domoboard - Bug reports

Post by squandor » Saturday 29 July 2017 10:03

And how do you start domoboard and what does it says exactly


Sent from my iPhone using Tapatalk

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest