Broadlink plugin: Connection error

Python and python framework
Post Reply
icemountant
Posts: 4
Joined: Tuesday 22 August 2017 10:52
Target OS: Raspberry Pi
Domoticz version:
Contact:

Broadlink plugin: Connection error

Post by icemountant » Sunday 27 August 2017 14:13

Hi there,
I have create my home automation via domoticz + Broadlink python plugin + Home bridge + Broadlink RM Pro 2 for a month.
In the past month, everything works great. Many thanks to mob41 and zak45, who really did a great job to help users to save a lot of time to implement broadlink SDK.

I create my switches by importing the setting from e-Control and modify commands to make domoticz sends code via python command.

However, in some how, my system, sometimes, will get disconnect with the RM Pro.
The error message in domoticz event log shows: Error Connecting to Broadlink device....
I tried to get more specific error part from the file, plugin.py, and find out the error occur bu line: 497: device.auth().

I have no idea how to get more further to find out the exactly error cause.
What I did to solve the problem is restart the domoticz service and reboot my RM Pro device by plug out the power.
Hope anyone can share your similiar experience and letś make it more powerful, thank you.

zak45
Posts: 273
Joined: Sunday 22 January 2017 12:37
Target OS: Windows
Domoticz version: V3.8153
Contact:

Re: Broadlink plugin: Connection error

Post by zak45 » Monday 28 August 2017 12:50

icemountant wrote:
Sunday 27 August 2017 14:13
Hi there,
I have create my home automation via domoticz + Broadlink python plugin + Home bridge + Broadlink RM Pro 2 for a month.
In the past month, everything works great. Many thanks to mob41 and zak45, who really did a great job to help users to save a lot of time to implement broadlink SDK.

I create my switches by importing the setting from e-Control and modify commands to make domoticz sends code via python command.

However, in some how, my system, sometimes, will get disconnect with the RM Pro.
The error message in domoticz event log shows: Error Connecting to Broadlink device....
I tried to get more specific error part from the file, plugin.py, and find out the error occur bu line: 497: device.auth().

I have no idea how to get more further to find out the exactly error cause.
What I did to solve the problem is restart the domoticz service and reboot my RM Pro device by plug out the power.
Hope anyone can share your similiar experience and letś make it more powerful, thank you.
This could happend, mainly network pb... but if you need to reboot to have it working again... not normal.
I know new broadlink firmware has been release.. if you do not have it, maybe give it a try.

icemountant
Posts: 4
Joined: Tuesday 22 August 2017 10:52
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Broadlink plugin: Connection error

Post by icemountant » Saturday 02 September 2017 3:44

Hello Zak45,

Thanks for your reply.
May I confirm the firmware you mention is for the Broadlink plugin or ?
My plugin has updated to V3 and the broad link SDK version is 0.5, is this what you mean?

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests