Blockly script execution

Post Reply
Padster
Posts: 21
Joined: Friday 26 May 2017 20:25
Target OS: Raspberry Pi
Domoticz version:
Contact:

Blockly script execution

Post by Padster » Tuesday 04 July 2017 13:34

Hi,

I've noticed if I add a script or edit a script it doesn't run straight away. It can take a while sometimes over an hour for the script to appear to work.

Any Ideas?

pvm
Posts: 920
Joined: Tuesday 17 June 2014 22:14
Target OS: NAS (Synology & others)
Domoticz version: Stable
Location: NL
Contact:

Re: Blockly script execution

Post by pvm » Tuesday 04 July 2017 21:52

What script type did you create? (All/Device/Security/...)
Are the events as configured in the IF condition changed? That would be the trigger for the Blockly .

(I do not experience the delay you mention)
Synology NAS, PI3, ZWave, Xiamo zigbee devices, BTLE plant sensor

Padster
Posts: 21
Joined: Friday 26 May 2017 20:25
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Blockly script execution

Post by Padster » Wednesday 05 July 2017 12:57

Hi,

The scripts are configured as 'ALL' type.

The edits are made within the IF conditions. For example in the below Blockly the test for the livingroom lights device being off was originally a test against a user variable. When I made the change it was as if the script wasn't running and then eventually it starts to work.
LRL.JPG
LRL.JPG (68.38 KiB) Viewed 582 times
I have seen it where I make a change and all scripts stop working for a while.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest