Traffic with waze in Domoticz

DomoHouse
Posts: 7
Joined: Thursday 03 November 2016 12:53
Target OS: Raspberry Pi
Domoticz version: beta
Location: Netherlands
Contact:

Re: Traffic with waze in Domoticz

Post by DomoHouse » Friday 28 July 2017 17:52

Yes, I have got exactly the same issue. Not sure whether Waze is blocking my IP address or that they have disallowed the usage of this feature :(

MarceldeJongNL
Posts: 41
Joined: Tuesday 03 May 2016 10:07
Target OS: Raspberry Pi
Domoticz version: 3.5108
Location: Barendrecht
Contact:

Re: Traffic with waze in Domoticz

Post by MarceldeJongNL » Thursday 10 August 2017 9:34

DomoHouse wrote:
Friday 28 July 2017 17:52
Yes, I have got exactly the same issue. Not sure whether Waze is blocking my IP address or that they have disallowed the usage of this feature :(
Just found out they made an extra check for the ""api""

I fixed my problem with information from here

You have to fake the referer url. I changed the row:

Code: Select all

local waze=assert(io.popen('curl  "https://www.waze.com/r...".')

to:

Code: Select all

local waze=assert(io.popen('curl --referer https://www.waze.com "https://www.waze.com/r...."')
And all is fine again
Hardware: Raspberry Pi 2B | RFXCOM RFXtrx433E v1 | Synology DS213+ | KaKu Clones | Conrad RSL switches | KAKu Doorbell Clone | USB Webcam | ICY Thermostat | Resol DL2 | Imatic Relay Board | Eminent 6230 | Eminent 6220 | iMatic 16 ports Relay Board

Podarcis
Posts: 5
Joined: Sunday 26 April 2015 18:05
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Traffic with waze in Domoticz

Post by Podarcis » Thursday 10 August 2017 13:58

+1! Great find. Now my lua script is working again!

Thanks!

pimseb
Posts: 1
Joined: Wednesday 13 September 2017 13:51
Target OS: -
Domoticz version:
Contact:

Re: Traffic with waze in Domoticz

Post by pimseb » Wednesday 13 September 2017 13:53

Hello,

I'm sorry I've followed the howto of lemassykoi but I'm getting this error :

2017-09-13 13:42:30.717 LUA: >> Monitoring Traveltimes
2017-09-13 13:42:30.718 LUA: >> Debug is set to: Y
2017-09-13 13:42:30.718 LUA: >> Update timeout: 600
2017-09-13 13:42:30.718 LUA: >> Lastupdate Home to Work : 5934
2017-09-13 13:42:30.718 LUA: >> Lastupdate Work to Home : 5922
2017-09-13 13:42:31.033 LUA: ========================================================================================================
2017-09-13 13:42:31.033 LUA: { "error" : "Internal Error"}
2017-09-13 13:42:31.033 LUA: ========================================================================================================
2017-09-13 13:42:31.034 Error: EventSystem: in script_time_Waze.lua: [string "-- script_time_Waze.lua..."]:99: attempt to index field 'response' (a nil value)

EDIT :

I changed the value work to home to their french translations and forgot to change the value in the script

JuanUil
Posts: 243
Joined: Friday 22 May 2015 12:21
Target OS: Raspberry Pi
Domoticz version: 2.xx
Location: Asten NB Nederland
Contact:

Re: Traffic with waze in Domoticz

Post by JuanUil » Wednesday 13 September 2017 17:10

great adonn
Your mind is like a parachute,
It only works when it is opened!

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests