Upgrade LUA 5.1 ==> 5.3

Post Reply
User avatar
emme
Posts: 798
Joined: Monday 27 June 2016 11:02
Target OS: Raspberry Pi
Domoticz version: latest
Location: Milano, Italy
Contact:

Upgrade LUA 5.1 ==> 5.3

Post by emme » Wednesday 17 January 2018 11:55

Ciao,

on a PI based system is it possibile to upgrade LUA from actual 5.1 to 5.3?

The main reason of this is the posibility to use the UTF8 support now included in LUA...
I'v seen that the upgrade procedure is quite simple: install and symlink the executible as /usr/bin/lua but is this enogh for Domoticz or does it need to be recompiled?

ciao
M
That's one small step for a programmer, one giant leap for me!
- - - - -
Raspberry Pi3 + AeonStick G5 + RFXCOMM433 + iRTrans Server + NodeJS
There's no stress in the mess!!

User avatar
Siewert308SW
Posts: 598
Joined: Monday 29 December 2014 16:47
Target OS: Raspberry Pi
Domoticz version: Beta
Location: The Netherlands - Zoutkamp (gn)
Contact:

Re: Upgrade LUA 5.1 ==> 5.3

Post by Siewert308SW » Wednesday 17 January 2018 12:14

Doesn't work that way.
Domoticz needs to be recompiled, Domoticz uses a compiled Lua version internally.
At the moment we are testing if Lua 5.3 is compatible.
https://github.com/domoticz/domoticz/pull/2061
Setup:
- RPi3 - PIco HV3.0A / Domo Beta 3.9XXX / RFXtrx433E / Aeotec Gen5
- RPi3 - PIco HV3.0A / PiHole / PiVPN / NAS / Print Server
- Youless Elec&Gas
- FI9803P Cams
- KD101 detectors
- Zwave & KaKu

MyDomoticz scripts: @GitHub
PIco UPS Toolkit: @GitHub

User avatar
emme
Posts: 798
Joined: Monday 27 June 2016 11:02
Target OS: Raspberry Pi
Domoticz version: latest
Location: Milano, Italy
Contact:

Re: Upgrade LUA 5.1 ==> 5.3

Post by emme » Wednesday 17 January 2018 12:14

thank you!
That's one small step for a programmer, one giant leap for me!
- - - - -
Raspberry Pi3 + AeonStick G5 + RFXCOMM433 + iRTrans Server + NodeJS
There's no stress in the mess!!

User avatar
Siewert308SW
Posts: 598
Joined: Monday 29 December 2014 16:47
Target OS: Raspberry Pi
Domoticz version: Beta
Location: The Netherlands - Zoutkamp (gn)
Contact:

Re: Upgrade LUA 5.1 ==> 5.3

Post by Siewert308SW » Wednesday 17 January 2018 12:16

btw:
Doesn't mean it will be implanted or not.
Two years ago Gizmocuz also tried to update Lua but there where major complications.
Setup:
- RPi3 - PIco HV3.0A / Domo Beta 3.9XXX / RFXtrx433E / Aeotec Gen5
- RPi3 - PIco HV3.0A / PiHole / PiVPN / NAS / Print Server
- Youless Elec&Gas
- FI9803P Cams
- KD101 detectors
- Zwave & KaKu

MyDomoticz scripts: @GitHub
PIco UPS Toolkit: @GitHub

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests