enable/disable thermostat timers

Post Reply
jimicek
Posts: 5
Joined: Monday 09 October 2017 9:35
Target OS: NAS (Synology & others)
Domoticz version:
Contact:

enable/disable thermostat timers

Post by jimicek » Thursday 11 January 2018 12:53

Tried to disable timers via script - this goes well using /json.htm?type=command&param=disabletimer&idx=timerID
However this doesnot work for thermostat timers. What command modification is needed?
From following timers listing is clear, that thermostats have own timerIDs and the command should somehow mark, that dealing with thermostat timers and not standard switch timers

Code: Select all

result	
0	
Active	"true"
Date	""
Days	128
DevName	"Cirkulace"
DeviceRowID	113
Hue	0
IsThermostat	"false"
Level	100
MDay	0
Month	0
Occurence	0
Randomness	"false"
ScheduleDate	"2018-01-12 07:30:00"
Time	"07:30"
TimerCmd	0
TimerID	1
TimerType	2
TimerTypeStr	"On Time"
Type	"Device"
1	{…}
2	
Active	"true"
Date	""
Days	128
DevName	"Nastaveni Hostovsky Ventil"
DeviceRowID	107
IsThermostat	"true"
MDay	0
Month	0
Occurence	0
ScheduleDate	"2018-01-12 07:25:00"
Temperature	"22.5"
Time	"07:25"
TimerID	1
TimerType	2
TimerTypeStr	"On Time"
Type	"Device"
3	{…}
status	"OK"
title	"Schedules"

jimicek
Posts: 5
Joined: Monday 09 October 2017 9:35
Target OS: NAS (Synology & others)
Domoticz version:
Contact:

Re: enable/disable thermostat timers

Post by jimicek » Thursday 11 January 2018 15:24

answering myself : following command makes the needed timer modification for termostat:

/json.htm?type=command&param=enablesetpointtimer&idx=SetpointTimerIDX

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests