2xDS18b20 GPIO Raspberry PI whith similar numbers

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
Ljasteran
Posts: 6
Joined: Sunday 04 November 2018 23:27
Target OS: Raspberry Pi
Domoticz version:
Contact:

2xDS18b20 GPIO Raspberry PI whith similar numbers

Post by Ljasteran » Tuesday 13 November 2018 5:55

Version: 4.10198
Platform: Raspbian
Hardware: 2xDS18B20

I conected 2xDS18b20 to 4GPIO Raspberry PI.
pi@raspberrypi:~ $ ls /sys/bus/w1/devices/
28-119995116461 28-3b7882116461 w1_bus_master1
Hardware:
hrdwr.png
hrdwr.png (50.44 KiB) Viewed 63 times
Devices:
dev.png
dev.png (38.06 KiB) Viewed 63 times
It is only one DS18b20.
pi@raspberrypi:~ $ cat /sys/bus/w1/devices/28-*/w1_slave
5d 01 ff ff 7f ff ff ff 97 : crc=97 YES
5d 01 ff ff 7f ff ff ff 97 t=21812
5c 01 ff ff 7f ff ff ff d4 : crc=d4 YES
5c 01 ff ff 7f ff ff ff d4 t=21750
@pmmisiek said:
I'm not sure but it looks like domoticz uses 2 last digit of serial number as device ID.
You have 28-119995116461 and 28-3b7882116461 so domoticz shows it as one device.
I tried another ds18b20. and it is fine.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 3 guests