DzVents kodiExecuteAddOn not working?

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
kimtieuphuong
Posts: 1
Joined: Tuesday 23 October 2018 18:08
Target OS: Raspberry Pi
Domoticz version:
Contact:

DzVents kodiExecuteAddOn not working?

Post by kimtieuphuong » Tuesday 23 October 2018 18:11

Version: 3.8714
Platform: RPI
Plugin/Hardware: Kodi
Description: Attempting to use the kodiExecuteAddOn function in DzVents to open a Kodi Addon, but not working. Other Kodi functions such as kodiPlayFavorites(1) are working fine, just kodiExecuteAddOn that is not. Using Advanced REST client Chrome addon, I can successfully trigger the Kodi addon with a HTTP POST with this data:

{"jsonrpc": "2.0","method": "Addons.ExecuteAddon","params": {"addonid": "plugin.video.iplayerwww","params": []},"id": 2}

...but calling kodiExecuteAddOn('plugin.video.iplayerwww') from dzVents script has no effect.

Have also tried using:

sendCommand('Lounge TV', 'Execute plugin.video.iplayerwww')
sendCommand('Lounge TV', 'Run plugin.video.iplayerwww')

...but nothing working.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests