Getting Fibaro FGD212 Dimmer status, Not working :-(

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
rgroothuis
Posts: 226
Joined: Friday 03 April 2015 17:09
Target OS: Raspberry Pi
Domoticz version:
Contact:

Getting Fibaro FGD212 Dimmer status, Not working :-(

Post by rgroothuis » Thursday 20 September 2018 22:04

Domoticz runs on a Raspberry 3B with the ZWave USB stick. Aeotec Z-Stick Gen5 with Firmware Version: 1.4-3155-ga27c2645-dirty.
Domoticz V4.9999, Build Hash: 9e8ea729, Build Date: 2018-09-09 18:27:57! Fibaro FGD212 dimmer

In the Lua script I use the following (for debugging purposes):

print('---- 1stFloorLight: ' .. otherdevices['HallWay1stFloorLamp'])

In the Domoticz debug window I get the following:

2018-09-20 21:58:49.936 Status: LUA: ---- 1stFloorLight: Set Level: 90 %

The bold/underlined part is the part I'm surprised about. My expectation is get the value On (if the light is on).

When the light is Off I do get "Off"

When using otherdevices_svalues['HallWay1stFloorLamp'] to get the svalue I do get 90, this is according to my expectation.

What is wrong? Is it me or is it the system in combination with the Fibaro dimmer?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest