Custom icon uploaded not working with latest beta releases

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
Jem101
Posts: 95
Joined: Saturday 02 May 2015 21:26
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bexleyheath, SE London, UK
Contact:

Custom icon uploaded not working with latest beta releases

Post by Jem101 » Tuesday 26 June 2018 22:56

Can anyone else check and confirm that the custom icon upload feature is broken with the latest beta (and I'm guessing the new stable release version)?

I can prepare the zip file containing the icon files, go to the option in Domoticz, select the file, press the upload button and nothing happens. No error message but the icons never get updated.

I've made sure that caches are cleared, I've tried with three different browsers and also, (just in case), two different themes but with the same result.

Is it just me or is the feature really broken for others as well?
I firmly believe in having an open mind - although not so open that your brain falls out!

- sometimes attributed to Carl Sagan, but the original quote is much older than that

User avatar
waaren
Posts: 1226
Joined: Tuesday 03 January 2017 15:18
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Custom icon uploaded not working with latest beta releases

Post by waaren » Tuesday 26 June 2018 23:09

Jem101 wrote:
Tuesday 26 June 2018 22:56
Can anyone else check and confirm that the custom icon upload feature is broken with the latest beta (and I'm guessing the new stable release version)?
Did you have a look here and checked if it is the same issue ?
Raspberry (debian stretch via berryboot on Synology DS916+) , Domoticz (almost) latest Beta, , dzVents 2.6, RFLink, RFXtrx433e, P1, Youless, Harmony, Hue, Yeelight, Xiaomi, HomeWizard, Zwave, Amazon echo

Jem101
Posts: 95
Joined: Saturday 02 May 2015 21:26
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bexleyheath, SE London, UK
Contact:

Re: Custom icon uploaded not working with latest beta releases

Post by Jem101 » Wednesday 27 June 2018 11:49

I did see that post, yes but in my case although the symptoms are very similar, refreshing the screen (even clearing down all the caches( and reloading doesn't show the new icon.
I firmly believe in having an open mind - although not so open that your brain falls out!

- sometimes attributed to Carl Sagan, but the original quote is much older than that

biggav
Posts: 12
Joined: Wednesday 02 August 2017 5:40
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Custom icon uploaded not working with latest beta releases

Post by biggav » Thursday 28 June 2018 8:48

I have just upgraded to 4.9723 and cant upload anymore either. This is the massage i get from the chrome console. Any ideas?
Custom Icon.JPG
Custom Icon.JPG (31.92 KiB) Viewed 416 times

biggav
Posts: 12
Joined: Wednesday 02 August 2017 5:40
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Custom icon uploaded not working with latest beta releases

Post by biggav » Friday 29 June 2018 8:57

it now appears to be working however i still get the errors in the console

Jem101
Posts: 95
Joined: Saturday 02 May 2015 21:26
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bexleyheath, SE London, UK
Contact:

Re: Custom icon uploaded not working with latest beta releases

Post by Jem101 » Friday 29 June 2018 9:18

Still doesn't seem to be working for me though. Still the errors in the javascript console and nothing actually gets uploaded when the button is pushed.
I firmly believe in having an open mind - although not so open that your brain falls out!

- sometimes attributed to Carl Sagan, but the original quote is much older than that

Gianni
Posts: 70
Joined: Saturday 21 July 2018 19:03
Target OS: Raspberry Pi
Domoticz version:
Location: Home@Belgium
Contact:

Re: Custom icon uploaded not working with latest beta releases

Post by Gianni » Wednesday 05 September 2018 10:17

create a icon and try to upload

Same error

Code: Select all

angular.min.js:124 TypeError: $http.post(...).success is not a function
    at m.$scope.uploadFileToUrl (CustomIconsController.js:14)
    at m.$scope.UploadIconSet (CustomIconsController.js:34)
    at fn (eval at compile (angular.min.js:242), <anonymous>:4:159)
    at e (angular.min.js:288)
    at m.$eval (angular.min.js:151)
    at m.$apply (angular.min.js:151)
    at HTMLButtonElement.<anonymous> (angular.min.js:288)
    at HTMLButtonElement.dispatch (jquery-3.3.1.min.js:2)
    at HTMLButtonElement.y.handle (jquery-3.3.1.min.js:2)
try a icon from the wiki page and that's works well.
So the question is what's the different.
I used a wiki icon and edit the png files and create a new zip.
Thats all but not working.
Attachments
Ap.zip
(7.85 KiB) Downloaded 9 times

jandirkv
Posts: 24
Joined: Monday 19 February 2018 7:20
Target OS: Raspberry Pi
Domoticz version: 3.9117
Contact:

Re: Custom icon uploaded not working with latest beta releases

Post by jandirkv » Sunday 30 September 2018 10:48

Hi,

I do not upload new icons, I just transfer them to
~/home/pi/domoticz/www/images
and manually change the
switch_icons.txt
through SSH. I add a Line at the bottom of the list with the name of the iconset without the '48_On' extension save it, restart and the custom icon is selectable.

with this Command you can alter the switch file:

Code: Select all

sudo nano domoticz/www/switch_icons.txt
I'm also experimenting with the resolution and maximum size of my icons. Haven't figured out what the maximum resolution and size is for Domoticz.

digitallez
Posts: 8
Joined: Thursday 21 June 2018 9:24
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Custom icon uploaded not working with latest beta releases

Post by digitallez » Friday 26 October 2018 10:23


Post Reply

Who is online

Users browsing this forum: bewo and 5 guests