There is no device with that name or id for not used devices

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
medo
Posts: 1
Joined: Thursday 14 June 2018 22:02
Target OS: Raspberry Pi
Domoticz version:
Contact:

There is no device with that name or id for not used devices

Post by medo » Friday 15 June 2018 14:29

Version: 3.9634 beta
Platform: raspberry Pi 3 Model B
Plugin/Hardware: fibaro double relayswitch
Description:

I have a fibaro double relayswitch wich is used to open and close Blinds.
switchOn() relay one opens the blinds, the blinds only need a pulse so the relay switches off after 0,4 sec.
switchOn() relay two closes the blinds, the blinds only need a pulse so the relay switches off after 0,4 sec.

this works but I have two devices for one real device (the blinds) also there is no status whether the blinds are open or closed after 0.4 sec all relay devices are off.

I solved this with a virtual blinds device, now I open and close the virtual blinds and the code does the rest, this works.
On the Switches Page I now have 3 devices

1.Blinds
2. RElayswitchOpen
3. RElayswitchClose

When I remove the relay switches from the switches page, and thus make them not used devices, it does not work.
In the logs I see: "There is no device with that name or id: RElayswitchOpen"

When I add them back to used devices it works again.

I'm not sure but I think this used to work in the release version.
I have 4 Blinds so 12 devices
What I would want is to be able to switch on/off unused devices
Or to be able to hide devices from the "switches" list, I now have 8 unused ones in an already cluttered switches page

(also in the mobile iphone domoticz app I cant filter on room so every device I can remove helps)

User avatar
jvdz
Posts: 1344
Joined: Tuesday 30 December 2014 20:25
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Westland/Netherlands
Contact:

Re: There is no device with that name or id for not used devices

Post by jvdz » Sunday 17 June 2018 9:52

There has to be a device for the event system to trigger. This was indeed different in past versions where the eventsystem would trigger for each known device.

Not sure what happens in the eventsystem when you put a $ Infront of the device name an snake it hidden.

Jos

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 6 guests