How to enable https in Domoticz

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
keithclean
Posts: 4
Joined: Monday 19 February 2018 13:50
Target OS: Raspberry Pi
Domoticz version:
Contact:

How to enable https in Domoticz

Post by keithclean » Thursday 22 February 2018 19:15

Hi Guys,

Yesterday I've bought an raspberry pi 3 and installed domoticz on it. I got domoticz working via HTTP, but I just can't seem to get HTTPS working even from within my local network. I've typed in 'https://ipadresMyraspberrypi3:443' in my browser.

After that I get the following message:
This site is not accessible
000.000.0.00 refused the connection. '000.000.0.00' of course isn't the real ip address of my raspberry pi 3 ;)

I've searched through the forum but there isn't a clear answer on how to solve this problem. I hope somebody can explain in a simple way how to connect to domoticz via HTTPS.

SweetPants
Posts: 2350
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.10213
Location: The Netherlands
Contact:

Re: How to enable https in Domoticz

Post by SweetPants » Thursday 22 February 2018 22:02

Start domoticz with parameter "-sslwww 443", see domoticz.sh in your domoticz directory.
Ubuntu 16.04.5 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

dextm80
Posts: 102
Joined: Tuesday 24 October 2017 18:32
Target OS: Linux
Domoticz version: 4.10159
Contact:

Re: How to enable https in Domoticz

Post by dextm80 » Thursday 22 February 2018 22:50

Use CERTBOT
Domoticz on AsRock j3455-ITX 8gb ram - Aeotec ZWave Usb Stick - RFLink 433Mhz
1x Fibaro Wall Plug
1x Fibaro Motion Sensor
2x NeoCoolcam Wall Plug
Netatmo Weather Station - Netatmo Thermostat
Philips Hue Bridge

maomanna
Posts: 108
Joined: Monday 30 November 2015 17:21
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: How to enable https in Domoticz

Post by maomanna » Friday 23 February 2018 10:29

i have the same problem. it seems like is has something to do with the libssl1.0.0.

when go to the https page it is very slow and its not loaded correctly.

salvacalatayud
Posts: 37
Joined: Monday 26 June 2017 21:16
Target OS: Raspberry Pi
Domoticz version: 3.8072
Location: Spain
Contact:

Re: How to enable https in Domoticz

Post by salvacalatayud » Thursday 21 June 2018 14:33

Same problem here

Enviado desde mi Redmi 4X mediante Tapatalk


niki_lauda
Posts: 141
Joined: Saturday 31 August 2013 14:48
Target OS: Raspberry Pi
Domoticz version: beta
Location: Eindhoven (NL)
Contact:

Re: How to enable https in Domoticz

Post by niki_lauda » Thursday 21 June 2018 20:03

salvacalatayud wrote:
Thursday 21 June 2018 14:33
Same problem here

Enviado desde mi Redmi 4X mediante Tapatalk
Try this viewtopic.php?f=47&t=23772&hilit=libssl1.0.0

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests