Unable to enable Dzvents in Setup->Settings->Other

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
julianmclean
Posts: 19
Joined: Wednesday 08 October 2014 21:52
Target OS: Raspberry Pi
Domoticz version:
Contact:

Unable to enable Dzvents in Setup->Settings->Other

Post by julianmclean » Friday 10 November 2017 0:25

Version: 3.8714
Platform: RPI
Plugin/Hardware: n/a
Description: When attempting to set the DzVents Disabled toggle OFF (so that it is enabled), the setting does not "stick" when hitting "Apply Settings", and when going back in the UI, the toggle is ON again. Haven't been able to make it stick from the UI, requiring a data hack in SQLite to sort it out!

SweetPants
Posts: 2255
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.10007
Location: The Netherlands
Contact:

Re: Unable to enable Dzvents in Setup->Settings->Other

Post by SweetPants » Friday 10 November 2017 20:12

Cannot confirm this on V3.8717. What Theme do you use?
Ubuntu 16.04.3 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

Nautilus
Posts: 771
Joined: Friday 02 October 2015 12:12
Target OS: Raspberry Pi
Domoticz version: beta
Location: Finland
Contact:

Re: Unable to enable Dzvents in Setup->Settings->Other

Post by Nautilus » Tuesday 14 November 2017 14:18

I faced the same issue today, tried with both elemental and default themes (after clearing cache and appcache). Eventually I had to modify the database to enable the event system again. I tried with a few days old beta first, then updated to 3.8734 and tried again but no luck. No errors visible in the console, it goes to Dashboard after saving the setting as it normally does, but then when I go back to respective settings tab all tick boxes related to events / dZvents are empty.
Last edited by Nautilus on Tuesday 14 November 2017 14:21, edited 1 time in total.

raymond
Posts: 92
Joined: Monday 12 October 2015 15:46
Target OS: Raspberry Pi
Domoticz version: V3.8275
Contact:

Re: Unable to enable Dzvents in Setup->Settings->Other

Post by raymond » Tuesday 14 November 2017 14:21

I've just created a new topic, Apply Settings does not work on the latest stable v3.8153 for me either.
viewtopic.php?f=6&t=20391

Similar issue

raymond
Posts: 92
Joined: Monday 12 October 2015 15:46
Target OS: Raspberry Pi
Domoticz version: V3.8275
Contact:

Re: Unable to enable Dzvents in Setup->Settings->Other

Post by raymond » Tuesday 14 November 2017 14:39

Strange, I can set another theme but going back, the Settings still reflect default as the theme. It does change though ?!?

Nautilus
Posts: 771
Joined: Friday 02 October 2015 12:12
Target OS: Raspberry Pi
Domoticz version: beta
Location: Finland
Contact:

Re: Unable to enable Dzvents in Setup->Settings->Other

Post by Nautilus » Tuesday 14 November 2017 14:51

Well yes, actually I was also able to get a check back to dZvents by changing theme / emptying appcache and cache but at that point it did not reflect the actual status anymore. So dZvents was enabled even though the box was checked for disabling it and normal event were disabled even though the box to disable them was empty. All in all, it is a bit confusing that there is first an option to disable events and then an option to enable dZvents. I think both should be either enable or disable...

jake
Posts: 440
Joined: Saturday 30 May 2015 22:40
Target OS: Raspberry Pi
Domoticz version: beta
Contact:

Re: Unable to enable Dzvents in Setup->Settings->Other

Post by jake » Tuesday 14 November 2017 19:56

I had the same. In chrome my whole settings page is also besides and below the menu buttons. I opened domoticz with the Firefox browser and both the menu alignment was normal and the dzvents setting could be used as expected.

dannybloe
Posts: 1473
Joined: Friday 29 August 2014 11:26
Target OS: Raspberry Pi
Domoticz version:
Location: Ermelo
Contact:

Re: Unable to enable Dzvents in Setup->Settings->Other

Post by dannybloe » Tuesday 14 November 2017 20:35

Nautilus wrote:
Tuesday 14 November 2017 14:51
Well yes, actually I was also able to get a check back to dZvents by changing theme / emptying appcache and cache but at that point it did not reflect the actual status anymore. So dZvents was enabled even though the box was checked for disabling it and normal event were disabled even though the box to disable them was empty. All in all, it is a bit confusing that there is first an option to disable events and then an option to enable dZvents. I think both should be either enable or disable...
Earlier the settings for enabling the lua event-system was to set the disable checkbox to false which is always hard UI-wise as this is not how people tend to think. When settings for dzVents were added I decided to make it similar to the setting for Lua (disable checkbox). At some point gizmocus correctly changed the checkbox from negative to positive and creating a migration in the database where the setting was negated as well. I also changed the setting for dzVents but only in the client (html and js code) so no migration was needed. It was just presentation. That does mean that other themes must also treat the value in a similar fashion.
Creator dzVents - RPi3, loads of zwave devices, esp8266, evohome.

julianmclean
Posts: 19
Joined: Wednesday 08 October 2014 21:52
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Unable to enable Dzvents in Setup->Settings->Other

Post by julianmclean » Tuesday 14 November 2017 22:30

Feels like something more fundamental here. I use the default theme and ANY time I Apply Settings from the UI, the dzVents "Disabled" toggled gets switched back on (and in the DB), necessitating a direct DB fix.

dannybloe
Posts: 1473
Joined: Friday 29 August 2014 11:26
Target OS: Raspberry Pi
Domoticz version:
Location: Ermelo
Contact:

Re: Unable to enable Dzvents in Setup->Settings->Other

Post by dannybloe » Tuesday 14 November 2017 23:47

If you know some javascript and how to enable the development tools in for instance Chrome, you can figure out what settings data are sent back to Domoticz when you press Apply (you need to set a breakpoint as the javascript does an immediate reload of the page). When at that breakpoint you can inspect the network tab and see the actual payload that's sent. Thing is that on all instances that I run everywhere (many tests instances) I have never been able to reproduce this problem. So, some debugging would be helpful on a system where it doesn't work.
Creator dzVents - RPi3, loads of zwave devices, esp8266, evohome.

raymond
Posts: 92
Joined: Monday 12 October 2015 15:46
Target OS: Raspberry Pi
Domoticz version: V3.8275
Contact:

Re: Unable to enable Dzvents in Setup->Settings->Other

Post by raymond » Wednesday 15 November 2017 15:21

Version: 3.8739
Platform: RPI
Plugin/Hardware: n/a

Ok so the strange thing about this altogether is that some of the settings are changed (for example Theme) but once you check back into Settings, the values reflected are not correct, or even changed back.

I moved from the latest stable to the latest Beta, which seems to improve somewhat. I could enable the Events and dzEvents by flipping the switches, and they are reflecting that value still when I return to the Settings page.

Changing for example the Counters Cost T1, it is never saved/applied and reflects the old values still.

I'm not that bright on creating the breakpoint in Chrome as asked, but it seems a good way of getting extra infos.

Ray

lrybak
Posts: 54
Joined: Thursday 18 December 2014 21:12
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Poland
Contact:

Re: Unable to enable Dzvents in Setup->Settings->Other

Post by lrybak » Tuesday 28 November 2017 11:15

dannybloe wrote:
Tuesday 14 November 2017 23:47
If you know some javascript and how to enable the development tools in for instance Chrome, you can figure out what settings data are sent back to Domoticz when you press Apply (you need to set a breakpoint as the javascript does an immediate reload of the page). When at that breakpoint you can inspect the network tab and see the actual payload that's sent. Thing is that on all instances that I run everywhere (many tests instances) I have never been able to reproduce this problem. So, some debugging would be helpful on a system where it doesn't work.
I have the same issue on lastest stable v3.8153
Once I enable dzVents in Settings and hit Save, following POST is sent
http://192.168.1.12:8080/storesettings.webem
with the POST data:
DisableDzVentsSystem on
DzVentsLogLevel 3

Once I disable in GUI and hit Save, following POST is sent:
DzVentsLogLevel 3

Seems logic is inverted. You have to disable to enable and enable to disable ;-)
HW: HP dc7900 USD running ESXi, RaspberryPi (few of it), AEON S2 USB stick, Fibaro modules (Dimmers, switches), 1-wire (DS18B20, DS2423), DSC Alarm with Envisalink ethernet module, MySensors, RFLink

Plips
Posts: 3
Joined: Thursday 28 December 2017 0:04
Target OS: Raspberry Pi
Domoticz version: V3.8153
Location: Netherlands
Contact:

Re: Unable to enable Dzvents in Setup->Settings->Other

Post by Plips » Monday 01 January 2018 12:02

dannybloe wrote:
Tuesday 14 November 2017 23:47
If you know some javascript and how to enable the development tools in for instance Chrome, you can figure out what settings data are sent back to Domoticz when you press Apply (you need to set a breakpoint as the javascript does an immediate reload of the page). When at that breakpoint you can inspect the network tab and see the actual payload that's sent. Thing is that on all instances that I run everywhere (many tests instances) I have never been able to reproduce this problem. So, some debugging would be helpful on a system where it doesn't work.
Had same problems here on Safari: theme not changed and dzvents checkbox toggled when not clicked. Not being able able to reproduce problems on Chrome, i decided to manually empty browser cache in Safari, it must have gotten corrupted somewhere. So Option-Command-E did the trick for me.
V3.8153
Raspbian GNU/Linux 8 (jessie)
Raspberry Pi3

dannybloe
Posts: 1473
Joined: Friday 29 August 2014 11:26
Target OS: Raspberry Pi
Domoticz version:
Location: Ermelo
Contact:

Re: Unable to enable Dzvents in Setup->Settings->Other

Post by dannybloe » Wednesday 03 January 2018 10:31

From what I've seen up till now with this problem is that it almost always related to caching problems. If you open the console in Chrome (F12 or alt-cmd-j) and you click and hold the reload button you do a full reload. You can also open the Application tab in the developer console and click the Clear storage on the left and then Clear site data on the bottom right. Usually that fixes the problem (you have to immediately reload the page when you do).
Creator dzVents - RPi3, loads of zwave devices, esp8266, evohome.

Timmiej93
Posts: 48
Joined: Saturday 26 December 2015 1:37
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Unable to enable Dzvents in Setup->Settings->Other

Post by Timmiej93 » Friday 05 January 2018 0:39

Version: 3.8798
Platform: RPi
Plugin/Hardware: n/a
Extra: dzVents 2.3 folder from GitHub copied over the 2.2 folder that comes with 3.8798

I'm having the same issues as described above. Changing themes etc. works fine, just the checkboxes for EventSystem and dzVents that are acting up. I'm also very confused about what the state of those should be. Since they say 'Disabled', I'm guessing they should be unchecked when I want to use them. However, they currently are both unchecked, and when I hit "Show current states" in the Event editor, I get this error message: "Error getting current states, Is the Eventsystem Enabled?". I have tried this before, and I used to get some values shown, so it used to work.
I've tried emptying the browser's cache, tried various browsers, nothing seems to work. My dzVents script also doesn't seem to function.

Something I just noticed: When I change absolutely nothing, and just hit "Apply Settings", the "Enabled" tickbox for dzVents toggles. When it was on before, it is off after I hit apply, when it was off, it's on after I hit apply.

Isn't there some way to enable the EventSystem and dzVents in a file / commandline, without using the GUI?

Update:

I just remembered we have this browser called "Edge" if you're on windows 10. For some reason, this browser apparently works. It gives me way better results in doing a hard refresh by hitting ctrl+f5 (Vivaldi, chrome based browser, and chrome both don't update the theme after hard refreshing), and also allowed me to enable both settings, and have them actually work.

TL;DR: Try the Edge browser

dannybloe
Posts: 1473
Joined: Friday 29 August 2014 11:26
Target OS: Raspberry Pi
Domoticz version:
Location: Ermelo
Contact:

Re: Unable to enable Dzvents in Setup->Settings->Other

Post by dannybloe » Friday 05 January 2018 15:32

Timmiej93 wrote:
Friday 05 January 2018 0:39
Version: 3.8798
Platform: RPi
Plugin/Hardware: n/a
Extra: dzVents 2.3 folder from GitHub copied over the 2.2 folder that comes with 3.8798
Copied over??? This is weird as the current beta already has 2.3 as part of the codebase (/path/to/domoticz/dzVents) I just checked the non-windows downloads and they come with 2.3.
Timmiej93 wrote:
Friday 05 January 2018 0:39
I'm having the same issues as described above. Changing themes etc. works fine, just the checkboxes for EventSystem and dzVents that are acting up. I'm also very confused about what the state of those should be. Since they say 'Disabled', I'm guessing they should be unchecked when I want to use them. However, they currently are both unchecked, and when I hit "Show current states" in the Event editor, I get this error message: "Error getting current states, Is the Eventsystem Enabled?". I have tried this before, and I used to get some values shown, so it used to work.
I've tried emptying the browser's cache, tried various browsers, nothing seems to work. My dzVents script also doesn't seem to function.

Something I just noticed: When I change absolutely nothing, and just hit "Apply Settings", the "Enabled" tickbox for dzVents toggles. When it was on before, it is off after I hit apply, when it was off, it's on after I hit apply.

Isn't there some way to enable the EventSystem and dzVents in a file / commandline, without using the GUI?

Update:

I just remembered we have this browser called "Edge" if you're on windows 10. For some reason, this browser apparently works. It gives me way better results in doing a hard refresh by hitting ctrl+f5 (Vivaldi, chrome based browser, and chrome both don't update the theme after hard refreshing), and also allowed me to enable both settings, and have them actually work.

TL;DR: Try the Edge browser
The thing is that in Stable (3.8153) the setting for the events where called 'disable event system' and 'disable dzVents' and ticking those settings would indeed disable the systems. But this was very confusing so in beta we made it a positive setting: 'enable events', 'enable dzVents'. And, for non-dzVents there was a migration done in the database that toggled the setting. For dzVents we didn't do this migration, we just inverted the value of the setting in the UI and when submitting the settings form, the value was inverted again. So if 'enable dzVents' was ticked in the settings form, it should be unticked in the database upon saving. So no migration was needed. That part works. Somehow though, perhaps due to incorrect themes or caches that aren't refreshed well enough, some people can't get it to work properly.

We didn't do a migration for the dzVents setting because we saw that the migration for the other setting gave people problems so we decided to just change it in the UI layer only.
Creator dzVents - RPi3, loads of zwave devices, esp8266, evohome.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests