Domoticz not starting. Domoticz.PID missing

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
User avatar
madpatrick
Posts: 49
Joined: Monday 26 December 2016 13:17
Target OS: Linux
Domoticz version: 4.9700
Location: Netherlands
Contact:

Domoticz not starting. Domoticz.PID missing

Post by madpatrick » Saturday 02 September 2017 20:43

Hi,

After a restart of my server, the domoticz app is not starting any more.

i see the following message :

Code: Select all

Sep 02 20:36:37 xxxxxxxxx.nl systemd[1]: Unit domoticz.service entered failed state.
Sep 02 20:36:37 xxxxxxxxx.nl systemd[1]: domoticz.service failed.
Sep 02 20:36:37 xxxxxxxxx.nl polkitd[710]: Unregistered Authentication Agent for unix-process:14664:4646339 (system bus name :1.1074, object path /org/fre
Sep 02 20:37:07 xxxxxxxxx.nl domoticz[14695]: 2017-09-02 20:37:07.081  Domoticz V3.8153 (c)2012-2017 GizMoCuz
Sep 02 20:37:07 xxxxxxxxx.nl domoticz[14695]: 2017-09-02 20:37:07.081  Build Hash: 494fff7, Date: 2017-08-07 20:07:56
Sep 02 20:37:07 xxxxxxxxx.nl domoticz[14695]: Domoticz is starting up....
Sep 02 20:37:07 xxxxxxxxx.nl domoticz[14695]: 2017-09-02 20:37:07.081  Startup Path: /usr/share/domoticz/
Sep 02 20:37:07 xxxxxxxxx.nl domoticz[14695]: 2017-09-02 20:37:07.081  Startup delay... waiting 0 seconds...
Sep 02 20:37:07 xxxxxxxxx.nl domoticz[14695]: domoticz: Domoticz is starting up....
Sep 02 20:37:07 xxxxxxxxx.nl domoticz[14695]: domoticz: Could not open PID lock file /var/run/domoticz/domoticz.pid, exiting
Sep 02 20:37:07 xxxxxxxxx.nl domoticz[14696]: Could not open PID lock file /var/run/domoticz/domoticz.pid, exiting
Sep 02 20:37:07 xxxxxxxxx.nl systemd[1]: domoticz.service never wrote its PID file. Failing.
Sep 02 20:37:07 xxxxxxxxx.nl systemd[1]: Failed to start Domoticz Home Automation.
-- Subject: Unit domoticz.service has failed
What can be the problem.
The only thing which has been changed, it that my Toon is not available (not yet mounted back)
Last edited by madpatrick on Saturday 02 September 2017 21:10, edited 1 time in total.
ClearOS 7.5.0 - Toon 4.15.16 (rooted) - Domoticz 4.9700

SweetPants
Posts: 2255
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.10007
Location: The Netherlands
Contact:

Re: Domoticz not starting. Domoticz.PID missing

Post by SweetPants » Saturday 02 September 2017 21:09

Can you start it manually?
BTW, if you don't like spam, don't put your email address on a public forum
Ubuntu 16.04.3 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

User avatar
madpatrick
Posts: 49
Joined: Monday 26 December 2016 13:17
Target OS: Linux
Domoticz version: 4.9700
Location: Netherlands
Contact:

Re: Domoticz not starting. Domoticz.PID missing

Post by madpatrick » Saturday 02 September 2017 21:19

SweetPants wrote:
Saturday 02 September 2017 21:09
Can you start it manually?
BTW, if you don't like spam, don't put your email address on a public forum
Manualy starting the app is working.
So must be a server issue ?

PS: thanks for the tip !!
ClearOS 7.5.0 - Toon 4.15.16 (rooted) - Domoticz 4.9700

sweetpants01
Posts: 7
Joined: Saturday 16 May 2015 22:05
Target OS: -
Domoticz version:
Contact:

Re: Domoticz not starting. Domoticz.PID missing

Post by sweetpants01 » Saturday 02 September 2017 22:33

normally the path for pid is /var/run did you change this? also look at permissons

Verstuurd vanaf mijn SM-G903F met Tapatalk


User avatar
madpatrick
Posts: 49
Joined: Monday 26 December 2016 13:17
Target OS: Linux
Domoticz version: 4.9700
Location: Netherlands
Contact:

Re: Domoticz not starting. Domoticz.PID missing

Post by madpatrick » Sunday 03 September 2017 8:39

sweetpants01 wrote:
Saturday 02 September 2017 22:33
normally the path for pid is /var/run did you change this? also look at permissons

Verstuurd vanaf mijn SM-G903F met Tapatalk
The location is correct.
It was a problem with the permissions.

Code: Select all

mkdir /var/run/domoticz
chown domoticz:domoticz /var/run/domoticz
now it is working again
ClearOS 7.5.0 - Toon 4.15.16 (rooted) - Domoticz 4.9700

SweetPants
Posts: 2255
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.10007
Location: The Netherlands
Contact:

Re: Domoticz not starting. Domoticz.PID missing

Post by SweetPants » Sunday 03 September 2017 10:38

Great, can you mark this topic closed/solved?
Ubuntu 16.04.3 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

strixx
Posts: 16
Joined: Tuesday 04 October 2016 11:21
Target OS: -
Domoticz version:
Contact:

Re: Domoticz not starting. Domoticz.PID missing

Post by strixx » Tuesday 12 December 2017 18:07

Just struggling with this my self. And this is not the solution. Not if you are running on a Ubuntu server at least.
/var/run is tmpfs by default on Ubuntu. So the folder will disappear on next reboot.

You need to add the following lines to your service to get it working:

RuntimeDirectory=domoticz
RuntimeDirectoryMode=0766

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests